Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Epson r340 not installing, worked before

06 Mar 2011   #1

WinXP, Ubuntu, Win 7
Epson r340 not installing, worked before

So I just recently installed a new SSD and installed a fresh version of win 7 64bit SP1. Everything has been great, except for now I can not install drivers/software for my Epson r340. It was installed fine on my last version of win 7 (not sp1).

I have tried epson's software install, but it usually kicks me back with "Operation could not be completed (error 0x00000003)" I have tried the normal things like run as admin, changing the compatibility prefs to both vista and xp. Turned off firewall, etc. I also tried to manually install the driver by doing a have disk and locate the drivers. FYI, this a usb printer, not a network printer so I tried a different usb port as well. It will again give me the same error as listed previously.

Interestingly it installs the Epson Stylus Storage USB device correctly (printer has a card slot) and as I said this installed perfectly on my last win7 install.

Any ideas on what else I can do or what this error is?

My System SpecsSystem Spec
06 Mar 2011   #2

Windows 10 Pro x64, Arch Linux

My System SpecsSystem Spec
06 Mar 2011   #3

WinXP, Ubuntu, Win 7

I have been using the newest version. Downloaded it today. v6.5aAs for win 7 64bit. no joy.
My System SpecsSystem Spec


 Epson r340 not installing, worked before

Thread Tools

Similar help and support threads
Thread Forum
New drive (Z:) after installing Epson on PC
Today I installed Epson printer XP400 onto my Win7 32bit laptop. The laptop prints to the XP400 via WiFi. When the printer is OFF WinExp has a "Z:MEMORYCARD (\\EPSONB9E26F)" drive. WinExp setting Hide empty drives in the Computer folder is enabled Q1: Can this drive be hidden when the...
Hardware & Devices
Trouble with installing Epson stylusSX235W,error 0x00000057
Hello, This is my first post here,and with hope one of the last. Since 2 days i have a new Epson stylus SX235W printer,and there is my problem also. I doesnt matter what i do but i cant get the printer driver to install and print anything. I have tried the following things: 1)the usuall way...
Installation & Setup
Epson Stylus NX420 Driver not found after installing
I have tried unsucessfully to install the printer driver for this Epson printer (NX420). Have spent many, many hours on phone with Epson support, emails etc. Changed security settings, turned off virus protection, used disk which was supplied, downloaded drivers from website, downloaded drivers to...
Epson cx3900 and epson scan
Hi I am hoping that some one can help solve this problem for me we have just upgraded our computer and it has windows 7 as the OS we used XP previously. The printer / scanner works fineas a printer however my problem is that the scanner part will only work with windows fax scan, I used to scan...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:35.
Twitter Facebook Google+