Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Access is denied error while installing driver

06 Mar 2011   #1

Windows 7 Home Premium 32bit
Access is denied error while installing driver

Hi all, and thanks for reading this thread - I have searched high and low for a solution but to no avail so would really appreciate any help you may be able to give.

Basically I have bought a printer (Canon p2720) and can't for the life of me install the driver. I have installed them fine on my wife's laptop but for some reason it just won't do it on the desktop. Here's what happens:

1. I normally just plug it in and Windows searches for the driver automatically - it finds, downloads and tries to install the driver but then states that an error occurred.
2. I also tried installing the driver from the software included in the CD (an option I hate because of the unnecessary software they also include) but again I get an error saying access is denied.

So I have tried the following to fix:
1. Gone to Computer Management into the device manager, found the printer (listed under 'Other Devices') and tried installing drivers this way via both the net and also the CD - both don't work claiming access is denied.
2. From searching the net it sounded like some sort of permissions issue (even though the account is an admin account) so I have tried to change the permissions of windows - system32 - spool. Currently they look like they're read only (when I right-click and go to properties the read only box is filled in). When I try to uncheck this box and click on apply it goes through a lot of them and then gets to the odd file and says "An error occurred applying the attributes to the file <lists file path> Access is denied". I've tried everything I can think of - disabling UAC, looking online and all that but with no joy. I've tried also changing the permissions of C: by unchecking the 'readonly' box but again it won't let me stating access is denied when I get to certain files (it applies to others fine)

I think I've had a permissions problem for a while because whenever I try to install something it always comes up with an error writing to config.msi et al (but when I click on retry it works) but again no idea how to fix. It's a bit of a pain because the likes of iTunes won't autoupdate or anything because it won't write to the folders.

I am pretty certain that they're linked, have an idea what the problem is (insofar as permissions) but am lost about trying to fix it!!

Can anyone help please???!!

My System SpecsSystem Spec
06 Mar 2011   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit

Hi dog3074,welcome to the forums, try installing the driver in compatibility mode Compatibility Mode :)
My System SpecsSystem Spec
06 Mar 2011   #3
Orbital Shark


Quote   Quote: Originally Posted by pebbly View Post
Hi dog3074,welcome to the forums, try installing the driver in compatibility mode Compatibility Mode :)
Good call.

Also, try downloading the files indepentantly and right-clicking the setup/install.exe file and selecting Run as Administrator
My System SpecsSystem Spec


 Access is denied error while installing driver

Thread Tools

Similar help and support threads
Thread Forum
Error : Access denied
I installed a program to test with some class mates. but after a while. I couldn't remove it because when you wanted to remove it via control pannel > Programs it will ask for a code/password to remove and it is one that I dont know. So I decided to run msconfig to turn off the service on boot....
Folder Access denied after installing new windows
Hi. I had applied access restriction through the security tab on a folder. The setting had been set on each subfolder and every individual file within them. Recently I installed new windows and when I changed the access setting to "Allow" it would only apply to the parent folder and an error comes...
General Discussion
Error- Access is Denied
I hope someone out there can help,as this is my last resort. Whenever I am attempting to install anything that I have downloaded, I receive this error message. "Error-Access is Denied" // (no error number) I have scoured the internet, and have tried everything that is out there. Turning...
General Discussion
Access Denied to D:\ after installing WIN7
Dear all, I've installed windows 7 and I had XP, but I can't access my D:\ drive any more :( can you help me? I've attached a photo for that.
Installation & Setup
Access is Denied when installing Corel X4
So we got the new laptop with a fresh copy of Windows 7 64bit. Additionally, a copy of Wilcom Decostudio with Corel Draw X4. It wont keeps throwing up a message of ACCESS IS DENIED, file /DRAW/, Feature: wilcom Decostudio, when it starts to install the Corel program. This has...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:40.
Twitter Facebook Google+