Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Can't Open ACPI ATK0100 kernel Mode Driver" error at boot.

12 Apr 2011   #11

Windows 7 Ultimate (x64) Service Pack 1

I've changed the MTsensor start value to 4, rebooted, and the message STILL appears!

Would I have the appropriate permissions to delete the entire MTsensor key? Would that help if I could, or should I take some different steps now?

I appreciate the help, by the way. Thanks a lot. :)

My System SpecsSystem Spec
12 Apr 2011   #12
Microsoft MVP

Win 7 Ultimate x64

You can but there is a lot more than just that one key, and more than one with a Start entry. Didn't think it would work just by how many references to it I found when doing a quick search through mine.

Is this the only driver that is causing a problem, or are there any others? Might be a better idea to do something like this,

Windows 7 Installation - Transfer to a New Computer

using method 1. Method 3 is the one that would have been used before moving the drive from one laptop to the other. Just make sure you have any necessary drivers handy for after to install for the bits that Windows doesn't install a default driver for.
My System SpecsSystem Spec
12 Apr 2011   #13

Windows 7 Ultimate (x64) Service Pack 1

Yes, this seems to be the only driver causing a problem.

I'll try method one in the tutorial you linked to, and report back with my results.

Thanks! :)
My System SpecsSystem Spec

14 Apr 2011   #14

Windows 7 Ultimate (x64) Service Pack 1

Well, after many failed attempts at using sysprep, I gave up trying to fix the many errors it threw at me, and just decided to install a fresh copy of Windows.

After I had finished installing Windows and most of the programs that he needs, I went to double-check I had installed everything I needed to by looking at the Add or Remove Programs list on the old laptop. I then saw a program called "AutoHotKeys" by ATK. I can't believe I missed this (I didn't know it was installed as a program, it isn't my laptop.). Still, I believe this is what was bringing up the error.

I think if I cloned the hard drive like I did the first time, without sysprep, but with this program uninstalled, it would have worked. Alas, I am not going to try this, since I have spent the day reinstalling programs and customising this new installation of Windows.

It was a rather silly mistake on my part, and for that, I apologise. :P

Thanks a lot for all the help!

My System SpecsSystem Spec
25 Aug 2012   #15

Windows 7 Ultimate 64 bit

All you needed to do from the very beginning was go to Control Panel/Programs/ATK Package/ Click Repair

I had the same issue on an ASUS K53TA laptop and after doing this and restarting the problem was gone.
My System SpecsSystem Spec
29 Dec 2012   #16

Windows 7 Ultimate x64


Thanks to everyone for the discussion.

I just add a bit of information. For an absolutely new AV55 / K55VD ASUS machine I have found the same problem. No ATK package in the "Programs" section of the Control Panel so no possibility of repairing it. No driver found anywhere in the computer.

I "simply" went to the Asus support web ASUSTeK Computer Inc. -Support- Drivers and Download A55VD and downloaded the latest version (2012.07.18) of the ATKPACPI "Utility".

It solved the problem. Now I have the ATK package installed in the system and I can see it in the programs section of the control panel. No need of reinstalling any other thing.

Good luck.
My System SpecsSystem Spec
11 Dec 2013   #17

Win 7 ultimate 32 bit and Win 7 Ultimate 64

Quote   Quote: Originally Posted by stormy13 View Post
Try again with it set to show hidden and ghost devices,

Device Manager : Hidden Devices
For what ever is worth just found the same problem changing system in some HP all in one computers I have and went in all motions of solving the problem with no luck. Finally I did what most of us don't do out of habit. Check into the OPTIONAL UPDATES of Microsoft and the fix is there to download.

This post it means for people as me who come late to the problem as I see this thread is old and is for the users who have their machines updating automatically and never check the site. .
My System SpecsSystem Spec
03 Feb 2014   #18

Windows 7 Ultimate x86

I'm a bit late as well, but this thread is on #3 in the results when you search for ATK0100, so...

The ATK0100 utility is one of two utilities that handle your Fn keys. Well, Toshiba decided to replace them with Toshiba Flashcards in one of their Value Added Packs, and didn't tell anyone. Almost all of their updates are horribly undocumented though, so I guess it's just par for the course.
My System SpecsSystem Spec
16 Jun 2014   #19

Windows 7 Home Premium 64bit SP1
2 utility combo

As mentioned earlier, Asus has modified their website (i have also come across url's that point to older sections of their server, which still host the older drivers)... you dont need those.

You must installl BOTH of the Driver Utilities that entertain the "Fn" key.

On the most recently patched version of the website,
navigate to your model and,
grab the ATK/ACPI and the KB Filter

Once you grab both of those, the function key will function.
My System SpecsSystem Spec

 "Can't Open ACPI ATK0100 kernel Mode Driver" error at boot.

Thread Tools

Similar help and support threads
Thread Forum
BSOD at boot says "...not fully ACPI compliant"
I installed windows 7 and theirs no problem with it, but later I decided to downgrade my W7 to Wxp. When I install win xp when installation was in "Windows starting to set up" but later on something came up which says "ACPI Bios is not fully ACPI compliant"...
Installation & Setup
"NVIDIA Kernel Mode Driver Version 186.75"
I just bought a new desktop and within the first hour I had an error message that said, "Display driver has stopped responding and has recovered. Display driver NVIDIA kernel mode driver version 186.75 stopped responding and has successfully restored". What the heck is this? Could this be related...
BSOD at boot says "...not fully ACPI compliant" but worked before
From power cycle or push-button reboot, I now fall into Windows Error Recovery screen, with options to - Launch Startup Repair (recommended) - Start Windows Normally The first one goes to BSOD declaring "The BIOS in this system is not fully ACPI compliant. Please contact your system vendor...
BSOD Help and Support
Reinstall driver "Microsoft ACPI Compliant Control Method Battery"
Hello all, I've spent a good few days trying everything the internet has thrown up to fix my mistake but nothing has worked. I shall list my attempts to fix subsequently. My problem is this: six days ago, I was using my laptop on its battery and I noticed that the battery icon in the...
Blue screen error 0x00000044; "Kernel Mode Driver Framework Runtime"
This shut down occurs ONLY when I am using 3 peripheral usb devices simultaeously and it doesn't happen right away. Sometimes it's an hour and sometimes it's several hours before it crashes. Now there is an executive program that is controlling all of the usb devices, if that makes any difference...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:54.
Twitter Facebook Google+