Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Code 10 Network Adapter intel 82562v10/100

14 May 2011   #1

Windows Vista Home Premium 64-bit
Code 10 Network Adapter intel 82562v10/100

Vista Home premium 64 bit
Dell Inspiron 530S Desktop

Dear folks, I can’t get the Network Adapter Intel 82562 v10/100 to work despite multiple diagnostics, installations and Dell factory system restore (F8). Consistently I get a recalcitrant ‘Code 10’ in the network adapter driver.

Everything began one day when I was using a program that requires Java. While doing so, I got bored and decided to browse another website (a questionable one) and it didn’t take too long before I got disconnected from the network. The first message was that the Bonjour Service was stopped (mDNSresponse.exe); then my network settings showed “a cable has been unplugged” but doesn't make sense since my computer is connected to the router through an Ethernet cable. After checking connections anyway, I closed everything, restarted the computer and ran Norton antivirus. Next thing I get was intermittent access to the network which rapidly evolved into marked instability and since then permanent disconnection. To get around it I hooked up a wireless adapter I have at home which works for a while just to end up being useless in a matter hours again with the message “a cable has been unplugged”.

I ran Norton antivirus & Malaware bytes. The latter one identified 4 viruses: 2 from Malware.Trace (a Registry Value virus), another from Rogue.Antivirus Suite (a registry key -avsuite) and another was Evidence Eliminator. A last one was stored in the Favorites folder which I deleted. I removed them all (or so I believe). After restarting everything, ‘a cable has been unplugged’ shows up again in the Device Manager beside the Network Adapter Intel 82562 v10/100 Driver (a yellow stop sign).

To troubleshoot the driver I’ve used the following sources of Intel® 82562V 10/100 network adapter driver. All of them to no avail despite multiple disable, enable, uninstall & reinstall.

-Original reinstallation CD that came with the computer ( on 6/21/2006)
-From Intel Website (v2, that is on 3/26/2010; PROWinx64)
-From Dell website (R185803)
-After factory reset D drive (R185803 but somewhere in 2008)

Before attempting installations & reinstallations of the network driver I did
'System Restore’ using Windows to a point about one month prior. Still without success, I ran ‘sfc /SCANNOW’. On top of that I’ve done 3 system restore to factory settings using an image available in the D Drive.

In the last system restore (from an image in the D drive), I have not been connected to the network and only original files have come in contact with the computer. As soon I get to Windows I turn on the the Windows Firewall and install Norton from an original CD.

Other things I’ve done is to reset the internet settings following these commands:
'netsh winsock reset' but also I've tried 'netsh in tip reset resetlog.txt'.

Initially when I resetted connections I noticed that when I hooked up the Ethernet cable to the computer I could see a light go on, but not anymore. Not sure what it means.

Bottomline I don’t know what else to do. I have the following questions:

-Is it possible for a virus to remain in the system despite factory restores? Supposedly while doing system restore (with the F8 command during rebooting) the drive is reformatted? Can still a virus remain? The reason I ask this question is that after doing the Dell Factory system restore (from an image in the D drive) I was asked to update Java which supposedly was erased during the system reinstallation.

-Is it possible that a virus infected the D drive where the image of the system is stored?

-What is my next step? Complete reset of the whole computer including the D drive?

-How do I do that? I have the original CDs although I’m not completely sure that everything is in there (I’ve read about many people who drag on for several days trying to locate unique drivers or files).

Thanks in advance. Help is appreciated.

My System SpecsSystem Spec
15 May 2011   #2

Windows Vista Home Premium 64-bit

This is a snapshot of the Registry Editor, hopefully is relevant for the problem at hand. If anybody has any insights, please drop me a suggestion if modifying the registry would help.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkCards\5


My System SpecsSystem Spec
17 May 2011   #3

Windows Vista Home Premium 64-bit

Well looks like my long post scared people away.

Basically I've tried to troubleshoot the 'code 10' using the most standard tricks. So far none have worked.

That's all I say in those long lines. Thanks for the input.
My System SpecsSystem Spec

18 May 2011   #4

Windows Vista Home Premium 64-bit

I've been noticing lately that the number of errors are accumulating, pretty much all related to the the "Windows Installer". Because this one quits, all attempts to install drivers fail. Now I need to troubleshoot Windows installer.

What I find disconcerting is that all of these errors still occur after Dell Factory Restore, suggesting that my computer stores prior information and this one corrupts future restores. I need to learn more about.
My System SpecsSystem Spec
22 May 2011   #5

Windows Vista Home Premium 64-bit

I did another Dell factory system restore and decided to leave Norton & Malawarebytes installation for last. After system restore Java remains installed in the system. As far as I know, Java is not among factory software packages. So this tells me that the computer is not totally reformatted or that the D drive where an image of the system is stored also got contaminated with Java.

Regardless of that, when I uninstall Java I eliminate the Code 10 in the network adapter. Next I continued to install windows updates to the point that now I have SP2. I was also having installation problems with iTunes and those went away with the latter installation, possibly because Norton antivirus was not interfering with the installation of all of these packages. Because I need to install Java for a program that I require, I got the Code 10 again. Now I'm not sure how much it appearance with due to Java. I don't have the time nor the patience to test this but so far I've relying on a wireless usb adapter. I'll continue using the computer this way and I'll post another update later.
My System SpecsSystem Spec

 Code 10 Network Adapter intel 82562v10/100

Thread Tools

Similar help and support threads
Thread Forum
Intel Network adapter
For some reason I cant upgrade my network adapter because I cant uninstall the old drivers. I've tried everything i can think of including deleting it from the device manager, add/remove program, and even the registry. It's asking for a file called PROSETDX.msi which there are many of but none of...
Problems in Network adapter (Code 10)
Hello, I have devices that aren't working in network adapter : Microsoft 6to4 ISATAP Adapter , Microsoft teredo tunneling pseudo-interface , microsoft Adapter , Microsoft Adapter #2 , Microsoft Adapter #3 . In properties, I see error (Code 10). The devices are up to date. I have uninstalled...
Network & Sharing
HELP!! W7 Home Premium and intel network adapter
Hi, im a newbie to W7. Just done a (Windows 7 Home Premium 32bit) clean install on my PC. i was using WXP Professional. PC SPEC motherboard: Intel Desktop Board DP965LT LAN: Gigabit (10/100/1000 Mbits/sec) LAN subsystem using the Intel® 82566DC Gigabit Ethernet Controller
Intel PRO/100 M network adapter
Hello everyone. I have an Intel PRO/100 M network adapter and I can't find a driver for it, for Windows 7 x64. Windows XP (32 bit) can recognize it automatically. Windows Vista (32 bit) does not have built-in drivers for it, but it can get them from Windows Update without me having to search for...
Intel 2200BG network adapter - Win 7 driver?
That said; Intel has discontinued support for the Intel ProSet/Wireless 2200BG Network Adapter. There might be some generic drivers capable of Win7 out there, but I can't find them on the Intel site. I did find Vista drivers here. Update: These drivers worked and this old lappy is now...
Installing network adapter - Intel 855 Centrino Chipset
Ok. so I'm trying to install this Intel 802.11bg driver on my Tosh lappy. (I am installing it from a USB Flash drive, since the machine has no network connections.) I install in XP2 compatability mode, and the report is that the installation is correct. But on restart, "Windows could not find a...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App