Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How can I get my usb drivers working?

09 Jun 2011   #51
Nigsy

openSUSE 13.1 64bit
 
 

What about using a Linux Live CD and see if you can boot with that.

https://help.ubuntu.com/community/LiveCD

Once in you should be able to access the windows file system and manually add the missing driver files.


It's a doooozy of a problem though!


My System SpecsSystem Spec
.
09 Jun 2011   #52
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

Quote   Quote: Originally Posted by Nigsy View Post
What about using a Linux Live CD and see if you can boot with that.

https://help.ubuntu.com/community/LiveCD

Once in you should be able to access the windows file system and manually add the missing driver files.


It's a doooozy of a problem though!
very good this is good advice
My System SpecsSystem Spec
09 Jun 2011   #53
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote   Quote: Originally Posted by jasv2 View Post
I just installed the serial pci card and low and behold it came with a driver cd. It also showed no signs of functioning with the mouse or keyboard. So I took the windows 7 drivers off the cd and put them on usb and tried installing those drivers from the Windows Recovery disc and I get the same error as when I tried reinstalling USB drivers. "The installation has failed."
I hope you mean USB/PS2 card.

Time to start checking PSU & MOBO, Mainly the 5v lines.
My System SpecsSystem Spec
.

09 Jun 2011   #54
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

have you been in contact with the dell support team or looked on there forums? i had help with a dell machine last year by contacting them.

i would try and run ubuntu live disc or install ubuntu alongside windows if you can to see if the usb controllers are ok. you have covered most of the repairs i can suggest to you do speak to dell and ask them for help you could have a virus/key-logger problem.

I uninstalled itunes then you have no usb functions seems a bit odd. how old is the machine?

i can see your frustration i have been searching the net on other forums and see you have posted the same problem on them. (no names mentioned)

another option is this SystemRescueCd http://www.sysresccd.org/Main_Page

You can use SystemRescue Cd to BACKUP DATA FROM AN UNBOOTABLE WINDOWS COMPUTER >> http://www.sysresccd.org/Sysresccd-m...ndows_computer

QUICK-START-GUIDE >> http://www.sysresccd.org/Quick-start-guide_EN


About SystemRescueCd

Quote:
Description: SystemRescueCd is a Linux system rescue disk available as a bootable CD-ROM or USB stick for administrating or repairing your system and data after a crash. It aims to provide an easy way to carry out admin tasks on your computer, such as creating and editing the hard disk partitions. It comes with a lot of linux software such as system tools (parted, partimage, fstools, ...) and basic tools (editors, midnight commander, network tools). It requires no installation. It can be used on linux servers, linux desktops or windows boxes. The kernel supports the important file systems (ext2/ext3/ext4, reiserfs, reiser4, btrfs, xfs, jfs, vfat, ntfs, iso9660), as well as network filesystems (samba and nfs).
My System SpecsSystem Spec
09 Jun 2011   #55
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

also there is this one to consider Ultimate Boot CD >>> Ultimate Boot CD - Overview

Quote:
Consolidate as many diagnostic tools as possible into one bootable CD. Wouldn't you like to avoid digging into the dusty box to look for the right floppy disk, but simply run them all from a single CD? Then the Ultimate Boot CD is for you!
My System SpecsSystem Spec
09 Jun 2011   #56
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

brianzion[Quote]you could have a virus/key-logger problem[Quote]

Following from brianzion, you try out this tool:
https://www.sevenforums.com/tutorials...m-sweeper.html

Also run:
On boot press F12, & run the Dell diagnostic tools.
My System SpecsSystem Spec
13 Jun 2011   #57
jasv2

Windows 7 Home Premium 64 bit
 
 

Back at it again. I had to take a break so that I wouldn't resort to bashing my pc and buying a mac.

@nigsy and brianzion I have a bootable Linux os that is one of the tools on Hyren's Boot CD. It boots in Linux fine, everything is intact. I replaced the usb.inf and usbports.inf files and Windows still would not boot with the usb ports intact. Maybe there are more driver files I need to replace...

@brianzion It's a 2 or 3 year old machine. I spoke to Dell and they were no help. They wanted to escalate my case to their premium tech support and bill me but I am not confident in their ability to solve this problem. I will check out those bootable CDs you recommended.

@theog I got the ps/2 pci card because I wanted to avoid anything USB because if there is a USB problem in Windows only, it could extend to overall new devices as well..I think. I don't know what you mean about PS2 and MOBO, I'll have to look it up. I will try the system sweeper tool. Dell diagnostic tool did nothing.
My System SpecsSystem Spec
13 Jun 2011   #58
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

well done a lot of progress so all the usb ports work in the linux? have you considered saving all important files etc on to another disc using the linux then re-installing windows? nice of dell to help at a price!!
My System SpecsSystem Spec
13 Jun 2011   #59
jasv2

Windows 7 Home Premium 64 bit
 
 

yea I know I can just save my files and reinstall but there's things I might forget and then there's programs with saved settings and configs I know I don't remember. If it comes down to doing a reinstall I will but dammit I shouldn't have to for uninstalling itunes
My System SpecsSystem Spec
13 Jun 2011   #60
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

i understand your frustration have you checked to see if the bios needs an update?

have a read of this not sure if it concerns you Chipset Circuit Design Issue Identified Solution for the Intel® Series 6 Chipset Design Error
My System SpecsSystem Spec
Reply

 How can I get my usb drivers working?




Thread Tools




Similar help and support threads
Thread Forum
USB 3.0 Ports not working: AMD Drivers cannot fix
Hi there. If you've read in my BSOD forum (https://www.sevenforums.com/bsod-help-support/349751-bsod-vacation-cannot-log-windows.html), I had to reinstall Windows in order to fix the problem. Well, I did. However, as I was reinstalling the drivers, I found out that the AMD drivers, which were...
Hardware & Devices
Drivers bot working after installation.
hello, First post, but i will get straight to the point. I installed a clean copy of win 7 ultimate 32 bit yesterday. I installed my Ati drivers and netgear wrg311v3 drivers, and restarted. but the drivers are not working, nor are they showing up in my system tray. I have a radeon hd5450 and...
Drivers
sound not working at all drivers
I have had this problem before and I fixed I just don't remember how. I'm working on an old computer and when I installed windows 7 for the 1st time on it, windows 7 installs all the drivers auto and it's wrong drivers and the sound doesn't work, I need to know how to disable windows 7 from...
Sound & Audio
realtek AC'97 drivers not working
I have an HP pavilion zv5000 laptop with the speakers on the front and the audio control buttons on the front and i have tried all the fixes i could find on other threads including: replacing the drivers from realteks website and making sure that the audio device is set to default. My ? is does...
Sound & Audio
XFI - WORKING Windows 7 Drivers
SB X-Fi Series Support Pack 1.0 (01/13/2009) - Sound Blaster - Creative Labs :D
Sound & Audio
ATI drivers not working- Help!
I just installed windows 7 a few days ago. Here is my system info: System Information ------------------ Time of this report: 5/9/2009, 07:16:50 Machine name: TREVOR-PC Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7100) (7100.winmain_win7rc.090421-1700) Language: English...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App