Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Focusrite Saffire problem

12 Jun 2009   #21

windows 7

I use Windows 7 x86 7126. Sound card Focusrite Saffire Le. Firewire controller Nec. all work When listen music (all work) but start work and all sound play clipping. Or sometimes start film or music or use Asio Sound start Noise - shshshshs.

Windows XP sp 2 and 3 All work Great!

My System SpecsSystem Spec
30 Jun 2009   #22

Windows 7

People Help
windows 7 x64 final release on this mounth
Motherboard Gigabyte GA-P35-DSL3 and Focusrite saffire le (firewire)
Sound play not correct My friend say but Problem in IRQ Harddrive and sound card or Lan in Motherboard . Anybody help Need Fix this problem

okey i found
Firewire IRQ 14 - Nec
Harddrive IRQ 14
this is problem?
My System SpecsSystem Spec
01 Oct 2009   #23

Windows 7 Build 7100
Saffire won't boot.

Hi all.

Ok, I don't want to bother you saying everything that everybody has already talked, but I think my system doesn't work quite fine.

I switched to Windows 7 when I upgraded my computer to an Intel i5 system. But when I tried to install the downloaded Saffire 2.5r driver, the driver installer says it installed "61833 Device Class" and finishes the process asking me if I want to update the firmware. But when I open the Saffire Control, it says the Firewire connection's lost and I don't see any Saffire kind of thing on the Device Manager. The "Line Mode" LEDs are lit orange on "Inst"s and won't change to green "Line"s.

On the other hand, when I connect my Saffire, I see "Focusrite Saffire AV/C Audio" and "Focusrite Saffire AV/C Subunit" with yellow triangles meaning unable to locate drivers on Device Manager>Other Devices.

And yes, I've read the comments on this forum and the Focusrite website, and tried to change the Firewire control driver to, both "1394 OHCI Compliant Host Controller (Legacy)" and "1394 OHCI Compliant Host Controller". And I recently updated the firmware using another machine (a Macbook).

Would somebody have a solution for this? Please share.

** P.S. : I also had to change my graphic card while changing the main board (Gigabyte P55-UD3) to a Sapphire Radeon HD4350, which installed something called "ATI High Definition Audio Device" on Device Manager>Sound, video and game controllers, even though I think I killed the included audio device on the BIOS menu. I tried to uninstall this thing but it comes back anyway. Should I somehow definitely kill this to make my Saffire work?
My System SpecsSystem Spec

25 Oct 2009   #24


Same problem here
Changed 1394 device(legacy) installed 2.5r drivers, could not upgrade firmware, then yellow lights...

Then I changed the firewire port of the soundcard (nearest the ground, sorry don't know how to say that better...)...Then it works !

I upgrade the firmware ( carefull, it's in 2 steps, firmware + dsp ) then yellow light again...But pluged into the other firewire port of the souncard makes all back to green

Enjoy !
My System SpecsSystem Spec
05 Jan 2010   #25

windows 7
Same problem

I've got the exact same issue as described above. I have a new HP computer with windows 7, but only have one firewire port. I am having the identical issue (can't update firmware, etc). The devices show on the device manager, but the triangles say drivers not loaded.

PS Also changed to legacy and installed the 2.5r drivers............
My System SpecsSystem Spec
27 Jan 2010   #26


Thank you spazbot !

btw works well with the original (not LE) saffire as well. Used the 2.5r2 version and updated firmware also.
My System SpecsSystem Spec
08 Apr 2010   #27

windows seven
Saffire pro 24 issue

I'm using Windows seven and the Focusrite Saffire pro 24 and I can not get out!
I tried to use the saffire mixcontrol 1.3 by downgrading my firewire port OHCI 1394 to the OHCI 1394 legacy and nothing happened.
Then I tried the new saffire mixcontrol 2.0 and upgraded my firewire to the OHCI 1394 and nothing changed.
The installation succed but the sound card is not detected more than 10 minutes.
Does anyone has a solution?
Thanks a lot for your advices!
My System SpecsSystem Spec
31 May 2010   #28


i have same problem with new hp dv6t-2000 i7 win7 with a focusrite saffire 26I/O...
the os can not recognize the device connected by firewire 4pin.. so cant update firmware

i install xp but without success,,, i thinkin try a express card ieee 1394 of TI,, recomended in focusrite web,, anyone has tried this??

saludos amigos!
My System SpecsSystem Spec
02 Jun 2010   #29


My System SpecsSystem Spec
09 Aug 2010   #30

Windows 7 32 ultimate

Hey I'm running Windows 7 32 bit Ultimate on a Dell Vostro 1320 laptop, 4GB of RAM, 2.2Ghz Dual core and I can't get my Focusrite Saffire to work.
I've tried using the legacy driver and installing Saffire Control 2.5 and also tried using the original driver with Saffire Control 2.6beta but in each instance I can't hear anything. You can see the saffire is registering sound and also in saffire control and in volume control but you hear nothing.
I tried recording into Audition 3 and it worked though you could only hear playback in the wave editor, not in multitrack view.
I think it might be something to do with the ouput as there is no sound registering on the speakers (either the laptops or the saffire's) in volume control.
Can anyone please help me out?
My System SpecsSystem Spec

 Focusrite Saffire problem

Thread Tools

Similar help and support threads
Thread Forum
BSOD - Focusrite USB2 audio interface is the suspect
Hi guys, recently bought a digital audio workstation from Scan (UK based company) with a Focusrite audio interface. Been getting BSOD SYSTEM SERVICE EXCEPTION when running the sequencing software Cubase 7. The main culprit when the crashes occur is obviously the Focusrite interface but I can't be...
BSOD Help and Support
Focusrite Saffire Pro 24 Problem (Clicks - Pops)
I have a Focusrite Saffire Pro 24 sound card that has been tested on Windows XP (with a relatively old system : Intel Core 2 Duo, 2GB RAM etc) and it works perfectly fine. I bought a new PC a few weeks ago (Intel i5 -750 @ 2.66 GHz, 4GB RAM) and I have installed Windows 7 Professional 32-bit on...
Focusrite Saffire Pro 24 DSP
Hi all I have been building my own computers for years, a new one about every two years. Each time I buy a new sound card, and have spent a lot in doing so. So now I have decided to use an audio interface, the Focusrite Saffire Pro 24 DSP as my main sound device. This way I can use it from computer...
Sound & Audio
BSOD with new Saffire Radeon HD 7850 2GB doing anything
BSOD with new Saffire Radeon HD 7850 2GB doing anything Hi, I'm new. I recently added 4x4GB of PNY ram to my Dell Studio XPS Core i7 system and replaced my Nvidia GT220 card. Then I started getting frequent bsods, about 8 a day. driver_irql_not_less_or_equal stop bsods in netio.sys...
BSOD Help and Support
Saffire Radeon HD 4350 hardware interrupts
Hey guys, i have just decided to turn my old computer into my media center so i decided to do a bit of upgrading, like up the ram, format and install Win7. all was fine with that. then i decided to get the HDMI crankin as well and have had nothing put problems. i tried a pci-e ATI HD...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:36.
Twitter Facebook Google+