Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need to reinstall windows generic driver

06 Jul 2011   #11
Microsoft MVP

Windows 7 Ultimate X64 SP1

Hi Coolclay. By installing Win7 that will negate the Acer eRecovery since it was installed with Vista.
In device manager have you went to all the USB devices and tried Update Driver? I have about 10 on my machine (desk top).
How about a system Restore if your have one available?

I say this for many issues, try SFC /scannow.
Try creating another user account and see if the problem persists with it.

Did you have the SD card in when you've tried updating and scanning for hardware changes?

My System SpecsSystem Spec
06 Jul 2011   #12

windows 7

Ok, I tried to update every usp driver individualy, no change sfc /scannow did not work either.
For some reason, I thought that sfc /scannow was more for network problems tho.

I have been installing and testing with a 512 meg sd card formatted fat32 with the lock on. I have several other cards I can try.
My System SpecsSystem Spec
06 Jul 2011   #13
Microsoft MVP

Windows 7 Ultimate X64 SP1

The SFC command is to find and restore corrupt files. did it find anything? Does the lock simply prevent reading/writing?
Did you try a Restore point and a new account?
As a last resort...Repair Install.
My System SpecsSystem Spec

06 Jul 2011   #14

windows 7

The lock is like write protect it is on all sd cards but not on micro sd.
i've had it off and on..doesn't matter cuz driver iz not working. I read somewhere that somebody thought this helped and since I'm trying everything + it keeps me from corrupting the card and have that as a reason for not working cuz I know it is good.

If I don't get it fixed now, I will live with it until someday when I have to reinstall. Right now I need my comp.
My System SpecsSystem Spec
25 Jul 2011   #15

windows 7

My problem appears to be fixed, but there is a story behind it.

I bought a new router with the intention of installing dd-wrt linux based firmware, after installing the firmware all working, decided to try out the optware addition.
In order to do this, I needed extra usb storage on the router. I went with a usb flash drive. To do this, I needed to format the drive with linux partitions and so downoaded and created a linux boot cd with a linux package called Gpart to do the formatting.

Since I needed to reboot my system anyway, I decided to kill 2 birds and install a couple windows updates as well.

Then I booted to Gpart.. gpart recognized the sd card which had been left in the slot with the vague hope that it would someday work and had been half forgotten. Bit of a surprise.

When I rebooted back to windows to continue configuring the router, Went to explorer to copy a couple files and was amazed to see the reader show up! And it works removing and reinserting cards, rebooting everything. It doesn't make sense.. I doubt that the windows updates were for that. Linux and windows have totally different drivers.

It is possible that this is a fluke or that the windows updates did it or what I believe is that somehow when I used the eject media that the hardware somehow marked itself as off line and linux recognized it and reactivated it.

Bizarre, but I'm happy it works, cross my fingers that it is not temporary. Though I am tempted to try and duplicate the problem and solution.

I will not use the windows eject media function for that anymore.

Thank you guys for your time and effort. Very much appreciated.
My System SpecsSystem Spec

 Need to reinstall windows generic driver

Thread Tools

Similar help and support threads
Thread Forum
Generic Communications Driver for windows 7
I put a generic PCI card in the computer i am using running windows 7 i am searching for a driver to make it work the current soundcard is fried and inoperable and this is a quick fix till i can go purchase a new sound card for it. this is one that has the modem attached and 2 plugins one for mic...
Is there a better driver for this generic gamepad?
USB Wired Gamepad Dual Shock Joypads PC Game Controller Computer Notebook Laptop | eBay I had bought this, and to be honest I love it as it works perfectly (except in Sonic Generations, which is basically crap. And that's the game that I bought the controller specifically for). My problem is:...
USB generic driver problems
Hi Anyone else come across the problem with the usbhub.sys? Everytime i plug in a hub it tells me that there was a problem installing the driver for the hub. Im running 7 x64. any ideas thanks
Hardware & Devices
Remove "generic" Windows 7 x64 graphics driver before installing new?
Hello folks. My first post so I'll try to keep it concise. I did a forum search, but found nothing that addresses my particular situation. I just completed installing Windows 7 Ultimate x64. The installation went fine and and so far I have no graphic card problems. My card is a Radeon HD 4830...
Graphic Cards
Generic driver
When I had Vista on the PC the webcam ran well with the drivers contained within Vista but when I upgraded to the "correct" driver the performance dropped. Following a clean install of W7 the webcam again ran better on the generic driver but after I had done another clean install of W7, after an...
Generic PnP Monitor Driver 64 bit
I have a Gateway LT2106 netbook that I recently purchased. It came with Windows 7 starter. I bought Windows 7 pro and installed the 64 bit version. Gateway does not have a video driver for 64 bit and the 32 bit refuses to install. My system is currently using the generic PnP Monitor driver...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App