Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DVD Drive Problem

12 Jan 2009   #1

Windows 7 Beta x64 Build 7000
DVD Drive Problem

Current Beta: x64 Build 7000

Laptop Model: Asus F8VA-B1

-Some CD/DVDs will lock up the drive and keep spinning (eject will not work)
-Whatever action i was doing from that CD/DVD (installing, copying, etc) will be seen as "not responding" but i can't use task manager to shut down the process
-Sometimes it will stop the process (after a long time waiting), but my Drive disappears from Device Manager + My Computer
-This occurs in both of the most recent builds for x64 and x86
-This drive worked PERFECTLY in Windows Vista and Windows XP
-Can't find much driver support for this drive

-I install Warcraft 3 Reign of Chaos perfectly. Eject disc and put in Frozen Throne. Click Install...install window pops up and just hangs there while the disc spins loudly....can't eject and can't end process
-Installed Microsoft Office 2007 perfectly, but left it in the drive to play Wii...came back and it was spinning loudly and was not able to be ejected.
-Tried to copy files from disc to hard drive and files did not transfer.

Has anybody experienced this? and if so, how'd you find a workaround.

My System SpecsSystem Spec
12 Jan 2009   #2

Windows 7 Ultimate Vista Ultimate x64

Are you sure the drive is still OK? Have you tested it again in another OS?
My System SpecsSystem Spec
12 Jan 2009   #3

Windows 7 Beta x64 Build 7000

Yes, the drive worked perfectly before installing Windows 7 (i was using Vista Ultimate 64 bit). To make sure, I just created another partition and installed Vista on it and it worked fine.
My System SpecsSystem Spec

17 Jan 2009   #4


Are you really sure the drive works in XP and Vista?

I own an Asus B50A laptop with a builtin HL-DT-ST DVDRAM GSA-T50N drive.
It was quite hard but the problem can be seen in XP. In Vista x64 it was no problem at all to reproduce this issue.

It looks like this is actually a firmware problem of this drive. My drive has firmware revision RR04.

Please see this linux-ide thread:

'2.6.28: Timeout problem with AHCI SATA DVD drive' - MARC

Several Ubuntu Linux users also complain about this issue:
My System SpecsSystem Spec
14 Sep 2009   #5

Windows 7

It would seem to be an issue with the firmware of the drive. I took a chance and flashed the drive's firmware, with excellent results - no more freezing, constant spinning up, non-recognition of the drive. It works.

The firmware can be found attached to this post, here, or if you don't trust me or you can find the file by googling or GSA-T50N RR07.

I sincerely hope this helps.

Edit: Ha, necropost on my first post. Sorry, mods.

Attached Files
File Type: zip (1.62 MB, 1735 views)
My System SpecsSystem Spec

 DVD Drive Problem

Thread Tools

Similar help and support threads
Thread Forum
Problem Replacing 750GB Boot Drive with 3TB Drive on older Desktop?
Hi, I have an HP Pavilion p6240f desktop purchased in 2010 that came with a 750GB C: drive. I'd like to replace the drive with a new 3TB drive using a cloning program to copy the old drive contents to the new drive. I've read that to access and boot from drives larger than 2TB "your system...
General Discussion
Problem after having cloned drive. (showing incorrect space on drive)
First off PC specs: AMD Phenom II x4 processor - 3.4 Ghz 8GB DDR3 RAM Nvidia N460 GTX GFX card 240GB SanDisk SSD Windows 7 64 bit So here is the problem. I had a Western Digital 300 GB SATA drive that was starting to quit on me. So using an Ubuntu live CD I cloned the 300 gig drive onto...
General Discussion
Boot Drive Not Drive Zero - Problem?
I just rebuilt my computer with Windows 7 Pro (32 bit) and I have a concern about the numbering of my hard drives. The motherboard is a Gigabyte GA-EP45-UD3P which has six ports controlled by the ICH10R controller (S1 through S6) and a pair through the Gigabyte SATA2 controller (GS0 and GS1). I...
Hardware & Devices
Hard drive problem with partition. Even after a new replacement drive.
After sending in my new 750 GB Western Digital Black Edition hard drive due to my partitions getting completely screwed multiple times. I received a brand new replacement 1 TB Western Digital Black Edition hard drive yesterday. Everything was working fine until I turned on my desktop on today and...
Hardware & Devices
USB flash drive/ DVD drive problem
Hello guys I recently ran into a very weird windows 7 bit problem after installing it on my desktop. I cannot copy large files/ holders into usb flash drive or write large files to cd/ dvd. The copying/ moving process would stay on for about 5-10 seconds then freezes then I get an error message....
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:14.
Twitter Facebook Google+