Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't find driver for "OpenHCD USB Host Controller"

07 Oct 2011   #1

Windows 7 Ultimate x64
Can't find driver for "OpenHCD USB Host Controller"


So I recently got a new motherboard: Asus Crosshair IV Formula. Everything seems to work fine except some USB devices. My MS Sidewinder X6 keyboard keeps disconnecting from the PC for no apparent reason, sometimes Windows says the device is malfunctioning and cannot be started. The keyboard works fine with other computers and other keyboards work fine with this computer. I've tried using different USB ports.

I noticed that there are two devices without drivers in device manager. There are total of 4 devices named "Standard OpenHCD USB Host Controller" and two of them give error message (10) "The device cannot start". They are all using drivers provided by Microsoft and they are very outdated: 21.6.2006.

I've installed every driver from my driver DVD and from Asus website. There seem to be two kind of USB3 drivers on the website: one made my NEC Electronics and one made by Renesas. I'm currently using the latest NEC drivers.

When I plug my Sidewinder in the front panel USB slots nothing happens. Nothing at all. But when I plug it in the back it works for some minutes before disconnecting again. Other devices seem to work fine in front panel.

So does anyone know where on earth I can find drivers for these two USB host controllers or are they even needed? And would they maybe fix my malfunctioning USB keyboard?

Thank you!

Hardware Ids:

Compatible Ids:

Device class guid:

Driver key:

Location info:
PCI bus 0, device 20, function 5

Physical device object name:

Bus type guide:

Power data:
Current power state:

Power capabilities:

Power state mappings:
S0 -> D0
S1 -> D1
S2 -> Unspecified
S3 -> D3
S4 -> D3
S5 -> D3

Location paths:

Device Instance Path:

DevNode status:

Driver Node Strong Name:

Driver version:

Inf name:

Property page provider:

Class lower filters:
AiCharger (some Asus thing that charges iDevices faster)
System specs below.

My System SpecsSystem Spec
08 Oct 2011   #2

Windows 7 Ultimate x64

Hello Jiia,

The first thing I would do would be to disconnect the keyboard then go to Device Manager and uninstall the two devices with error messages then restart the PC go back to Device manager and see if they are reinstalled.

The best drivers for USB3 are the Renesas drivers but if you are happy using the Nec drivers you can leave be.

You could also try going through this tutorial; USB Driver - General Fix for Problems[2]=Hardware%20and%20Drivers

I have come across this problem before when a USB device comes up as malfunctioning. if the above do not fix the problem I suspect that the device may well be malfunctioning. I have first hand experience with a wlan USB stick that also works in another PC but not my desktop. I suspect that this is caused by an oversensitive BIOS that is relaying wrong or no information to Windows as opposed to a fault with Windows.
In simple terms the USB device maybe dying, albeit that it works in other PC's or the problem may just be that the BIOS thinks it has a problem and stops it working.
The good news is that you can still use your Keyboard with other PC's
The bad news is I cannot offer you a fix as I do not know myself what is causing this and unfortunately just having the two PC's myself means that it will take me a long time to come to a definitive answer.
My System SpecsSystem Spec
08 Oct 2011   #3

Windows 7 Ultimate x64

Thanks for the reply! After some reading and surfing I managed to find the problem.

Apparently the generic Microsoft USB 1.0 (openHCD) drivers aren't compatbile with my motherboard. So I went ahead and disabled legacy USB support in BIOS and voila: Windows installed new drivers for the malfunctioning USB hubs and they are working.
My System SpecsSystem Spec

09 Oct 2011   #4

Windows 7 Ultimate x64

Thats great thank you for letting us know
My System SpecsSystem Spec

 Can't find driver for "OpenHCD USB Host Controller"

Thread Tools

Similar help and support threads
Thread Forum
"Intel USB 3.0 eXtensible Host Cont. Driver" Crash during installation
I’m downgrading a ASUS N550LF-CN100H from windows 8 to windows 7 Pro x64. But when I try to install the driver "Intel(R) USB 3.0 eXtensible Host Controller Driver" the system crash. I have installed the latest version of the BIOS (2.12) and changed some settings (for W7). - Boot -> Lunch CSM...
Cannot find "Mass storage controller" drivers for win 7 dual boot.
I have a Toshiba Satellite A205-S7442 laptop which came with Vista and I upgraded to win 7 dual boot. For some reason there are no drivers for the card reader ( sandisk microSD card ) in win 7 but Vista works fine. Have tried Toshiba driver download but cannot find drivers for mass storage...
AMD 3.0 USB Host Controller "cannot start (code 10)"
I have been having a lot of problems with my USB ports lately. Every time I turn my laptop on, whether it's off or hibernating, the AMD 3.0 USB Host Controller has a yellow exclamation mark by it and has the error "The device cannot start. (code 10)". I can get it to work temporarily by disabling...
What is a "SM Bus Controller"? Missing driver part of the Chipset drv?
After having installed a new Win7 the Device Manager tells me that the "SM Bus Controller" driver is missing. What is the purpose of this SM Bus Controller? Is the driver part of the Chipset (for LGA 1155 boards with Intel H67 Chipset) driver package? Peter

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:20.
Twitter Facebook