Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Marvell Yukon Driver

11 Oct 2011   #1

Windows 7 x64 Ultimate
Marvell Yukon Driver


Just wondering who else has a Marvell Yukon network controller and are you happy with the new driver changes?


My System SpecsSystem Spec
11 Oct 2011   #2

Windows 7 Ultimate x64 SP1

I have it. What do you mean by "new" driver changes exactly?

Do you mean the way they have a universal installer with it now?

Marvell - Support - Driver Downloads
My System SpecsSystem Spec
11 Oct 2011   #3

64-bit Windows 10 Pro

Hello Devnulllore,

If you mean the driver version from May, then I haven't noticed any difference other than the universal installer now. However, there's not any information about what was changed in the readme file either.
My System SpecsSystem Spec


 Marvell Yukon Driver

Thread Tools

Similar help and support threads
Thread Forum
Marvell Yukon 88E8059 - Can't register resources
Hey guys. I have a big problem with my LAN controller..for some reason the driver for it has randomly stopped working. I've tried to reinstall the setup from Marvell's website a number of times, rebooted etc but it just won't bring it back. It's an onboard Ethernet controller on an ASUS...
Network & Sharing
Windows 7 & Marvell Yukon 88E8001
I am having a strange problem with the onboard Marvell Yukon 88E8001 network adapter running on Windows 7 64bit. For some reason it has suddenly stopped being able to connect to the routers DCHP and obtain an IP address, nothing has changed and it was working fine previous. When I type...
Network & Sharing
Marvell Yukon 88E8056 PCI
Hi Folks, I have a eathernet card as in the title, and it refuses to function with Windows 7 or Ubuntu 10.10, However the thing logs on to the internet just fine with an older Ubuntu 9.0 that I ran from a disk, and of course, it ran fine with the previous XP. I got the newest driver and installed...
Hardware & Devices
Marvell Yukon Gigabit Ethernet freezeing every 15 mins
Earlier many reported this problem with win 7 x64 build 7100, now I did a clean install of build 7600 x64 & the problem is now more frequently happening every 15 mins it freezes the comp. Uploading stops downloading sometime stops sound/video freezes applications stop responding nothing can...
Network & Sharing
Marvell Yukon Controller cant connect
Hi, I just loaded Windows 7 Build 7600 and cant connect to network or internet through my on-board Marvell Yukon gigabit controller. I've updated my drivers to the latest i can find (v. and still nothing. Occasionally it will show I'm connected, but when I launch IE it drops connection....
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App