Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB 3.0 Host Controller Not Found

18 Nov 2011   #1

Windows 7 x64
USB 3.0 Host Controller Not Found

I've just recently upgraded my pc but i'm having issues trying to install and setup the drivers for the usb3.0 ports and updating the firmware.

I'm running on Windows 7 x64
My motherboard is the
P8P67 PRO Rev. 3.0 - New P67 B3 Revision

I have tried the drivers and firmware from here without any success.
RENESAS/NEC Drivers & Firmwares
Perhaps I am installing the wrong drivers? No clue.. i'm not the best with computers so that's why I cam here.

Also in the end my goal will be to run and use this product which needs to be ran from USB 3.0

The product is the Black Magic Intensity Shuttle
Blackmagic Design: Products
Blackmagic Design: Support Detail

Here's a good video tutorial to setup the drivers but mine doesnt allow me to open the host controller.. it just says Host Controller not found..

Please help.

My System SpecsSystem Spec
18 Nov 2011   #2

Windows 7 Ultimate SP1 x64

How are you trying to update the drivers? I would recommend unzipping the files, then using device manager to update the driver for the USB controllers... There should be two that you may have to do at two separate times... You may have to update the driver for the controller first, then the hub...
My System SpecsSystem Spec
16 Mar 2012   #3

Windows 7
USB 3.0 Driver not found solved

Just spent about 3 hours trying to get a USB 3.0 controller to work on an Asus eeepc 1215n with a new SSD drive installed. Clean install of Windows 7 home premium 32bit.

At first I thought this was a problem with USB 3.0 and SSD, not even close!

Simple solution to this one: Asus have the wrong drivers on their website!
They list USB 3.0 controller as NEC, when it is infact Asmedia.
Downloaded the asmedia driver and everything works, drivers detected and USB 3.0 ports now active.
If ASUS have done it for this model I expect they have done the same for a lot of different boards.
Hope this helps someone out.
My System SpecsSystem Spec

07 Aug 2012   #4

Windows 7 Home Premium 64bit

I can confirm KS1's solution to the problem. I wasted about an hour and a half trying various things with bios, device manager, windows update settings etc, to no avail. It annoyed me, having to buy a program to get my USB 3 working - but it saved me wasting more of my time. Seriously Asus & Microsoft... get your act together. Oh wait, Microsoft is in partnership with Driver Detective...
My System SpecsSystem Spec

 USB 3.0 Host Controller Not Found

Thread Tools

Similar help and support threads
Thread Forum
The Asmedia USB host controller was not found
Hello all, I have an Asus Z97 pro wifi ac and have been having issues with USB 3. I tried to install the usb drivers from the Asus website but I get an error "The Asmedia USB host controller was not found". Can someone please help me with this issue. Im running windows 7 64bit. Thanks
USB 3.0 host utility controller not found
Hi, I think I have accidentally uninstalled my Reneas USB 3.0 controller as the usb ports are not working and I'm getting the not found error. I have tried installing the driver from the reneas website and restarting my laptop but I get the same problem. Also usb 3.0 doesn't show up in the driver...
USB 3.0 Host Controller Not Found
I know this is a well documented situation and I have seen and read a lot of information about the problems others have had with the USB 3.0 Host controller. My situation is that I have followed several different solutions only to wind up with USB's on the 3.0 hub not working after reboot. I have...
USB 3.0 Host Controller not found
Today I got a WD usb 3.0 PCI-e card. WDBFJ0000NNC I installed the software on the CD it came with. Then I put the card into a free PCI-e slot. When I restarted the computer, windows gives a message that the device driver was not successfully installed. Specifically the "NEC Electronic USB...
Hardware & Devices
USB 3.0 host controller not found
Yesterday, my usb 3.0 host controller seems to have stopped working. I have tried enabling/disabling controller from BIOS, reinstalling drivers, finding different drivers, and reinstalling my mobo CD, but to no avail. (Yes, i already tried searching). It does not show up in windows device...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:40.
Twitter Facebook Google+