Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DigitalPersona not recognizing Authentec reader!

11 Aug 2009   #1

Windows 7
DigitalPersona not recognizing Authentec reader!

I just upgraded to Windows 7 on my notebook and installed latest version of authentec fingerprint drivers. After installation, I notice that there is TrueSuite 2.0 fingerprint software included with the drivers, which is made by authentec also, and it can read fingerprints fine and log me into windows too. But when I install digitalpersona 4.0.1, it complaints that the fingerprint reader is not attached. Only if TrueSuite could log me into website as well using fingerprints, I wouldn't even bother about DigitalPersona, but since its only for logging into windows, i want to get DP working. Is someone else facing similar problem with DP not working with Authectec reader on Windows 7 so far?

So far I have tried version 8.0.10 and 7.9 of Authentec drivers and version 4.0.0 and 4.0.1 of DP software.

My System SpecsSystem Spec
29 Aug 2009   #2

windows 7
Digital Persona doesn't work in W7

I have the same problem any one has the answer please. Since I upgrade to W7 my finger print reader is not being detected by the W7 though I installed genuine softw
My System SpecsSystem Spec
30 Sep 2009   #3

Here is my solution

I have an HP DV9700 and an Authentec AES2501 with Windows 7. I tried with the “w7wbf32.exe” and many others drivers and fingerprints manager’s software with the same result: "the fingerprint reader cannot be detected".
I've uninstalled all and installed from scratch with every driver found, trying even with "xp compatibility" and administrator credentials, with no better results. Finally I went to and download 3 files: sp35583, sp40206 and sp39199. In the first time I just looked for the oldest driver for my fingerprint-reader and the same with the “digital persona”, the fingerprint manager software but I don’t know really how I also download the sp39199 which, in my opinion, appears to be the key.
Anyway, if you wasted too much time looking for a solution may be this can help. I should start downloading and installing just the “sp39199” (remember that I have an HP and this came from their web) with the newer Authentec win7 driver (w7wbf32.exe) and the same with the fingerprint software.
In case you need them here are the links:
sp39199: vOID=2094&swLang=13&mode=2&taskId=135&swItem=ob-60526-1



Good luck!
My System SpecsSystem Spec

05 Jan 2010   #4

win 7

I've been having the same problem but on a dv2626, and tried everything, I mean everything offered as solutions on various forums, but installing that 'sp39199' fixed it for me, after a reboot obviously, windows then installed another auto-update and that was fixed, all working smooth.
My System SpecsSystem Spec
08 Jan 2010   #5

Windows 7 Ultimate
Get DigitalPersona to work in Windows 7 Ultimate 64-bit

Thanks alot Rastro, your solution did help.

I kinda did it a bit different though. I had DigitalPersona already installed using 'sp43883' and 'sp45217' (both from HP support website). You can just google them.

So after I couldn't get that red 'x' over the DigitalPersona taskbar icon to leave, I downloaded the 'sp39199' and installed it... still no luck when I restarted. So I then went to device manager, found my fingerprint device, then uninstalled AND deleted the driver that was installed. I think it was Authentec 2501A or somethin. I restared my computer and it worked!! But the sp39199 did the trick I think. It was just a matter of uninstalling the previous driver first and then restarting.

I then had the option to enroll my fingerprints and it no longer said 'device not detected' or 'detecting reader' before startup. I know this may not have been the best way to do it, but this way worked for me 100% after a whole day of frustration.
My System SpecsSystem Spec
11 Jan 2010   #6

You're welcome!

I really appreciate the thanks in the notes related to the Authentec Reader problem. It's good to know that your wasted time finding a solution could be helpfully to others in some way. It feels like an extra bonus.
Thanks everyone!
My System SpecsSystem Spec
23 Jan 2010   #7

Win7 x64
Authentec AES8210 with DigitalPersona 4.11 in Win7 x64

I had a hard time trying to get my Authentec AES2810 fingerprint reader to work with DigitalPersona under a fresh install of Win7 x64.

The driver was successfully installed from Microsoft Update and I could use the AES2810 to log in to Win7 using the native functionality. However, DigitalPersona kept displaying "Can't connect to fingerprint reader".

I tried with several drivers provided by HP and none of them seemed to work with DigitalPersona. Finally, I tried downloading a driver package from the Dell support site and bingo! Now it works like a charm!

Here's a link to the version, A05 driver package:

I hope this will help some of you guys out there!

My System SpecsSystem Spec
10 Feb 2010   #8

Windows 7 x64


YOU ARE THE MAN! Those Dell drivers worked perfect with my Lenovo T400. I'm using digitalpersona with the built-in reader and an Eikon USB external (for docking). Sweet!
My System SpecsSystem Spec
04 Jul 2010   #9

windows 7 32bit
It worked!!!

Thanks Rastro! After searching posts and trying different driver/software combos your advice (and links to the files!) did the trick. My fingerprint reader is being detected by Digitalpersona in Windows 7 and i'm back in business. Thanks!
My System SpecsSystem Spec
13 Jul 2010   #10

Thanks for the thanks!

It is good to know that many people found my post usefull.
Greetings to all.
My System SpecsSystem Spec

 DigitalPersona not recognizing Authentec reader!

Thread Tools

Similar help and support threads
Thread Forum
I can not register my mark on DIGITALPERSONA 2.0
good morning: I have a consulate on the fingerprint reader (fringerprint) from microsoft in windows 7: I comment, install digitalpersona 2.0 to perfection but when I enter the program to register my fingerprints did not detect any trace and I get a little sign at the bottom right with a...
I can not register my mark on DIGITALPERSONA 2.0
good morning: I have a consulate on the fingerprint reader (fringerprint) from microsoft in windows 7: I comment, install digitalpersona 2.0 to perfection but when I enter the program to register my fingerprints did not detect any trace and I get a little sign at the bottom right with a...
Problems with Authentec AES 1610 fingerprint reader
it works fine on boot up, but after my computer goes to sleep and comes back up, i cannot use it to log in anymore... I changed the power settings so windows cannot turn it off to save power, but the problem still exists, any help would be nice... running win7 =P if you need more specs please ask
Hardware & Devices
Win 7 not recognizing internal mem card reader
"One of the USB devices attached to this computer has malfunctioned, and windows does not recognize it. I have 4 USB ports in the back which are connected to my printer, mouse, keyboard and external hard drive which are all functioning fine. I have two USB ports on the front which are...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:07.
Twitter Facebook