Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Event Viewer error iaStor Event 9

01 Jan 2012   #1

Event Viewer error iaStor Event 9

I have a pavilion desktop h8-1075, and have found the following comes up in error of event viewer every so often

iaStor did not respond within the timeout period event 9

any assistance would be great to see if someone can cure this issue

Pavilion Desktop hpe h8-1075uk
Win 7/Pro
16 Meg ram

Tony Miller

My System SpecsSystem Spec
01 Jan 2012   #2

Win 8 Release candidate 8400

Iastor is your storage driver (for HD or Raid) and often a driver will not respond within the normal range. No big deal but you can update the driver to newest version to see if that eliminates the messages
My System SpecsSystem Spec
17 Oct 2014   #3

Windows 7 Home Premium x64

I recently ran into this, thought I'd detail how I fixed it, since there doesn't seem to be much information out there.

I was searching for some information in a linux virtual machine, on my Windows 7 ultrabook that came with a SanDisk U100 SSD, when I started getting strange errors from VMware that it couldn't access my disk. It kept saying that the operation on file vm-s004.vmdk failed and continually pausing the VM while "grep" tried to search those files. A google search suggested looking in the Event Viewer and I found a bunch of errors of the form "Event 9, iaStor" "The device, \Device\Ide\iaStor0, did not respond within the timeout period" over and over again. Further searching suggested it might be a loose cable or bad sectors, but it was consistently reproducible by searching a particular directory, so that ruled the cable out.

First, I shut down my VM and tried to back it up, but when I tried to copy the VMware disk file in question, vm-s004.vmdk, to my backup drive, it got about halfway through and I got a BSOD. I'd had some experience with bad sectors on FreeBSD, so I figured that might be it. I went to "Tools->Error Checking" for the system drive and scheduled a disk check, with only "Automatically fix file system errors" chosen. That ran fine after a restart, saying it fixed some problems, but the errors persisted afterwards. I looked in CrystalDiskInfo and it showed everything as fine, except the Raw Values for "Reported Uncorrectable Errors" kept going up every time I tried to access the files in question, it was at 2500 or so and moving up. I tried running another disk check with both options chosen, ie "Scan for and attempt recovery of bad sectors" also, but that seemed to freeze the disk check after 15-20 mins. I finally rebooted after it got stuck at 43% for an hour and a half, declining to disk check again.

When I'd had this problem before on a regular hard disk, the problem was solved by tracking down the file with the bad sectors and writing to it, so that the bad sectors were replaced with new sectors: I decided to try that again. I kept searching parts of the directory inside the linux VM that I'd been looking at initially till I narrowed it down to one directory in particular that kept triggering the VM pause. Luckily that directory had a bunch of compiler stuff I had downloaded in a compressed file that I'd kept around, with no modifications to the compiler files by me, so I unpacked the compressed file and copied the originals on top of the existing directory with "cp -av fresh-compiler/* old-corrupted-compiler." After that, I had no problems searching directories again!

I shut down the VM and tried to back it up again, but I hit errors that it still couldn't copy the same vm-s004.vmdk and more "Event 9" errors in the Event Viewer. I figured there might be more bad sectors on the disk, so I started up the VM again and went looking for them, by searching and reading all the files in the system. I eventually narrowed it down to the swapfile, and since I don't care what's in there, I turned swap off and wrote a bunch of zeros to it. Shut down the VM and back it up again, it worked!

No "Event 9"s for the last hour and a half and the "Reported Uncorrectable Errors" have stopped increasing. It's a little worrying that the Raw Values for "Retired Block Count" and "Remaining Life" still show zero, but it's possible those two numbers are meaningless for this SanDisk U100. I went back and looked at my System log in the Event Viewer, which had data going back to March, to see if this had happened before and it showed 1300 Event 9s, with most of them starting today. About 70 of them started sporadically about a month ago. I hope this doesn't mean my SSD is dying, been using it for more than two years without a problem. I guess I'll have to pay close attention to the Event Viewer and CrystalDiskInfo from here on out.

The upshot is that if you start having disk problems, it may be because a sector has gone bad and the "Event 9" is because Windows can't read that sector anymore. The solution is to write something to those bad sectors and force the disk to chuck them and allocate new sectors from its reserve. You have to find the files stored in those bad sectors and if you have the original files somewhere, write over them again.
My System SpecsSystem Spec


 Event Viewer error iaStor Event 9

Thread Tools

Similar help and support threads
Thread Forum
Event errors (11, 7000, 7026), intellipoint and event viewer freeze.
Hi, keep getting the errors above every startup regarding; 11 - "Custom dynamic link libraries are being loaded for every application. The system administrator should review the list of libraries to ensure they are related to trusted applications." 7000 - "The Crypkey License service...
General Discussion
After BSOD Event Viewer Logs Event ID 3012 and 3011 every time I boot
I was running 3DMark06 and got a BSOD code 124. After that every time I boot Event Viewer logs Error Codes ID 3012 and 3011. Attached are screenshots of both. I googled this and found two different threads where someone suggested to rebuild the performance counters. Both responses were...
BSOD Help and Support
WHEA-Logger event 18/19 errors in Event Viewer (W7 Home Premium)
Hi, I was hoping somebody could offer an insight on the below, as searching around I've not found much to go on other than "overheating" Basically my laptop has been having very high temperatures for a long time (usually ~60C for CPU and often 100-110 for GPU...insanely high, in other words)...
Hardware & Devices
Event Viewer Error Message Event ID11 - How do I get rid of this to?
Every time I boot my laptop I get error message Event ID 11 in Event Viewer. The details are: Custom dynamic link libraries are being loaded for every application. The system administrator should review the list of libraries to ensure they are related to trusted applications. This is listed...
BSOD Help and Support
Event Viewer Error Message Event ID10 - How to get rid of it?
Every time I boot my laptop I get error message Event ID 10 in Event Viewer. The details are: Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor"AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:16.
Twitter Facebook Google+