Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Devices not showing up...

22 Feb 2012   #11
Microsoft MVP

Windows 7 Ultimate X64 SP1

Well, I have a large gray beard. Let us now the outcome when possible. That was a strange error message. I sound a broken record, one more thing to try is a restore point before the issue started, if one is available. Are the new devices USB 3?

My System SpecsSystem Spec
22 Feb 2012   #12

Windows 7 64 bit

Hi there, sorry to keep you waiting.

No, the the devices aren't USB 3 as they work on my laptop which have USB 2, I tried a system restore point, only problem is that on windows 7 there aren't any system restore points (which is what I miss about XP, you had loads of them!).

Looks like I may have to do a system reboot (as what was mentioned before, if I disable the usb points that are faded it may work. Problem is, none of mine are faded. I spoke with a friend about this who is an IT expert and sent him an invite to try and resolve the issue, and we tried it several times, but no matter how many times we tried, it just wouldn't work!)

Looks like I may have to reinstall windows 7. My HDD is partitioned, is it true that the stuff that is saved on your partition stays there? I have a custom built PC, so installing it is VERY time consuming.

Here is the error message I get when I open system restore. Which is quite strange, as I do seem to remember creating one.

Attached Thumbnails
USB Devices not showing up...-system-restore-error.png  
My System SpecsSystem Spec
22 Feb 2012   #13
Microsoft MVP

Windows 7 Ultimate X64 SP1

How about uninstalling all USB devices in device mgr? Reboot and see if Windows will install some driver that will work.
Yes what is on a partition, other than what you reinstall on, will stay there. You'll likely have to reinstall programs though, even if they are already installed on the other partition.
My System SpecsSystem Spec

01 May 2019   #14

debian, mint, mx, 7
2019; problem still persists ...

Notice: The last post in this thread was 2625 days ago. If your post is not directly related to this discussion please consider making a new thread.

yes, it is still a problem in 2019. simple fix for me (as suggested by necrotic) is to check to see if it has a drive letter. mine didn't. i will be giving my usb drives letters starting with r, s, t, ... because i am multibooting and the system assigns c:, d:, e:, ... to installed hdd/ssd

ok, gave it a drive letter, right away autoplay wizard opens and asks me what i want to do

so, problem still persists, but has easy solution. i suspect original post has other issue. 2625 days later, i hope problem is resolved; op is probably on win 10, which is a resolution, of sorts
My System SpecsSystem Spec

 USB Devices not showing up...

Thread Tools

Similar help and support threads
Thread Forum
Bluetooth devices not showing up in "Add New Devices"
I just bought a new USB Bluetooth adapter (Targus Bluetooth 4.0 Dual-Mode Micro USB Adaptor), so that I can use my Bluetooth speaker and my PS4 controller with my desktop. I used the included CD to install the drivers. But for some reason, no devices show up in the "add new devices" menu. I'm...
Hardware & Devices
Audio USB Devices showing under Other Devices in Device Manager
Hi! I have two USB audio devices that I cannot seem to properly install drivers for. Focusrite Scarlett 2i2 & KORG MicroKONTROL I am in communication with both product tech support teams but so far they have not offered a successful solution. As the same issue is occurring with multiple...
Hardware & Devices
Devices and Printers not showing up
I downloaded the latest Windows update just a bit ago. When the comp rebooted I had an Adobe Flash update (which I installed). Rebooted, then opened Word to print out a document and it couldn't locate any printers. Tried to "Add printer" and got the error "The Active Directory Domain Services is...
Hardware & Devices
devices not showing that previously did!
i had to replace my pc and my kodak printer used to show exact image in devices and printers in my new pc x64 it doesnt i have a generic printer image and when i click on it i no longer get the kodak screen ! WTF.
Hardware & Devices
USB devices not showing up in XP Mode
I am hoping someone can give a little help with this problem. I have XP mode installed and it works great. I have a bunch of programs installed and they all work fine, almost. The problem is I need to use an older windows xp program for transcribing voice files. The program installs fine,...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:17.
Twitter Facebook