Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD during boot on AHCI mode

31 Mar 2012   #1

Windows 7 Professional x64
BSOD during boot on AHCI mode

My motherboard is a Gigabyte Z68XP-UD3 Revision 1.3, my OS is Windows 7 Professional 64 bit, my HDD is a Seagate 1.5tb, and my SSD is an OCZ Agility 3 60gb.

So i was using Intel Smart Response technology with my SSD for SSD caching, everything was pretty much working fine. The other day i flashed my bios using @BIOS without properly disabling my smart response configuration, which i probably shouldn't have done and i won't do again. When i rebooted, Intel Rapid Storage technology was acting up and when i tried to open it, it said "IAStorUI.exe has stopped working". After that, i uninstalled the program and tried to re-install it, but during the install it said "This computer does not meet the minimum requirements for installing the software." After a little research, i found out that it meant that my bios was set in IDE mode instead of ACHI mode. I am not sure what the mode was before i flashed my bios, but it was probably some sort of raid that it used for SSD caching. When i went into the bios and switched from IDE to AHCI, windows would blue screen after performing a few seconds of the boot logo. I switched back to IDE, and did some research to find out about the "Start" registry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci. I switched that from 3 to 0, and windows was able to boot into AHCI mode and automatically got drivers. Then, i tried re-installing Intel Rapid Storage technology. It was able to install, and i rebooted my computer. It blue screened again on the same part of the boot logo as before. I had to switch back to IDE mode to get it working again. Then, i got new chipset drivers from Intel's website, which didn't help. The registry that i changed is still set to zero, but it just won't successfully boot with AHCI like it did the first time i changed the registry. I am very stumped and i dont know what i could do to make it work like it did before i flashed my bios. My friend recommended that i should reinstall windows, but then i would have to go through the trouble of getting everything back and i think there should be some way of doing this without reinstalling the os.

Thanks for reading all that. The bottom line is that windows blue screens when the bios is in AHCI mode, even though i have the registry that should fix that and that did fix it on one boot set to zero.

My System SpecsSystem Spec
03 Apr 2012   #2

Windows 7 Ultimate x64

Try to read the error code or name and see if you can get the dump file from the disk...
The files of interest are C:\Windows\MEMORY.DMP and anything in C:\Windows\MiniDump.

Given that the crash occurs during the Windows Logo there is most likely access to the disk thus a dump will be saved there, and given that the BSOD only shows shortly it most likely is a MiniDump, can you upload the most recent ones so we can analyze them?
My System SpecsSystem Spec

 BSOD during boot on AHCI mode

Thread Tools

Similar help and support threads
Thread Forum
AHCI mode and driver boot problem
Hi there, some time ago I switched my SATA controllers from native IDE to AHCI mode via regediting the "Start" parameters of msahci and pciide. After rebooting and swichting to AHCI support in the BIOS, Windows installed the generic AHCI drivers. Afterwards, I replaced those with AMD AHCI...
Hardware & Devices
can't boot from cd/dvd sata drive/AHCI mode
Is it just plain not possible to boot from a CD/DVD drive that is set in BIOS as SATA/AHCI mode? I can acces the drive & read/write from it, it just won't boot to it. Yes I have CD/DVD drive set as 1st boot drive. I have "Googled" the earth & can't seem to find a straight answer to this. Can anyone...
Hardware & Devices
Can I switch my boot disk from ahci mode to raid mode?
I Installed windows on a ssd drive running in ahci mode. I then switched the sata setting in the bios from ahci to raid in order to add 2 other hdds as a raid 0. Now the pc won't boot anymore getting no boot device error. I know about the registry fix to get an IDE sata drive to boot in ahci mode,...
Hardware & Devices
AHCI mode no boot from sata optical drives
A strange problem, nothing critical, but I found it annoying that my optical sata drives will not boot from a bootable disk when in AHCI mode in Bios. If I switch the drive mode to native IDE then I can boot just fine from either of the Opitcal Sata drives. I have done some searching and found...
Hardware & Devices
Can't Boot from CD-ROM in AHCI mode
I'm trying to do a startup repair of Windows 7 x64 on an SSD but can't boot from the CD-ROM while in AHCI mode. I have set CD-ROM at the top of the boot order in BIOS but this is just ignored and the computer boots from the SSD with the knackered version of W7x64. I read somewhere that when...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:18.
Twitter Facebook Google+