Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AMD Radeon HD 6700 Blank Screen Before Login

01 Apr 2012   #1
TurnaboutStorm

Windows 7 Ultimate x64
 
 
AMD Radeon HD 6700 Blank Screen Before Login

Hi everyone,

After upgrading my existing installation to Windows 8, I realized I hated it and reinstalled Windows 7 Ultimate (deleting the old installation). Once everything was up and running, I tried installing the latest AMD drivers for it (I'm using a Radeon HD 6700). However, after I reboot and the Windows splash screen disappears (but before the Windows Login), I get a blank screen. There's not any "No Signal" that pops up on my monitor, but my mouse does show.. I can boot just fine into safe mode, then disable the drivers to boot normally. However, I can't boot normally with the drivers enabled.

Does anyone know how to fix this? I'm nearly at my wit's end with this.


My System SpecsSystem Spec
.
03 Apr 2012   #2
alishathomaz

Windows 7 Ultimate x64
 
 

Removing the graphics driver in safe mode might work for you. Just remove it via Device manager, and re-install them.

Also remove every single removable components like ram, hardisk, power supply cables, data cables..
My System SpecsSystem Spec
04 Apr 2012   #3
TurnaboutStorm

Windows 7 Ultimate x64
 
 

Thanks, but it doesn't work. It just keeps showing the black screen when I boot.
My System SpecsSystem Spec
.

04 Apr 2012   #4
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

is it just one monitor ?>

Connected Hdmi or Vga or dvi link ?

Might want to swap ports could be in the wrong port
My System SpecsSystem Spec
04 Apr 2012   #5
TurnaboutStorm

Windows 7 Ultimate x64
 
 

I have one monitor connected over VGA and my TV connected over HDMI. Both have been in the same ports ever since I got the computer two years ago.
My System SpecsSystem Spec
Reply

 AMD Radeon HD 6700 Blank Screen Before Login




Thread Tools




Similar help and support threads
Thread Forum
Blank screen after login (sometimes)
I cannot log in to Windows 7 Professional - all the system does is hang after initial login (after the password has been entered.) However, I can log in using Safe Mode with Networking (but not Safe Mode!). I did a chkdsk /f /r - it reported and repaired corrupt index entries. This let me log in...
General Discussion
Windows 7: Blank screen on boot up, before login screen; slow startup
After the Starting Windows screen a blank black screen with a cursor that I can move pops up that lasts a minute (shouldn't happen with SSD, used to be ~10 second boot). Afterwards the login screen will appear as normal and everything works as normal. This doesn't happen when I boot into safe mode....
General Discussion
Blank screen after install amd ccc for AMD radeon HD 6700
hello,guys. I just reinstall my windows 7 professional 32 bit to win 7 ultimate 64 bit ,But when I download the latest and same update for my graphic card the AMD Radeon HD 6700 ,After shutting down my laptop and restart it my screen goes blank after "Starting Windows" screen and after that...
Graphic Cards
64-bit - Blank screen on boot up, before login screen; slow startup
Bonjour mes amis. I recently have started getting the infamous black screen of death at my computer's startup, very similar to this fellow user's problem. Basically, Blank screen on boot up, before login screen; slow startup. The black screen lasts at least two minutes on average, before the...
Performance & Maintenance
Blank screen on boot up, before login screen; slow startup
Hey, first time posting here, so sorry if this is the wrong section or anything. Lately my laptop has been experiencing a problem when I boot it up. After the Starting Windows screen with the glowing Windows logo, a blank black screen pops up that lasts for ages (I'd say at least 5 minutes)....
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App