Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Igrabber for PC, drivers not being found (screenshots)

08 May 2012   #1

Windows 7 Home Premium x64
USB Igrabber for PC, drivers not being found (screenshots)

Okay, I really need help with this. Windows 7 REFUSES to install new devices by USB. I've tried all usb fixes that were supposed to work --- unplug for 5-10 minutes, remove the battery, check if any plug-and-play services are disabled (none are), removing all the USB hubs in device manager and have to install them upon reboot ... nope.

My computer is running Windows 7 Home (64 bit). I'm trying to install the Igrabber for mac and PC. I installed the x64 drivers for the Igrabber ... and when I plug the igrabber into my USB port, windows says "installing device driver software", but NEVER finds it. What the hell?

In device manager, it's listed as "USB Device." Tried updating the device driver with the driver CD, didn't work. Tried manually inputting the directory where the drivers were installed into "search my computer for driver software" ... and then it looks as if it's going to install, but never does, just says

"Windows Found the driver software but encountered an error when trying to install it ... the system cannot find the file specified"

I have problems with other USB devices too, for example my flash drive --- when I plug it in, windows ignores it as if I didn't do anything.

How do I get my device to install? usually windows will see these devices automatically and install whatever is neccessary to make them work. I don't see why this is such an issue ... it's been this way since the format. Everything works fine except for USB ports.

Device Manager:

If anyone can help me with this issue, i'd greatly appreciate it.

My System SpecsSystem Spec
08 May 2012   #2

Win 8 Release candidate 8400

iGrabber is basically a video capture cable, software, and drivers. If you have more than 2-3 unpowered USB devices it may not be getting sufficient power to find the device and therefor wont install the driver.

Since you have only said you have tried "all" I have to ask if you have tired installing in safe mode with no other non critical USB devices plugged in?

Have you followed this tutorial?

USB Driver - General Fix for Problems
My System SpecsSystem Spec
08 May 2012   #3

Windows 7 Home Premium x64

Hi. Yes, while in safe mode, I tried again getting windows to see the drivers - it gave me the same "Windows Found drivers for your device but encountered an error while attempting to install them" error.

Also in device manager under "Universal Serial Bus Controllers", under Power Management, I found "Generic USB Hub" and "USB Root Hub" to have their "Allow the computer to turn off this device to save power" boxes checked. I unchecked all of them that said that, but it appears to re-check itself upon restart and boot.

Could that be the issue? that windows keeps turning off my USB ports even though i've unchecked them?

I'll see if anything in the tutorial works for me. Thanks.
My System SpecsSystem Spec

08 May 2012   #4

Windows 7 Home Premium x64

Okay, tried the tutorial twice, exactly. Uninstalled all the faded entries in device manager, deleted the INFCACHE.1 file, rebooted ...

It installed my USB SNES retro port controller automatically. It's still refusing to install the igrabber, though. It refers to it as the USB Device, and for some reason there are two entries.

Still not sure why it's not letting me install it.

I'll try the tutorial again ....
My System SpecsSystem Spec
08 May 2012   #5

Windows 7 Home Premium x64

My USB mouse installed perfectly. Still not letting me install the igrabber. I've uninstalled and re-installed the drivers for this device multiple times.
My System SpecsSystem Spec

 USB Igrabber for PC, drivers not being found (screenshots)

Thread Tools

Similar help and support threads
Thread Forum
Samsung S4 Drivers can't be found
I just upgraded from Vista to 7. I tried to connect my S4 to my laptop and am encountering this issue (see picture) It worked fine in vista and i have also installed Samsung KIES to see if the drivers would be accessed but no luck so far. Any idea how to resolve this?
operating system not found and no drivers were found eror
as usual I turned off my laptop and after a while a turned on again to use my laptop but it couldn't reach operating system and showed error : " OPERATING SYSTEM NOT FOUND" ! I tried all instructions to solve the problem and finally run by windows start up CD to re-install new windows. this...
Installation & Setup
CD/DVD drivers not found
I'll rundown my symptom, list my system and then list the solutions i've tried so far - unsuccsefully. I've already been pretty resourceful, and yet... Any help is appreciated :) ======================= PRObLEM Insert bootable dvd (which works on my other system, so its not the disk),...
Installation & Setup
No device drivers were found
No device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK. Windows XP-32bit > 7-64bit I have now spent many hours now on this and this is the latest error message i get after redownloading and going through all this malarky. I am...
Installation & Setup
no device drivers found
Hi i bought a new dell inspiron n 5010 and i have downloaded windows 7 professional(64 bit) from the MSDNAA account and burned the image on the DVD. In the bios of my laptop i set the sata mode to ahci when i try to install windows 7. it loads file completely but after install and next...
Installation & Setup
Drivers not found during install
Ok I've already read the section about this here on these forums, i tried to run the install DVD with AHCI enabled, disabled, and even one time trying to boot in non driver signature mode. Nothign seems to work, every time it hangs and gives me the same error about not beign able to find...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App