Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: How do I force windows to use a driver it doesn't list?

22 May 2012   #11

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

I usually ask the "stupid question" first, but have you checked to see if the mic is compatible with Windows 7?
Win7 Hardware compatible microphones 32 bit

Win7 Hardware compatible microphones 64 bit
It might not be on the list, but it's a good thing to know when trouble shooting. solving takes some extra steps, if it can be solved. A lot of unknowns right now. so please help and provide some information about your microphone and your system - thanks.

My System SpecsSystem Spec
22 May 2012   #12

win 7 X64 Ultimate SP1
Some Software

Some Software will let you turn off specific inputs such as a mic. But if your device manager shows a problem. You probably have driver problems.
My System SpecsSystem Spec
23 May 2012   #13

Windows 7 Home Premium 64Bit

It exceeds the maximum file size four and a half times...

EDIT: The exact problem I have is I know the EXACT driver I need to use for it, and it is built in to windows and has worked before, but it isn't allowing me to use the driver for anything anymore and so I have to force it, but do not know how when it is not even acknowledging said driver's existence anymore.

To go farther into this I have a logitech microphone that uses that driver, but windows stopped even knowing when it was plugged in, and I had this mic lying around, so I decided to use it. This mic has also worked before, but now it doesn't anymore, and I am going to blame it somewhat on this driver being denied. The people I went to for help before couldn't help, so I came here where I know I am sure to eventually be helped into my problem being solved.

The driver it uses is USBaudio.sys, and I even tried updating the driver to see if a recent security update might have messed it up and not gotten a new driver version, but that didn't help at all.

I'm sorry for being a little too vague, I was very tired and was busy with something else when I was posting earlier.

I noticed windows also automatically took me out of test mode recently, which may be a contributor, but it can't be the entire problem, because I've been trying this microphone for months.
My System SpecsSystem Spec

23 May 2012   #14

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Sorry I can't be of more help KinKin. The best I can do is point you to the only real information you have given me.

Logitech Headphones / Headsets / Microphones

You can try to locate AsYetTobeIdentifiedMicrophone that's giving you problems in Device Manager and remove it (or them) and restart your machine. But that's all I can suggest.

Good luck.
My System SpecsSystem Spec
23 May 2012   #15

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

You can try System File Checker (SFC) to make sure your system files are where they belong. This takes a while, so sit back and enjoy your evening.

Start Menu ==> All Programs ==> Accessories

Right click on Command Prompt -> answer yes to UAC dialog

in the Command Prompt window type:

SFC /scannow

Run SFC a few times in a row - someone recommended thrice
Run SFC a few times, restart machine between each run - someone recommended thrice

If this doesn't get you up and running, I'm out of ideas.

Your system information (It exceeds the maximum file size four and a half times...)?
Open the SysInfo report in a texr editor and crop the bottom - Windows Error Reporting (WER) is probably making the thing huge!
The max is 1MB for text. If removing the WER makes it less than 1MB please upload it. If it still exceeds the upload limit, could you break it down into smaller chunks. Try to make the breaks at a section.
My System SpecsSystem Spec
24 May 2012   #16

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Ok, To get better answers this really should have been put in the sound & audio. But you focused on the driver, hence where it is.

To get quick help, people really need to search for answers on their own. But since I started helping, I decided to follow up on this. I think your answer is here - if that doens't do it, you know where to look. People over there have far more detailed experience in sound & audio. I'm certain they'll have a more direct solution.

Good Luck.
My System SpecsSystem Spec
24 May 2012   #17

Windows 7 Home Premium 64Bit

Linked thread is no help, since the problem is not really my microphone. I was again vague.

Windows acknowledges it's existence, to the point of it being something in the usb port that might be usable. By default, though, it is using the "Unknown Device" driver for it. While trying to change the driver to the proper driver, which is built into windows, I found there not to be said driver in the driver list, even though it actually exists as a file in the folder where all the drivers are. I know it used to work, because I used to use a USB headset and recently had a Logitech microphone, which uses that driver, but that broke, some kind of short in the USB cord causing windows not even to notice it being plugged in. But we aren't talking about that microphone, are we? I'm currently(trying to) using a microphone that uses the USB audio driver that comes with windows, and worked at some time in the past. Right now, though, windows is refusing to acknowledge the existence of said driver. This is a question about how to force an unlisted driver because that's what I need to do, and that's what I know I need to do. This microphone is like any other USB device; it uses a driver, and if the driver is not picked up by windows, you cannot use it. The problem boiled down to it's simplest terms is a driver is there, windows used to know that, it doesn't know that anymore, I need to know how to force this driver that windows doesn't know exists anymore.

If you still feel like trying to solve the problem at it's core instead of at it's solution, like you have been trying to do, I recently uninstalled then reinstalled a driver, but this problem arose AFTER that, so it's unlikely that's the cause. There have also been a high amount of BSOD crashes quite a while ago, but the Logitech microphone had been working quite a little while after that and windows found it to work, so I'm just gonna rule that off as well.
My System SpecsSystem Spec
24 May 2012   #18

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

the Unknown Device seems to be getting in the way - remove it in Device Manager

did you run SFC?

Too many guesses for me to be of any help. sorry we couldn't find a resolution.
My System SpecsSystem Spec
27 May 2012   #19

Windows 7 Ultimate x64

Did you find a solution for this? I had something similar happen to me before thats if your driver started messing up after a BSOD. Sometimes it would work if i changed the cable/usb slot and now just nothing.
My System SpecsSystem Spec

 How do I force windows to use a driver it doesn't list?

Thread Tools

Similar help and support threads
Thread Forum
Force List View in Libraries
Somewhere, and I cannot find it, I found a post that detailed how to force list view for all folders including Libraries. If someone knows of the document I speak of, or knows how I can accomplish this I would be grateful. I understand it requires some registry edits and does come with it's own...
General Discussion
Windows 7 Setup Issue Cannot see SSD on driver list
Trying to install Windows 7 x64 on a custom built desktop and once i boot the windows cd, i cannot see my ssd partition, only my HDD partition. I have read online and tried various things but no luck BIOS can see the SSD and i have attempted to use SSD in "IDE" & "AHCI" & "RAID" Nothing...
Installation & Setup
How to add new resolution or force one that isnt in list?
Ive tried 2 tutorials already but none helped. How to Force a Resolution in a Registry | Learnosity Tech Blog : HOWTO Add 1680x1050 resolution to Windows VMware Server clients I can use either 1200x900 or 1024x768 but best resolution for my monitor would be 1366x768 Is there any...
General Discussion
Windows Media Center 7 Doesn't list movies with .mkv extension.
I am running Windows 7 64Bit Ultimate Edition and my .mkv files doesn't show up. I installed Shark007 codecs and 64bit stuff but it doesn't show up. Can you guys offer some assistance? Thanks
Media Center
Windows Live Mail doesn't appear in the program list
Hi, I have tried installing windows live essentials to use live mail, it says live mail is installed but it doesn't appear in the program list and i cant open it. why would that be?
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:09.
Twitter Facebook Google+