Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Oki B4350 Problems

31 Aug 2009   #1
aaronemerick

Windows 7 7100
 
 
Oki B4350 Problems

I have an Oki B4350 printer that doesn't like to work under Win7, either 32 bit or 64 bit, but it works perfectly under Vista. Everything I try to print something, the printer just says "invalid data" And refuses to print anything. I've tried looking but the official site has no drivers that I can use, as it says that the drivers come with the OS. Any ideas about how I can fix this problem?


My System SpecsSystem Spec
.
01 Sep 2009   #2
whest

XP, Vista, W7 64bit Home Premium
 
 

Yes you can install previous OS drivers in compatibility mode with the previous OS eg vista driver is installed in compatibility with vista OS (operating system) -
To install a driver in compatibility mode - right click the setup.exe file - click properties - click compatibility - check run in compatibility with vista/xp etc - check run as administrator - leave the rest blank. Start setup.exe and install.
Driver Page - B4350 | Drivers & software | Welcome to OKI Printing Solutions in Australia
My System SpecsSystem Spec
21 Oct 2009   #3
ChristopherM

Windows 7 Ultimate x64
 
 
Printer problems

I had the identical problem with the same model printer. It is caused by the fact that Windows 7 recognizes the correct printer but installs the Postscript (PS) drivers rather than the PCL drivers. The solution is to download the correct drivers from the OKI website and install as a separate printer (I had to install as a parallel connection then change the port to USB to stop Windows looking for the connected printer). I had to leave the incorrect (PS) driver on because otherwise Windows kept re-installing the incorrect printer. However, after a few days some curious process of Windows osmosis occurred and merged the two printers into one so only a single device appears under printers although when you right-click on it, for each of the top five menu items you can select either PS or PCL. Still it defaults to printing as PCL so it works OK
My System SpecsSystem Spec
.

16 Jan 2010   #4
csakamoto13

Win 7 home premium 64 bits
 
 
OKI B4350 driver

I had the same problem after installing Windows 7 Home Premium 64 bits and my OKI4350 using USB.
Never had problem with Windows Vista. I tried to install Windows Vista driver but received a message like this: "Win Vista includes the driver for thid printer and it is not necessary to dowload a driver". I could never find a driver!
The solution I found was: After installing the driver OKI 4350PS, what happens when you plug the USB cable with the printer turned ON, go to Control Panel and RIGHT CLICK on the OKI4350 icon. Click on Properties and go to Advanced. Click on NEW DRIVER and wait for Windows to search for drivers. When it is done look for OKI4350PCL and click on this option and OK. Is done!!
Click on Print Test Page.
Good Luck!!
My System SpecsSystem Spec
17 Jun 2010   #5
RadioTVCenter

Windows 7 Home Premium 32-Bit
 
 
RE: Help

"I had the same problem after installing Windows 7 Home Premium 64 bits and my OKI4350 using USB.
Never had problem with Windows Vista. I tried to install Windows Vista driver but received a message like this: "Win Vista includes the driver for thid printer and it is not necessary to dowload a driver". I could never find a driver!
The solution I found was: After installing the driver OKI 4350PS, what happens when you plug the USB cable with the printer turned ON, go to Control Panel and RIGHT CLICK on the OKI4350 icon. Click on Properties and go to Advanced. Click on NEW DRIVER and wait for Windows to search for drivers. When it is done look for OKI4350PCL and click on this option and OK. Is done!!
Click on Print Test Page.
Good Luck!! "

I tried all these steps and now everytime I try to print anything it says windows has stopped working and looks for a solution to the problem. Then after a minute it just cuts restarts my explorer or whatever I am trying to access the printer with
My System SpecsSystem Spec
21 Mar 2011   #6
daviddb

windows 7 64bit home premium
 
 
Oki B4350 probs

Quote   Quote: Originally Posted by ChristopherM View Post
I had the identical problem with the same model printer. It is caused by the fact that Windows 7 recognizes the correct printer but installs the Postscript (PS) drivers rather than the PCL drivers. The solution is to download the correct drivers from the OKI website and install as a separate printer (I had to install as a parallel connection then change the port to USB to stop Windows looking for the connected printer). I had to leave the incorrect (PS) driver on because otherwise Windows kept re-installing the incorrect printer. However, after a few days some curious process of Windows osmosis occurred and merged the two printers into one so only a single device appears under printers although when you right-click on it, for each of the top five menu items you can select either PS or PCL. Still it defaults to printing as PCL so it works OK
Exact same problem for me - just as pressure was on to print out some boarding passes - ChristoperM's solution worked perfectly - thanks a million - I owe you!
My System SpecsSystem Spec
30 Apr 2011   #7
thedslguy

XP Pro SP3
 
 

I found the solution today.

Windows Updates. So you find the printer properties and update the driver. Then choose Windows Updates. It'll find the correct PCL driver, load it and you'll be printing. Really simple after reading lots of really comolicated scenarios that didn;t work.

Try it!!

thedslguy
My System SpecsSystem Spec
03 Dec 2011   #8
daviddb

windows 7 64bit home premium
 
 

Slight update - had to reinstall the printer for unrelated reasons and exactly the same solution works as above as thedslguy and myself have detailed and couldn't find an OKIB4350 option but it works just fine if you click on the OKI B4300 PCL option. I guess the two printers are closely related.

toodlepip!
My System SpecsSystem Spec
Reply

 Oki B4350 Problems




Thread Tools




Similar help and support threads
Thread Forum
Many problems with video errors and somehow RAM problems
Okay so for a while now i have been having many problems. First off i had a PC with the video card i am using right now(Nvidia GTX 295), and it has been "losing signal" and just plain old crashing. So i bought a PC off my uncle. Its got reletivly good hardware, but i am still getting the same...
General Discussion
USB Problems, Errors and port problems!
I have a Dell Inspiron 1545 laptop, not to long ago I had to replace my hard drive. After that I reinstalled windows 7. Before this the usb devices would charge just not be recognized. Now only ONE port does everything (charge, sync, etc.) the other two just stopped working. I have no clue if its a...
Hardware & Devices
Can't start up my computer. (Driver problems, BSOD, other problems)
Hi I hope I'm placing this in the right section, if not, then could someone tell me where to put it and I'll post it again. I've got a Samsung RV510 laptop with Windows 7 HP 64 bit. About 2 weeks ago, I was watching a Youtube video, had Spotify and Facebook open too, and my computer...
BSOD Help and Support
extract problems, random BSOD errors all those problems
hi guys i dunno why i have many problems with win7 since installation and so far btw i wrote many topics before about my installation and eventually i didn't found any solution so i took my pc to computer shop and they solve the problem after that i installed win7 without any problems...
BSOD Help and Support
Windows Index Problems a.k.a Windows Assesment Problems
Hi, I have had Windows 7 for a while now and have continually tried to run windows assesment tool for a while now, but each time I run it, it always ends up having a problem when it starts "Tuning Windows Media Decoding" and ends up closing. This is not terribly important but I was just wondering...
Performance & Maintenance
Problems leading to problems...
Hello, I am new to the forum, and I am hoping someone can help me out. I am attempting to install Win 7RC 64 bit on my system and seem to run into another problem as soon as I solve one. I am now at a problem that has me at a loss. Bear with me as I outline what I have done so far. I had...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App