Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Difficulty finding mv61xx.sys Marvell RAID Controller

30 May 2012   #1

Windows 7 Home Premium 64 Bit
Difficulty finding mv61xx.sys Marvell RAID Controller

I was trying to find a more up to date version of the mv61xx.sys Marvell RAID Controller driver, and I am unable to find it through a search. The mv91xx.sys driver seems to be the more common, so most of my search efforts yield that. The only mv61xx.sys I was able to find was through the user's motherboard, but that is out of date and nearly three years old. 2009.11.05

The OP in the thread I linked to found a driver from station-drivers; I am not sure that is a reputable source. Any recommendations?

My System SpecsSystem Spec
30 May 2012   #2

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

I have always found Station-drivers to be very reputable and reliable as well

They do have access to beta drivers, though, as well as released drivers.

Marvell drivers
My System SpecsSystem Spec
30 May 2012   #3

Windows 7 Home Premium 64 Bit

I will take your word that it is reputable and reliable and mark this solved.

Further research does suggest that the latest 61xx driver on that site is a beta, though. may not be stable. probably is.

ASUSTeK Computer Inc. -Support- Drivers and Download P5Q Deluxe -> SATA -> Beta Version
My System SpecsSystem Spec


 Difficulty finding mv61xx.sys Marvell RAID Controller

Thread Tools

Similar help and support threads
Thread Forum
Marvell driver for controller not compatible with Win 7
My system is slow to load and no real problem with using the internet. It's just when I play BF3 online my system crashes hard sometimes and powers off or I get real slow fps/ freezes up and I have to shut down the pc to get out. Windows tells me the hd controllers driver (Marvell) is not...
Onboard Marvell Controller Opinions
Like a lot of you, my motherboard has an extra set of SATA Controllers by Marvell. When I first tried them back on my Gigabyte Socket 1366 board I thought they were lousy in comparison to the Intel SATA Controller. The benchmarks were not even close. I was mainly concerned about my boot drive...
Hardware & Devices
How do I disable a Marvell Controller?
My computer starts up very fast, but it takes over 2 minutes to restart! I had 2 500 hard drives with a Raid array set up (I think). This caused endless waste of time because it had to keep repairing it'self ... so I disconned one of the hard drives. Now when I select to 'restart' my computer,...
General Discussion
Marvell Yukon Controller cant connect
Hi, I just loaded Windows 7 Build 7600 and cant connect to network or internet through my on-board Marvell Yukon gigabit controller. I've updated my drivers to the latest i can find (v. and still nothing. Occasionally it will show I'm connected, but when I launch IE it drops connection....
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:45.
Twitter Facebook Google+