Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Logitech SetPoint installation

19 Jan 2009   #11

Windows 7

Setpoint works for me now. Think it was this that solved the problem:

And I used run as administrator and compibility mode. Dont think that was the problem because from what I can remeber I had already tested with those settings before.

My System SpecsSystem Spec
19 Jan 2009   #12


Isakii!!!! You're my Hero! Works perfectly after I followed that guide =)
My System SpecsSystem Spec
19 Jan 2009   #13

Windows 7 Ultimate Beta

32 bit. I just downloaded the Vista version through the page linked on wikipedia.
My System SpecsSystem Spec

20 Jan 2009   #14

Windows 7 Ultimate x86

I managed to install SetPoint after I fixed the MSI package problem...It installed without any compatibility option activated. Whoever got that installation problem refer to Windows Installer - can't install ANY msi package
My System SpecsSystem Spec
22 Jan 2009   #15


Hmm - I missed this thread yesterday - else I would have told you that if you don't use Vista compatibility then you get prompted that this version of SetPoint was written for a previous OS, do you want to continue... message, whereas with the compatibility on you never get that message.

However, I can also say that SetPoint x64 installed perfectly here on this machine and SetPoint 32 installed perfectly on my laptop.
My System SpecsSystem Spec
19 Feb 2009   #16

windows vista
Vista 32 /SetPoint 470

Tried Compatibility wizard, Admin mode, and Anti-Virus disabled... still would not install. It stops as it begins to install drivers.

I'm running Vista 32 and Setpoint 470

Please help!

My System SpecsSystem Spec
19 Apr 2009   #17

Build 7000

Just installed version 5.0a running compatiblity mode for Vista and running as admin;
No issues so far with my G9 or software....4.7 wouldnt detect my G9 though
My System SpecsSystem Spec
19 Apr 2009   #18


That's b/c the G9 has it's own version of Setpoint that only it could use - the 5 series.

The 4 series is for *non* G-series mice - and that is why over at Logitech forums, under mice, they have separate forums for mice and G-series.
My System SpecsSystem Spec
19 Apr 2009   #19

Build 7000

My apologies
My System SpecsSystem Spec
19 Apr 2009   #20


No apologies needed - that is a frequent question on the Logitech forums as well.

The problem erupts with programs like DriverMax, which only lists the latest available version of a driver, not the latest *applicable* version of a driver - thus, a lot of folks erroneously install SP5 when they need SP4.x or vice versa.
My System SpecsSystem Spec

 Logitech SetPoint installation

Thread Tools

Similar help and support threads
Thread Forum
Latest Logitech SetPoint Software
Latest Logitech SetPoint Released Date: September 13, 2018 Software Version: 6.69.114 OS supported: Windows 7, Windows 8, Windows 10
Another Logitech Setpoint problem.
I get most of the way through the installation, and then the window just kills itself. The only info I could find is that the Log says File created on 1-18-2009 at 02:17:48 Product : SetPoint version 4.70 02:17:48 = Before khal launched 02:17:48 = Installing khal... 02:17:48 =...
Logitech Setpoint 4.8 x64 - VC8 Library
I can't install Logitech's Setpoint 4.8 software on my Win 7 x64 system. Tried installing in compatibility mode (Vista SP2) and running as Administrator, but no luck. Each time, I get an error that says the VC8 library was not installed correctly. Have searched and posted messages on Logitech's...
Logitech EX 310, Windows 7 & Setpoint
Hey guys, I got a Logitech EX 310 for Christmas. I installed everything find when i get the set, but until a few days ago, my music controls started to play up. I reinstalled set point and no luck. I uninstalled set point and it works perfectly.... although some of the mouse features don't...
Hardware & Devices
Logitech Setpoint not working W7 X64
Hi there, I can't get Setpoint to install and without installing it my mouse some times laggs on a click. It's strange, sometimes it will work fine then all of the sudden, when I click something it 'sticks' for about 1-2 secs. Any ideas? Thx

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:10.
Twitter Facebook Google+