Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DVD/CD Device not reading media/Bad Block

21 Jun 2012   #1

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
DVD/CD Device not reading media/Bad Block

hi all

well! just joined sevenforums and this is my first post. glad to be here.

the problem i'm having is to do with the dvd/cd device on my "acer aspire 4741 with windows 7 home premium x64 notebook".

the driver for the device is:

DVD/CD ROM drives - (Standard CD-ROM drives)

i decided to creat a system backup to use in case of a serious crash and i have to reinstall windows. i was able to do this on 4dvds using erecovery. i haven't had the need to use these dvds yet thank God for that.

since then, i have burned some folders onto a dvd use like a usb....using windows explorer. all goes well with the burning part but when it comes to mounting the disc to access the folders is when all hell breaks loose.

whenever i slot the disc into the device, a dialog box shows up asking how i'm going to be using the disc. if i skip that part, launch windows explorer and double click the dvd icon, a window shows up alerting me to drag files onto the window to burn, but the folders that i had already burned on the dvd never shows up.

this is what i have tried so far:

1) launched microsoft fixit4me from the microsoft support center to check and fix dvd/cd device.

result: problem detected but could not fix

2) started system in "safe mode" ran diagnostic tool.

result: CDROM-the device,\Device\CDROM0 has a bad block

so i'm here now hoping somebody can enlighten me about what the problem is with the device and possible solutions.

thanks again for having me and hope to hear from somebody.

My System SpecsSystem Spec
21 Jun 2012   #2
Hanna 1

win7 home premium-64bit-SP1-IE10

Welcome to the forum
Did you try to read other cd's/dvd's than the ones you have make?
My System SpecsSystem Spec
21 Jun 2012   #3

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

hi hanna

thanks for the response. i really don't do much burning so i don't have that many lying around.

i do have a lot of prerecorded dvds that use to mount and launch my dvd player automatically. the problem now is, when i slot them into the device nothing happens. if i launch the dvd player manually and try to access the disc, the msg i get is....blank disc in device.

what i would like to know is:

1) do i need to update the drive? and if so can you possibly point me in a direction as to where to get it. i have tried acer's website without success.

2) do i need to change the device?

thanks in advance hanna
My System SpecsSystem Spec

22 Jun 2012   #4
Hanna 1

win7 home premium-64bit-SP1-IE10

Maybe some dirts are stick on the lens of the dvd tray,try to clean it up with a special dvd that you can find in any shop where you buy CD's & DVD's.
PS: Fill your system specs to get more help.
My System SpecsSystem Spec

 DVD/CD Device not reading media/Bad Block

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 not reading device connected through Firewire
I have a Samsung MiniDV cam which I'm trying to connect to my laptop using a 4-pin firewire cable but when I connect it nothing happens. I tried updating the IEEE 1394 driver to the Legacy one and the Ricoh one but still no luck. I have a Dell Inspiron 1525 running Windows 7 Ultimate 32-bit.
Ping DG, ftp block/httpd block
Hello Guys, I find this to be quite embarrassing, having an issue like this that I can't figure out. Here's what I can't do. 1. Ping DG (Default Gateway) 2. Ping my IP ( 3. Can't access my router via remote, even though its setup to allow it.
Network & Sharing
How to block a bluetooth device?
hi, is there a way to block a certain device from trying to send files via Bluetooth to my laptop running on windows 7?
Performance & Maintenance
C-Media AC97 Audio Device. This device cannot start.
C-Media AC97 Audio Device. This device cannot start. (Code 10). Sound hardware on ASUS Mobo will not work after installing Windows 7. Latest drivers installed. Don't know what else to try?
Connecting media device wirelessly
My situation is that my network is largely wired, but devices and other computers can also connect with my Cisco modem/router wirelessly. I have a Roberts Internet Radio which can connect to the internet happily, but it won't connect to my computer's Upnp server - I guess probably because the...
Network & Sharing
NAS shows up as media device?
Ok I have a NAS from airlink and it was working fine on my laptop with windows 7. Then at some point it stop showing up on my laptop, but I was still able to access my NAS from my XP Pro desktop. I used the config utility to change the network name on the NAS from HOMEGROUP to MSHOME and now I can...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App