Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: In China, Uninstalled iNode VPN, corrupted Miniport Drivers, Code 31

06 Aug 2012   #1

Windows 7 Ultimate x64
In China, Uninstalled iNode VPN, corrupted Miniport Drivers, Code 31

Hello 7Forums!

I come to you, desperate and browbeaten after many days of searching, in an attempt to resolve my apparent driver mess-up. I'll elaborate, but to start: I cannot access the internet from the computer in question neither on Wireless nor Wired connections, and am writing this from a separate tablet. I can, however, move files generated by my computer to the tablet to post here, download and move over necessary programs, and take photos of my screen. I'm not entirely sure what would be helpful, so I'm starting by posting the context and the DXDiag log.

I am on an Asus G51vx, Windows 7 Ultimate 64-bit with SP1 and most of the latest updates (old now given the lack of internet access).

The full story:

The problem started after I conducted a Revo Uninstaller Pro uninstall (by nature very comprehensive, deleting presumably all files edited by the installation) of connection middleman software iNode, installed with the help of staff here. It helped me access the subscription-based wall jack internet over proxy, but once the subscription ran out I uninstalled it and apparently the drivers, too, with Revo. All the drivers in the screenshot are displaying Code 31, "The device is not working properly because Windows cannot load the drivers required for this device." Nevertheless, my wireless network is still able to detect and connect to wireless networks and even shows high sent/received activity, but remains unusable. Chrome is unable to load any pages, Steam autofails with Error Code 10107, Skype remains unable to connect. All very confusing. My wired connection is showing error 651, with no additional details besides that the device is reporting an error. It is not a modem problem as i have tested it successfuly with another computer.

I have completed a full virus scan with Microsoft Security Essentials and a full malware scan with Malwarebytes, with no infections. I've tried reinstalling some drivers to no effect (although I admittedly had little idea as to what I was doing, and could have it wrong), using dskchk, sfc /scannow, and a few other cmd commands, and event tried some registry tweaks (with backup!) with no luck. I do not have my original Win7 cd handily available nor do I have the original G51vx driver CD. They're both incidentally on the exact other side of the world or so.

So, please, where do I go from here?

Attached Images
In China, Uninstalled iNode VPN, corrupted Miniport Drivers, Code 31-driver-sn.jpg 
Attached Files
File Type: txt DxDiag Metaphysical 8-6-12.txt (36.9 KB, 6 views)
My System SpecsSystem Spec
08 Aug 2012   #2

Windows 7 Ultimate x64

Adding to this post my Malwarebytes scan for further info.

What I want to emphasize is that I am detecting wireless networks on my computer, can even connect to them successfully, but cannot access any form of internet. I can guess it may be the result of improper proxy data removal? Still at a loss.

Also, booted into Safe Mode with Networking, and did not see the WAN Miniport devices in Device Manager at all.

Attached Files
File Type: txt mbam-log-2012-08-08 (00-29-07).txt (3.1 KB, 4 views)
My System SpecsSystem Spec

 In China, Uninstalled iNode VPN, corrupted Miniport Drivers, Code 31

Thread Tools

Similar help and support threads
Thread Forum
Uninstalled pgm., win7 starts but all aps. are locked, getting code.
I have an AMD 3.1gig quad core, 16gigs 1300meg? ram. great system. A week ago I tried to uninstall an unwanted app., since then win7 opens up normally. When I try to open ANY app. get error message saying the app. cannot open due to (0xc0000005). When I say nothing opens I mean nothing, no...
WAN miniport drivers vanished,can't reinstall PLEASE help.
Hello, this is my first post i don't have much time to write it so i will go straight to the point! Today while i was trying to connect to the internet i discovered that my network card and some other components showed up in device manager with the following message "This device is not working...
Network & Sharing
Missing drivers for WAN Miniport
I have a Toshiba Satellite A660-047 PSAW3C-047017 running Windows 7 Professional 64-bit. I just downloaded the ISO for Norton Ghost 15, created the installation CD, installed Ghost, and ran the driver validation from the installation CD. I got the following message: > The following devices...
Drivers are corrupted or missing (Code 39)
All my USB drives are gone. I get the message, "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)". One of the solutions I saw was to remove any UpperFilter and LowerFilter keys in two registry values. I did that, disabled and enabled the...
Where I can find drivers GeForce 9400gt china for win 7
Hi you guy, I came from Vietnam. I have bought a GeForce 9400GT card made in china. Here it is: I have tried the original drivers download at and but can't install, because my...
drivers for Intel 855 Centrino Chipse(from China)
Hi ,i come from Beijing China,my english is bad. but i very pleased to come here about drivers for Intel 855,sombody insalled ok,you can For reference somebody installed 7106 is OK I instanlled 7000 (DELL 710m)1020 * 800 on desktop,but when used 3D accelerated,my computer shutdown. ...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App