Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: X58 Chipset Update

22 Aug 2012   #1

Windows 10 Pro 64-bit
X58 Chipset Update

Sorry if this is in the wrong posting area, but I think it is in the correct one.

So I read in an earlier post that the proper way to update the chipset of your board is to use the run command with -overall at the end.

So I just got some new SSD's and have them in RAID0. So I started loading all my drivers, but I may be slipping here. Asus P6T Deluxe v2, I thought there was an entry in the Device Manager called QPI or something like that.

Q1 - After this new install I do not see it so I am wondering; am I losing it?

I did check ALL the Intel entries and they all had Microsoft drivers 6.1.7601.17514. I got the latest chipset for the board which is I did what the instructions said on how to install and now I have more questions.

Q2 - After install, shutdown then restart, in the device manager I see that only the Intel 5520/5500/X58 I/O Hub items got changed. Should the Intel ICH10 items have changed too or no?

Q3 - After the install, when I checked on the driver version for all of the I/O Hub items, they say dated 2-8-2010. The driver package I used was dated 5-3-2012. Did something go wrong? I got this version from the Intel website and I check the "this applies to" which the X58 is an Intel 6 series.

Q4 - Does anyone else have this board and had this problem? Or is this not a problem?

Q5 - Whoever has this board, what latest chipset are you using? Is it the same I got?

I look forward to your responses, I have read other posts not only here, but other sites as well and there seems to be some sort of installation issue, but I am coming here because in the past, this is where the answers to my past computer issues were solved. Thanks to all of you.

My System SpecsSystem Spec
22 Aug 2012   #2

Windows 7 x64

I will help if I can, but my P6T is probably revision 0 and the last chipset drivers were from 2009..on the ASUS site.

QPI shows on the side of the box but I don't see anything in device manager. Any specific directions as to where I might look?

If you are running SSDs, you might want to check for Bios updates in case one of them may help in that area. I suppose the latest SATA drivers are fairly important.

But if want specific info, you need to give me specific instances of whatever.
My System SpecsSystem Spec
22 Aug 2012   #3

Windows 10 Pro 64-bit

Thanks, yes the QPI, I think was listed, is not listed under Device Manager under System devices. I thought it was there from my old mechanical hard drives. I should have kept those just in case, but I erased them already.

I got the latest BIOS for the mobo and the firmware from the SSD's is the latest.

If you go to your Device Manager and go under System devices you should see some entries like Intel 5520/5500/X58 I/O Hub Control Status and RAS Registers - 3423, what is the driver version and date you have? The next 7 or 8 items that are just like this entry, just wondering what the versions are.

For my RAID I am using for the SSD's
My System SpecsSystem Spec

22 Aug 2012   #4

Windows 7 x64

Of the 8 listing under your heading, all say 6.1.7601.17514 6/21/2006

Ports 1,3 and 7 say 6.1.7600.16385 pci.sys

The rest all show no drivers needed from the Driver Details button.

I have not updated this system for a while, so I cannot guarantee I have the latest.

I don't run RAID so it probably would not be relevant.
My System SpecsSystem Spec
22 Aug 2012   #5

Windows 10 Pro 64-bit

Yes, those are the Microsoft drivers. Those are the old ones, if you get the ASUS ones, they are more up to date.

I am interested to see if anyone else can answer my 4 questions because when you update, you are going to be in the same situation as myself, the differences in the numbering and versions. How is one to know if you are really up to date if nothing matches.

I have tried third party software to tell me what's out of date, not one works near 100%. So doing this manually has been my only way. This chipset thing is another discovery for me and as I read on in forums, there is a hidden way to do these updates the manual way and to make sure your updates stay.

Hence why I am asking here to see what anyone else knows. There is a post here from 2009 that has a lot of info on this, but they are talking about an out dated chipset driver in regards to today.

Thanks again and I hope I am helping as well.

Edit: Here is what I have. The yellow highlighted ones are the ones that got changed to the now weird version number. The ones with a red dot are the ones I am asking if those should change during the installation as well or does the ones with the red dots get updated with what driver?

My System SpecsSystem Spec
22 Aug 2012   #6
Layback Bear

Windows 7 Pro. 64/SP-1

You all got me confused. The only place I have ever seen QPI is in the bios of a Asus board. Sometime QPI is use to help clock your Dram voltage. Does QPI mean something else I'm not aware of?
My System SpecsSystem Spec
22 Aug 2012   #7

Windows 10 Pro 64-bit

My first question is "IF" it is suppose to be there, under the device manager under system devices. I am not sure anymore, I thought (and a big thought) it was, but I could be wrong. So I am asking if anyone else who has this board can check and tell me my gray matter is overworked or not.
My System SpecsSystem Spec
23 Aug 2012   #8

Windows 10 Pro 64-bit

I made a mistake on the series I mentioned early, X58 is not class 6 series, it is 5 series.

@Saltgrass - If you want to update your chipset, best way I have read is download the latest ( from Intel) or Asus for your board (

open the run command, clear any contents in the field

drag the set up program to the field and it will add the entry

then at the end of it, add -overall so mine looked like this (there is a space between the " and the -;
"C:\Users\username\Desktop\Setup.exe" -overall

The update did fix a couple of new issues that arose about 1 month ago, my speakers were making a popping sound during shutdown and boot up. Also I had this weird "brrr" every now and then. It even carried over to the new SSD's full clean install. I checked grounding from the case, power supply, the pins to the plug, etc and all was grounded. Now with the update, these two issues are gone. So from that I am happy, but many questions as you can see from the first opening thread.
My System SpecsSystem Spec
23 Aug 2012   #9

Windows 7 x64

Intel does not seem to have updated drivers for this board. I have had it since before Windows 7 came out.

The ASUS drivers appear to be the same as I have.

Chipset on the update is described as Intel 5 series/3400..

I think my system is about as up-to-date as I can make it. Sorry I can't help.
My System SpecsSystem Spec
23 Aug 2012   #10

Windows 10 Pro 64-bit

Sorry I cannot help you either. I have an e-mail going on at Intel as well. So far it does appear that the last version could be the and that the one Intel provides ( are for the new chipsets like the x79 and what not. I still covers the older chipsets, but I am asking for them to confirm my theory.

So some files do get updated, I have 9 system device entries updated. I was able to check the files too. Originally the files were version 6.1.7601.17514 for these 9. Now they are version

Also I checked and the 6.1.7601.17514 were from Microsoft and they were a file called OEM12. When I updated, a new OEM17 was created and the version is from Intel. The old OEM12 is still there for some of the other items in the system devices. In other words, if the OEM12 took care of (let's say) 40 items in the system devices, with the update 9 are removed and they now have their own file (OEM17). But the OEM12 file still needs to exist because it is now handling the remaining 31 items. Not sure if that is clear, sorry if not.

Anyways, I think I am getting somewhere though. At least updating fixed my issues. I'll follow up with Intel and get back here with the answer.

Edit - I know this seems futile, but I have seen weird things. Example, client of mine tried running Microsoft Security Essentials and it would get about halfway or almost done and then BSOD. Spent hours, to feel better I started to look for updates. I updated his BIOS and viola, MSE did full scans. I ran it 18 times (9 quick scans, 9 full scans) and never a BSOD. Who would have thought the BIOS to fix that!!! 2 months later, client can still run MSE without BSOD's, system is fine.
My System SpecsSystem Spec

 X58 Chipset Update

Thread Tools

Similar help and support threads
Thread Forum
90% cpu usage after AMD chipset update
Since I have all SATA HDDs now, I recently switched to AHCI. Following this I started to get a lot of keyboard lag in some programs. This seemed to be linked to the Microsoft AHCI drivers, so I updated to the latest from AMD. Now the keyboard lag is gone, but one of my cpu cores is always...
Cannot find Chipset update for Windows 7
I have tried on Google to find an update for my NVIDIA nForce 780i SLI SPP Chipset but only found updates for XP version. Anyone have links?
Intel Chipset Drivers Update
As advised in another thread I have downloaded and installed the Intel Chipset Drivers Update but the nothing happened to the unknown device I see in Device Manager. The installation completes instantly and I see that this indicates the drivers in the update are not needed by my system. I am...
Chipset update bagged my powered usb ports
I f you look @ my system you'll see I own a Dell XPS Studio 1640. I recently grew tired of Dell's lack of chipset updates. So I went to Intel and DL'd the latest CS. All was/is fine except it knocked out the afore mentioned powered usb ports. As in I can charge a device via usb while my system is...
Hardware & Devices
Chipset Update ???
I have installed WIN 7 Pro 64 bit on my HP Dv7 1000 laptop and everything seems to be working fine. No issues at all. I have reinstalled a couple drivers I needed to get things like the fingerprint detect and webcam working. So with those now working I am happy. Reinstalled all my applications...
update chipset ?
OK...I've decided to install the 64 bit version. My motherboard is Asus M3A78-EM which has AMD chipset. I looked at the Asus site at the updated drivers for Windows 7 64. They have the updated chipset listed as NVIDIA nForce Chipset Package Driver V15.49(Chipset version for Windows 7 64bit...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App