Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SMC Ez Connect 2.0 Draft n doesn't work

16 Sep 2009   #1

Windows 7 RTM
SMC Ez Connect 2.0 Draft n doesn't work

Hi guys, hope you can help me out. I just bought a new computer and everything's working fine but my older USB Wireless adapter, which windows doesn't recognize for some reason. What happens is, I'll plug it in, windows starts looking for drivers to install and takes ages, then gives me an error, can't install them. I tried installing the drivers on the SMC website but basically after installing them (have to install on compat mode) the program just doesn't detect the wireless adapter. I tried installing, rebooting and reconnecting the adapter, but the same happens, it tries to install drivers for it, fails, and the program keeps saying there's no wireless adapter connected. I'd try connecting to windows update to get the drivers but well, that adapter IS my internet access :P

I have both this and this. Basically the same thing happens with both. Also, if I reboot with them connected, it takes ages to shut down and restart. Everything else works great though, I'm really enjoying this OS. Hope you can help me!

PS: I did try downloading the drivers from the update catalog but no luck there, maybe there's something else I need to try.

My System SpecsSystem Spec
23 Sep 2009   #2

Windows 7 RTM

Can't anyone help me? please
My System SpecsSystem Spec
29 Sep 2009   #3

Windows 7 RTM

This is probably related to something other than the devices themselves. I tried installing vista x64 ultimate and pretty much the same thing happened. How can I help you help me? Screenshots?
My System SpecsSystem Spec


 SMC Ez Connect 2.0 Draft n doesn't work

Thread Tools

Similar help and support threads
Thread Forum
acer aspire 4738' s bluetooth doesn't work but wifi work?
Acer aspire's Bluetooth doesn't work since I bought it I've installed drivers too but it doesn't work what should I do. In its specs it has Bluetooth . But there is no Bluetooth device found in device manager how to repair this. Please HELP!!
Hardware & Devices
still looses connect/doesn't connect - win 7 wireless home network
She keeps loosing connection, then has to wait until it decides it can connect again. She would wait about five minutes and then click on something and would gain access. the ...
Network & Sharing
My bluetooth doesn't work. bttray doesn't open.
Hello. I am quite new here, but I've been wanting to get this problem solved for a long time, and I haven't seemed to get any answer. So here's my problem: I bought my Asus N53SV for around a year ago, and it worked great. But for some reason something changed. When I try to open bluetooth,...
Updated Dell Wireless 1505 Draft 802.11n WLAN Mini-Card Worse Connect
I currently use drivers from 2008: Driver Version - 10/1/2008 for my Dell Wireless 1505 Draft 802.11n WLAN Mini-Card. Whenever I run Microsoft Update it tells me to upgrade to the latest drivers, however, with the newest drivers I experience a SIGNIFICANT drop in throughput-...
HELP: power option doesn't work - screen saver doesn't start!
I have an ASUS notebook running windows 7 64-bit. I am using the QuietOffice power profile, however the screensaver won't kick in no matter what I do, and the display does not turn off even though I set it to be after 5-minutes of inactivity. I don't know if there is something running in the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:22.
Twitter Facebook Google+