Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: His HD 4670 ATI Vga Problem !

19 Sep 2009   #21
jfar

Vista Ult64, Win7600
 
 

Hi, and you say you installed the latest drivers from ATI, is that correct?


My System SpecsSystem Spec
.
19 Sep 2009   #22
rcmadawala

windows 7 ultimate build 7600.16385
 
 

yep. i installed ATI Catalyst™ 9.9 Display Driver
My System SpecsSystem Spec
19 Sep 2009   #23
jfar

Vista Ult64, Win7600
 
 

Hi, I haven't installed mine yet from ATI, so can you upload the same two pics as these, from the Device Manager please.

His HD 4670 ATI Vga Problem !-1.png

His HD 4670 ATI Vga Problem !-2.png


My System SpecsSystem Spec
.

19 Sep 2009   #24
rcmadawala

windows 7 ultimate build 7600.16385
 
 




I installed another driver after trying Ati 9.9 driver. because dinesh said try that one.you can see his link in 1st page of this thread.but it didn't help me
My System SpecsSystem Spec
19 Sep 2009   #25
jfar

Vista Ult64, Win7600
 
 

Yes I saw that, now I have just installed the latest 9.9 drivers for my machine, and they are making everything flicker when I use my mouse, so obviously they are cr..p,
so I am going to UNinstall them Immediatly, I am going to try the ones for Vista, and we will see if they're any better, be back soon, I hope.
My System SpecsSystem Spec
19 Sep 2009   #26
jfar

Vista Ult64, Win7600
 
 

Ok I didn't change them, I had an idea just after I wrote the post, that hey, maybe I should just reboot, which I did, and that seems to have stoped all the flickering.
My System SpecsSystem Spec
19 Sep 2009   #27
rcmadawala

windows 7 ultimate build 7600.16385
 
 

Ok. i thought ATI is good.but now i know ATI is a totally ****
My System SpecsSystem Spec
19 Sep 2009   #28
jfar

Vista Ult64, Win7600
 
 

What about the monitor, did you try for the latest drivers for it?
My System SpecsSystem Spec
19 Sep 2009   #29
rcmadawala

windows 7 ultimate build 7600.16385
 
 

i installed monitor drivers.i hate ATI. pls help me
My System SpecsSystem Spec
Reply

 His HD 4670 ATI Vga Problem !




Thread Tools




Similar help and support threads
Thread Forum
Sapphire radeon hd 4670 - Need Help!!!!!!!!!!
I am facing a lot of problem with my Sapphire radeon hd 46701gb ddr3 card. This is my second thread to help me for solving this problem. Aero doesn't run even with the latest driver or the old drivers i have tried all the things like enable force to run aero that doesn't work. And also use services...
Graphic Cards
Missing inf file for my hd 4670
Well i had a blue screen problem and it happened to be my video driver. so i tried to uninstall all the display drivers and it work. so im here happy and i go to download the latest driver from ati and during installation i get the "missing inf file" right after my screen flickers (normal for...
Drivers
ATI Radeon 4670 Display Port Problem
I have an ATI Mobility Radeon HD 4670 (on my Dell Studio XPS 1640 notebook) and I just tried to use my external monitor (Dell P2210) through a DisplayPort cable, but it did not work in Windows 7 (x64). It did display the BIOS and the Windows startup screen, but after the startup the (external)...
Graphic Cards
Sapphire Radeon HD 4670 and second VGA card problem
Had a frustrating afternoon trying to get my triple-monitor setup going again; I had WinXP for years with two video cards: a single, simple VGA / PCI card, and a recent Radeon HD 4670 card with two outputs. Under XP everything was recognized without incident, first repeating all three monitors and...
Graphic Cards
sapphire 4670 problem
hey i just signed in this forum.and i need some serious help.i bought a sapphire 4670 graphics card few days ago.then when i tried to rate it using windows7 experience index my display goes off and then never comes again.i restart the pc but in vain.my pc dont get my card anymore.i went to the...
Graphic Cards
help ATI 4670 driver problem
Everytime I try and install catalyst 9.6/driver, my screen will display only the background picture, nothing else. Ctrl-alt-del turns the screen black, esc out and back to background picture. Had to go safe mode and system restore everytime. Driver shows up in microsoft updates and same result....
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App