Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 1608: InstallShield Error when trying to update USB Drivers

13 Oct 2012   #1

Windows 7 Professional 64Bit
1608: InstallShield Error when trying to update USB Drivers

Hello, this is my first post so I hope someone can help me.

I've recently built my PC and I'm having problems with some USBs at the back of my computer. I realise that this can be considered a motherboard issue but please let me fully describe the situation.

Motherboard: Gigabyte Z77X-D3H
BIOS Version: F15 (Up-to-date)
OS: Windows 7 Professional, 64 Bit.
RAM: Crucial 8GB (2x4GB) DDR3 1600Mhz Ballistix Sport Memory Kit CL9 (9-9-9-24) 1.5V
Processor: Intel 3rd Generation Core i5-3570K

My device manager shows that the USBs are indeed, not working:

Windows tries to update these drivers, but to no avail:

And so I've proceeded to go directly to the manufacturer's website and download the VIA USB Drivers. When I begin the setup, it seems to work initially but then abruptly brings up this message:

I've tried the solutions found on the Microsoft Support webpage, by attempting to install it in both Safe Mode and after a Clean Boot. But the same error applies with the Clean Boot and an 1607 error instead during Safe Mode. I've tried using Right Click > Compatibility Mode but that didn't work either.

I've also tried different Setup.exe files for the driver update but they all come with the same message. I've looked up the 1608 issue and found that this has happened for a few games (Flight Simulator and some Finding Nemo game) and am confused to why is it happening now. I have successfully installed applications before, and even some games (via. Steam).

In addition, I should mention that I've updated Windows Update fully and I've used Run As Administrator in all occasions, I am also the only user on this computer.

I've tried to follow: Microsoft Games: InstallShield Error Messages but the FixIt didn't fix it.
I've seen lots of suggestions to go to Download: Windows Installer 4.5 - Microsoft Download Center - Download Details - but there's never an option for Windows 7. And I've checked and found that my Installer is enabled.

I've also just made another Administrator account and attempted to install, it also failed with the same message.

Thank you very much for your time in reading this, I hope this post abides by the forum rules and really wish someone can help me.

I also have another issue but it is less pressing than this current one. This message keeps coming up during Startup:

Any ideas? Many thanks again!

EDIT: I've put in the Utility CD included with my motherboard and it has gotten rid of 3 of the 4 Exclamation Marks. But the USBs still don't work and I still cannot install the drivers.

My System SpecsSystem Spec
13 Oct 2012   #2
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I would remove all games and what ever programs until I got the system working properly with all of Windows Updates. I don't understand your motherboard c/d fixing 3 usp ports and not 4. I would check all motherboard connection again and their/there harness. Did you make a note what Bios the motherboard came with. That is what I would use.
My System SpecsSystem Spec
13 Oct 2012   #3

Windows 7 Professional 64Bit

I find it very strange too! I thought it was all solved but then just one remained (The USB Controller); I find it odd how they all don't seem to be working despite making one USB Controller disappear.

I do remember my BIOS version (F7) - but I only updated the BIOS because I thought that it was the problem; frighteningly, it said "No Operating System Detected" after successfully updating, and after a reboot it had restored my Windows normally. Are you suggesting that it could be that the F7 version would've worked with the Utility disk and the F15 version is causing the problem? I would still like to try to install the VIA Drivers before attempting to fiddle with any BIOS changing. Thanks for your reply, but I'd like to mention that my system is pretty bare at the moment, not much has been installed.
My System SpecsSystem Spec

13 Oct 2012   #4
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

The way I do it is; Use the Bios as they were when you got the motherboard. The reason is it worked for the manufacture it should work for you. Just because their/there is a new Bios doesn't mean you need it. Bios and drivers updates are to solve problems some people are having. If you don't have those problems I recommend leaving the Bios and drivers alone. Get the system working then if you have problems that a possible update addresses try it. All Bios and driver updates arn not for all systems.
Example: My motherboard Bios are 502 the three newer ones cause problems.
My Nvidia driver is 268.96 July 20,2010 anything newer cause problems.
New Bios and drivers don't fix problems you don't have.
My System SpecsSystem Spec
14 Dec 2012   #5

Windows 7 Professional 64Bit

Many thanks for your reply, I'm afraid to report that I am still suffering from this InstallShield Error and have attempted to post on their forums, unfortunately my post is pending moderation. I have browsed through their knowledge base: Flexera Software - Knowledge Base, but all the relevant articles won't work for me! I have tried both Chrome and IE to view.

EDIT: Example Article: 0 139999574 - Unfortunately I can't seem to link the other results when I type in, "1608 Unable to create InstallDriver" in the search box.

I have contacted Gigabyte's Support Team and they instructed me to update the BIOS, which I did, again. It's now at F16. They have now instructed me to Reinstall Windows, but I had already tried to "Repair Windows" previously. Is there a method to uninstall Windows without Formatting the disk and then Installing windows again?

Much appreciated as always.
My System SpecsSystem Spec

 1608: InstallShield Error when trying to update USB Drivers

Thread Tools

Similar help and support threads
Thread Forum
BSOD While installing anything using installshield , error 0x000000f4
As the title says... Things done -Looked for new drivers (all are up to date according to Asus) -Upadated Bios -Ran memtest86+ (passed) -Ran seagate tools on seagate drive (passed) -also ran chkdsk -and fsc
BSOD Help and Support
InstallShield error while attempting to install drivers
I tried to install wireless card drivers for my laptop (via InstallShield Wizard), but during setup Windows froze, so I had to restart the OS.Next,I ran the setup.exe once more,but I encountered the following error: How can I solve this issue?My laptop is running Windows 7 Home Basic x64.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:00.
Twitter Facebook Google+