Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: NO sound whatsoever with Realtek AC'97 and SPDIF output

20 Oct 2012   #1

Windows 7 32bit
NO sound whatsoever with Realtek AC'97 and SPDIF output

This one has got me pulling my hair out!! I hope you guys can help.. I'm surprised I havent found anyone else in my boat out there!

I have a little Shuttle G2 6100H, also known as the SB61G2v3.It has the FB61 v3 motherboard made by Shuttle themselves and an onboard Intel Springdale 865 chipset. More importantly, it has SPDIF in and out and uses the Realtek ALC650 chip AC'97 audio codec with the Intel ICH5 chip for onboard audio. I'm running the latest chipset drivers and latest drivers from Realteks own website.

Now here's the problem..

I have hooked up my amp with optical input to the Shuttle's optical out via a TOSlink optical cable. The red lights shines through it, just as it should and connects fine at either end. In Win7, I select 'Realtek Digital Output' to be the default output and when I click to hear the test sound, I see the green bars bouncing but hear nothing at all, absolutely nothing!

Now, I checked over all the obvious, I checked the same cable and used it to connect my laptop to the amp via SPDIF and no problem, everything was perfect. That rules out amp settings/cable problems. I even played around with different settings on the amp, like stereo, auto, 5.1 etc, no change. I checked all menus in Windows for levels/muting found nothing stopping it. Set up media center with spdif settings to see if that would output anything but nothing. It is probably worth mentioning at this point that my normal stereo output via 3.5mm jack is absolutely fine.. this is what is also intereting, I connected my laptop via SPDIF to the SPDIF in on the shuttle and that works fine, I can the hear sound through my analogue jack so that means its just theSPDIF output that is giving me the shits!!!

What I dont understand is that, why does it emit the light if it is not sending anything? Surely also this means that it is not a faulty connection on the motherboard.. So anyway.. I'm surprised nobody else has had this issue.. maybe its just because I'm the only one trying SPDIF on this particular board in Win7.. but any ideas?? I'm now officially desperate!!

My System SpecsSystem Spec
20 Oct 2012   #2

Windows 10 64 bit

I suspect its the frequent XP hardware and Windows 7 compatibility issue. According to the Shuttle site, this is a Windows XP model PC. I tried to look for drivers using both SB61G2v3 and GS62100H and didn't come up with anything on the Shuttle download site.

There is also the issue of which driver will work properly and with full functionality. Generally, the PC vendor (or motherboard as applicable) drivers are preferred. Non-Vendor drivers (including the sound chip hardware vendor's drivers) can either not work at all or not work properly. On our forum sound section you will see many cases of this. I used to do a lot support on the Dell users forum and this was a common issue with the Dell's - only Dell supplied drivers worked properly. Some sound chip manufacturers don't have any drivers and refer users to their PC or motherboard vendor for drivers, I've seen one sound chip manufacturer that has some drivers but they have a statement on the driver download page that the drivers supplied may or may not work, no guarantee, and that the PC/Motherboard vendor should be contacted for drivers.
My System SpecsSystem Spec
21 Oct 2012   #3

Windows 7 32bit

Hello fireberd and thanks for your reply..

Based on your suggestion, I went back and downloaded the the drivers available for XP 32 bit and they installed into my Win7 32bit fine.. however still only getting SPDIF as a recording device but not a playback device.. I installed drivers with compatibily mode switched on and again with it switched off but it didnt make a difference.

Really frustrating.. I've tried everything.. there are no jumber settings or anything on my mobo for spdif, the header is plugged in tight and there is even light coming out of the hole! Tried different toslink cables..

Is there anything else I might have missed?
My System SpecsSystem Spec

21 Oct 2012   #4

Vista/Win7/Win8/Win10 (x86/x64)

Hi JOgz,

I have the 865 chipset too, although on a different board by Intel.

I do recall when first installing Windows 7 that I had no sound at all - surprising that there were no drivers within Windows 7 to support Our 865 5chipset.

I remember then searching google with my audio drivers PCIVEN_8086&DEV_24D5&SUBSYS_A0008086&REV_02 ...number and eventually it brought me to download drivers for it which were SoundMAX Intergrated Digital Audio drivers v5.12.5240 ...which did work, and interestingly a month later I happen to notice Windows Update had an even later update which brought it to v5.12.1.5410, of which I took and installed.

My SPDIF does work and I use it 'occasionally' when I connect to our main TV setup so that I get the 5.1 surround to work for a downloaded movie on my computer.

I'm sure you have already, but did you try swapping out your optical cable with a different one, even a different brand! ...just to make sure somehow it's not within the cable itself or how it 'seats' fully within your particular jack. Just because that one cable works for one of your units does not mean it will for another if it's because of physical seating issues - I've seen this happen, and seen even some get around it by physically modifying the base of the cable end itself if it did not seat fully right; the plug end lengths of some brands are longer than others, etc, affecting seating in various jacks differently. The fact that you see the light is not the final indication.

Anyway, just some suggestions, good luck.
My System SpecsSystem Spec

 NO sound whatsoever with Realtek AC'97 and SPDIF output

Thread Tools

Similar help and support threads
Thread Forum
Staticy Sound output (only over Realtek Device)
ok i've allready tried some varios steps (Disabling various devices one by one/drivers) tried Disabling S/PDIF, tried Disabling LAN (as i'm over Wifi), tried disabling the Nidia Sound (HDMI out) as well teh "Additional ports" w/o any success. this occurs reguardless the Media Player, i've...
Sound & Audio
My SPDIF Output sends bad data
Hello SevenForums, This issue just occurred out of nowhere, my optical audio output used to work fine. Now when i set my "Realtek Digital Output" to default, the bars work as they should and the red light passes through the optical fiber cable. But when it reaches my "receiver" (Logitech...
Sound & Audio
No sound from SPDIF Xonar DS output to TV with Windows 7
Ok before I had Windows XP...have a Xonar DS Audio card with a SPDIF output going to my Nvidia 9500GT Video card...the video card is connected to my Yamaha V-867 Reciever via HDMI and then of course the reciever to the TV via HDMI. So with XP it worked great. Had the video card set via the...
Sound & Audio
less /unsatisfied sound output of realtek alc 892
Hello I've bought a new system with AMD athlon ll x635 2.9ghz , motherboard TA890gxe ram 2gb kingston . I've installed Windows 7 x64 and i've also installed all the drivers provided by the biostar TA890gxe motherboard CD. The TA890gxe has realtek alc 892 codec in ....
Sound & Audio
spdif output not working properly
Hi , i have been using Windows 7 RC for awhile now .I have the coaxial spdif output on my Gigabyte Ep 45-ds3r board connected to my home theartre amp.Have been getting 5.1 sound with no problems.I recently installed Windows 7 enterprise edition to my pc and now only have 2.1 sound.Have tried the...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:16.
Twitter Facebook Google+