Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Root Hub Issues in RTM

29 Jan 2013   #11

Windows 7 Home Premium x64
UpperFilters WARNING

A word of warning on the "UpperFilters" regedit method:
applying this caused my laptop to no longer recognize my (internal) touchpad and keyboard.

As I was trying this out on a computer with USB problems,
this resulted in having *NO* input devices left whatsoever.

I would recommend:
  • backing up the registry key before you delete it (in case you need to restore it)
  • setting up your computer for some form of remote acess
Best of luck!

P.S.: did not resolve my USB Root Hub issue :-/

My System SpecsSystem Spec
28 Apr 2013   #12

windows 8 enterprise

Quote   Quote: Originally Posted by DaMoose View Post
Just a follow up post to say I solved the problem.

If anyone else with the same problem should stumble upon this topic, my issue was a conflict with LibUsb-Win32, which I had installed in Vista in order to have my PS3 controller usable in Windows.
DaMoose, you are Da Man!! Just upgraded from windows 7 to windows 8 and had the exact same issue. I was almost running desperate but you seriously saved the day! Thanks bro!
My System SpecsSystem Spec

 USB Root Hub Issues in RTM

Thread Tools

Similar help and support threads
Thread Forum
xHCI root hub
I purchased this small card to add 4 USB 3.0 to my system and it came with an useless CD (no driver). It figures on my device manager as "xHCI root hub 0". After to browse online I only found a bunch of crap sites with no driver at all and that instead are sponsor traps that keep bouncing you...
Intel USB 3.0 root hub and USB root hub registries missing/incomplete?
Ok, so I've run into a very tricky spot: Yesterday, I successfully resolved a windows update issue (thread can be found here: ). Basically, one problem led to another and I ended up...
Cant Browse UNC Root from XP to 7 after SP1
Hello, This problem has been annoying me for a few days now and I can't figure out what it is. If I browse my Win7 PC via UNC (\\192.168.0.x) on an XP PC I am unable to get a list of shares. If I Directly open \\192.168.0.x\ShareName that will work perfectly. I have a vista PC on the same...
Network & Sharing
root directories
I need to edit the .ini file in a program I've loaded but Windows 7 does not show the root directory. I've used the Command Prompt to access the program file and the root file is not displayed. I've tried to search for the .ini file but the system says it can't find it. Can anyone help?
General Discussion
Windows 7 Usb root hub problem
I'm using the build 7600. It all started when i inserted a SD card. It didn't work so I inserted the SD card on my camera and plugged it in by usb. The second I inserted the usb to my laptop my usb mouse turned off and my wlan just literally vanished(it wasn't even in device manager.) Usb root...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:37.
Twitter Facebook Google+