Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Blu-Ray Drive Not Functioning

26 Jan 2009   #11

Windows 7 X64

This is a little off topic for that I apologize and If I have broken any rules by doing so, please let me know so I know not to again!

But all the blu-ray burners I see are at a max or f what 4x write? so a single layer blu-ray disc is 25 gigs how long does it take to burn a full disc, do they even sell dual layer blank blu-ray discs yet?! The other question I have is when do you think the blank media will come down in price, seen one sigle blank 25 gig blu-ray disc for $24

My System SpecsSystem Spec
26 Jan 2009   #12

Windows 7

Windows 7 is very good but Windows 7 not saport sound dirver= p4 + doul cor

in motherboard intel = 865 = 945 only saport intel core 2 deo

UPDAT only HD sound dirver TAHANKS

PLEASE- GIV ME sound dirver PAC = p4 + doul cor== TAHANKS
My System SpecsSystem Spec

 Blu-Ray Drive Not Functioning

Thread Tools

Similar help and support threads
Thread Forum
USB 3.0 Occasionally not functioning
Hi all, I'm using an Asus A53SV laptop running on Windows 7 Home Premium 64x Occasionally when I start my laptop, I'll find the USB 3.0 not functioning. I would plug a USB hub as there's not enough USB ports for all my devices. Whenever the USB 3.0 is not working, I would use the driver from...
Hardware & Devices
ICS - No longer functioning.
My setup: Windows 7 Home 64bit - quad CPU - 8GB ram - Available Virtual memory 14GB NIC 1 Internet - trying to re-setup ICS NIC 2 XBOX360 What happened recently: Everything worked fine with ICS, however I wanted a router with wire + wireless connections so I could use the wii and DS...
Network & Sharing
Java not functioning.
Several times I have installed/reinstalled java but Win 7-64 Home Premium does not allow this to run. Programme is installed but applications, e.g. ping test speed test are reporting Java requires to be installed. Any assistance appreciated. Thanks.
Homegroup is not functioning
We have 3 pc's, 2 laptops on our homegroup. I recently upgraded one of the pc's and couldn't get it connected again to the homegroup. Since then, I've tried the suggestions on the forums, and still get errors. I'm unable to leave/remove the homegroup on the host pc. I can't view/print the...
Network & Sharing
Optical Drive not functioning
I have a Toshiba Satellite Laptop which is running Windows 7 Home Premium 64 bit. I don't know how long it has been since the DVD drive stop functioning. Whenever I insert a factory DVD,CD, or even custom/ blanks my drive does not recognize the inserted device. For some reason, which I cant...
Hardware & Devices
UAC not functioning as expected
My apologies if this is not the correct forum for this question/issue. We have several Windows 7 professional systems. Most of them function as expected, however we have a few that do not. Case in point: We have two windows 7 pro 32bit systems that have the same identical setups, same...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App