Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Synaptic touchpad can't kill "Tap to Click" - Acer Aspire 5741

13 Feb 2013   #1

Windows 7 Home Premium 64bit
Synaptic touchpad can't kill "Tap to Click" - Acer Aspire 5741

I just had to replace the top cover, including touchpad, on an Acer 5741 running Windows 7 64 Home Premium. The cover appears identical to the old one, and everything works, but the symantics touchpad software doesn't recognize the touchpad as a touchpad; it shows as a "wheel mouse on PS/2 port". Therefore, I can't turn off the incredibly annoying "tap to click" function. The option to disable tap to click is grayed out... it appears that's because the touch pad is seen as a "mouse" not a touch pad, as it was before.

When no drivers are installed, Device Manager just sees it as a PS2 Mouse. When drivers are installed, Device Manager sees it as Synaptics PS/2 Port Touchpad.

Acer identifies three manufacturers of touchpads on the 5741 on its support website. I have tried all three; ALPS, Synaptics, and Elan; the Synaptics drivers install and work as above; ALPs installs but doesn't provide any control, and Elan doesn't even install.

At the recommendation of the vendor of the laptop cover, I tried a site called "magicdriver" to help identify the hardware, since Windows apparently does that based on the drivers. It does appear to be a synaptic touchpad based on "hardware ID" under properties, details, via device manager.

The OS is entirely up to date. I have tried the latest Synaptics drivers, I have tried using the original driver version that came with the laptop, and I have tried a couple of versions in between.

Does anyone have any suggestions on how I might correct this? Are there any utilities that I can use to kill "tap to click" generally? Anything in the registry?

My System SpecsSystem Spec
16 Feb 2013   #2

Windows 7 Home Premium 64bit

I determined that the touchpad in the replacement top cover was from Elantech. Even when deleting the Synaptics drivers under "uninstall programs" and deleting the driver in device manager along with the "PS/2 mouse" the device ID code implies that the hardware manufacturer is Synaptics. I downloaded the "Acer" versions of all three manufacturers' drivers from the Acer support page, then extracted them all to separate directories. I then installed and uninstalled them all. The key was to use "Update Driver" from within Device Manager to get them to properly install. That was hours of my life I'll never get back!
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Acer Aspire - Windows 7 reinstallation stuck on "Setup is starting"
Hi all, I am trying to reinstall Windows 7 on my notebook (Acer Aspire 5742-7645) from the DVD. I get as far as this screen: When I click "Install now," the screen says "Setup is starting..." and then never moves on. I have gone into BIOS...
Hardware & Devices
Acer Aspire 5349-2899 locked "Setup is installing services" grandkids destroyed their computer. Don't know what they did but getting "setup is starting services" and it's frozen. Am not able to get past it. Did try one suggestion: On the same error screen press SHIFT+F10 and...
Installation & Setup
Acer Aspire Alt+F10 Failure - "ERROR: failed to copy napp7.exe to ram"
Hey guys. Recently my computer's been having an infinite reboot issue, so I looked on various websites on how to fix said problem. Each website I went to directed me towards the alt + F10 method, but whenever I try to use this method it says "Please wait a moment..." for about 10 - 20 minutes then...
Backup and Restore
Acer Aspire 1410's trackpad "killed itself" :s
Guys, three days ago I was using an Acer Aspire 1410 notebook until I mistakenly pressed the disable trackpad key on the keyboard for the one which turns off the display. I have hit on that key previously various times, but for the first time it permanently disabled the trackpad on the little pc....
Hardware & Devices
Acer Aspire 3690 w/ Conexant: "No Audio Output Device is installed"
Greetings and salutations. I recently upgraded an Acer Aspire 3690 to Windows 7 (32bit) and everything went well, almost. See, for life of me I can't get audio to work. (That old chestnut.) The speaker icon in the notification area displays the white cross/red circle and informs me that "No...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:18.
Twitter Facebook