Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB device not recognized, code 43. All usual fix methods not working.

19 Mar 2013   #1

Windows 7 x64
USB device not recognized, code 43. All usual fix methods not working.

This just randomly happened while I was on the internet, but my USB mouse stopped working. I didn't think it was a big deal so I just unplugged the mouse, and plugged it back into a different port. I got a pop up that said "device not recognized". So, I just rebooted the computer, and tried to plug the mouse in again. Still, same message no matter which of the four ports I plug into. It doesn't matter what device I use either. I have a USB webcam that does the same thing. These devices work perfectly on two other computers, and I've confirmed that since this issue began yesterday.

So I go into the Device Manager, and try to uninstall the driver and reinstall. That doesn't work. I tried to update the drivers, that doesn't work either. I've tried to uninstall everything under the Universal Serial Bus Controllers drop-down flag in the Device Manager and then restart, that didn't work.

I've tried restarting in Safe Mode, and then running the command line "sfc /scannow", and it didn't detect any problems. I've tried it in normal mode with and without the mouse plugged in. Still didn't detect anything.

I ran a System Restore to my earliest point, and that didn't work either. I ran everything in CCleaner (why not), Emergency Kit Scanner and Avast, and that didn't detect anything. I ran the download from the Fix It Center from Microsoft. It just tells me what I already know...nothing.

So I then I unplugged my laptop, took the battery out and let it sit overnight while I slept. Plugged everything back in when morning came and plugged my mouse in and it worked, for literally two minutes. Then my mouse went dead again, and the problem resumed. No it's being even worse, because when I plug something into the USB port it won't say anything until I unplug it. Now in the Device Manager it'll have three unknown devices listed, but nothing is plugged in.

That's what leads me to believe it's a software issue, but I've been using this laptop (Toshiba hand-me-down) and Dell mouse for over a few months with no issues. I've explored every forum I could find, tried all of the tips and tricks, and still nothing works. Is there something in the registry I could do? Is it possible I have some weird virus (I feel stupid for asking that)? If I had a Windows disc I would just reformat the hard-drive, but I'm not sure any of that would help anyway.

My System SpecsSystem Spec
19 Mar 2013   #2

Windows 7 x64

No one knows? Is it a hardware issue then?
My System SpecsSystem Spec
20 Mar 2013   #3

Winndows 7 32 bit

Hi FirebatHero,

It could either be an issue with the Mouse, USB driver or USB ports itself. Please connect the same mouse to a different system to ensure there is no problem with the Mouse.

Once that is verified as you have already reinstalled the driver you should reinstall windows on the system and then drivers. You should request the backup disc from the manufacturer for the same.

If that also fails then you should consider replacing the USB ports or the complete motherboard depending you have seperate USB ports on the system or not.

However, would still suggest before replacing any hardware you should get the backup discs and try the windows re install on the system.

If you have any further queries please feel free to contact us.
My System SpecsSystem Spec


 USB device not recognized, code 43. All usual fix methods not working.

Thread Tools

Similar help and support threads
Thread Forum
Advanced Recovery Methods not working
Hi guys. I'm having a problem with being able to bring up the Advanced recovery methods from my Backup & Restore program. I have know idea when this started because I haven't ever used it since I've had my laptop. I went to explore it this morning and found when I click the link "Advanced recovery...
Backup and Restore
Permissions Needed for Old Hard Drive Usual Instructions Not Working
Hello I have an old hard drive and just recently bought a docking station. I have been trying to delete some files off of it and transfer new files. It says I need permission. I have searched around on the internet and found the two solutions below.. neither worked for me. How can I get...
General Discussion
"USB Device Not Recognized" but the device is working fine.
This has become a great annoyance to me. Whenever I have my keyboard and mouse plugged into my computer (the mouse uses a USB port on the KB (it's a G-15)) I keep getting messages of "USB Device Not Recognized", however, the mouse and keyboard work perfectly fine. It's not really a problem, it's...
Hardware & Devices
Getting Code 43 but all Device's are working
Hi I am trying to figure out what I have to do to repair (code 43) , Every divice that is hooked up to a USB port is working perfect, but when I go to windows 7 Printer and devices I have this message on one device Port#0003Hub_#0006 Windows has stopped this Device because it has reported...
Hardware & Devices
(Code 43) - USB device is not recognized.
Please tell me if this is not the right sub-forum. I've been encountering error Code 43. I've tried a lot and I am running out of options. I'm working on an Acer Aspire 5542G. My operating system is Windows 7. The USB device not being recognized is my Wacom Intuos 4 PTK. - I've...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:27.
Twitter Facebook Google+