Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Prolific USB-To-Serial Driver

18 Oct 2009   #31

Windows 7 Ultimate 64-Bit

I am actually running 64-bit and I think that is the problem. Anyways, I had a copy of VMware Workstation and just mounted the USB. It worked.... This will get me by since all I am trying to do is get my Pioneer Plasma calibrated with ControlCal. ;-)! Thanks for all the help guys... Especially Kegobeer!!

My System SpecsSystem Spec
19 Oct 2009   #32

Windows 7 Ultimate x64

I really don't know where your problem is. The Win 7 driver from prolific installed and works here without any issue. No compatibility mode, nothing. Driver version is (ser2pl64.sys), and there is a second file (serenum.sys) from Microsoft, its version number is equal to Win 7 RTM.
My System SpecsSystem Spec
19 Oct 2009   #33

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by pattont View Post
Maybe before posting a comment like that SillyMan you would assume that I would have tried that. The site says that it supports Windows 7 64-Bit, but I can assure you that it doesn't.

Any suggestions?
And I can assure you that it does!
My System SpecsSystem Spec

23 Jan 2010   #34
Miro H

Windows 7 64-bit

I tried everything that was said here and it still did not work. Every time it said

"The name is already in use as either a service name or a service display name."

What was strange is that first I had Windows 7 32-bit version and installed some Profilic drivers for Vista and it worked with no problem.

After that I did a clean install of Windows 7 64-bit version and used the same drivers. But in the middle of installation it said that drivers are not digitaly signed and since then nothing I tried worked. I downloaded the latest drivers from Profilic site, but it didn't help.

So I tried many things and finally found a solution and wanted to post it here.

First I removed all the drivers like it is said here:

Removing drivers from Vista

After that I still got "The name is already in use as either a service name or a service display name." error

Then I did this procedure

You Cannot Install Driver Files for Your Network Adapter and You Receive a "Cannot Install This Hardware" Error Message

but in the part where it said that you look for network adapter

"Expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services, and then look for registry entries specific to your network adapter. For example, if you have a Linksys network adapter, look for entries named Linksys. When you find an entry, right-click the name and then click Delete."

I deleted the whole ser2pl64 directory and followed the procedure to the end.

Then I installed the usb to seriall adapter again with the latest drivers from Profilic

Welcome to Prolific

For some reason it took couple of minutes until the adapter was installed. I was affraid that there was error again and that it didn't work, because the installation of the Profilic drivers was finished and the usb to serial device in the Device manager still had the yellow exclamation mark and it was in the Other directory. I was doing something else and when I looked after 5 minutes it moved to correct directory and everything was OK with the device.

Hope this helps.
My System SpecsSystem Spec
06 Mar 2010   #35


hi, I've been struggling with this for a while.
I used the driver: PL2303_v110
It worked after I installed the certificate of the driver (right click on the .exe, "numerical signature", "show details", "accept certificate"), used the compatibility with vista and ran the whole with administrator rights.
Words aren't necessarely the proper ones, I'm translatting from french, excuse my english.
Hope it may help, before burning it.

Hope it may help
My System SpecsSystem Spec
21 Apr 2010   #36

windows 7 home premium

I had the same problem. I've found this driver and now it works great

Hope it helps!
My System SpecsSystem Spec
21 Sep 2013   #37


The Solution is this Vsta Driver that Works for Win 7 x 64 and Win 8 x64

My System SpecsSystem Spec
15 Nov 2013   #38

Windows 7 Ultimate x64

I am running w7 x64 and struggled a while until I found the trick.
1. Check the device revision. Mine is USB\VID_067B&PID_2303&REV_0300
2. For Rev_300 install older driver like from 27.10.2008 which you may find on the logilink website.
3. Windows always tries to use the latest driver, but for REV_300 go to
Device Manager
   -> Update Driver ...   
   -> Browse ..  
   -> .. pick from a list  (show compatible hardware) and select the older version
My System SpecsSystem Spec
15 Nov 2013   #39

Windows 10 64 bit

The prolific device and drivers is iffy. I don't know whether it was the actual PC's that didn't work properly with the serial adapter or my wife's Singer XL6000 embroidery machine. I had a Dell E510 desktop PC with Vista and it would work with that. I had another PC, a home built desktop with an Intel DP35DP motherboard and it would not work with that. I tried it with a Lenovo laptop with Win 7 and couldn't get the Singer to connect.

I now have a home built with an ASUS motherboard and Win 7 64 bit and it is working with that system (at least able to transfer embroidery patterns from the PC to the Singer embroidery machine).

I don't have a "breakout box" so I can't see what control signals are or aren't there, which could be a problem with some com port devices. If a handshake signal that it requires is not present the device will not work with the interface.

I've had problems with other USB to Parallel (printer) adapters and HP printers would never connect. I suspect there are missing handshake signals that HP requires. I've seen the same problems posted on the Dell forums and some other PC forums.

Looks like these types of devices are hit or miss.
My System SpecsSystem Spec
21 Oct 2014   #40

Windows 7

here are correct instructions for those trying to get it to work on windows 7 32/64
for Prolific USB Cables to serial RS232 and Drivers for Microsoft XP, Vista, W7 & W8

Prolific FTDI Windows Cable Drivers
My System SpecsSystem Spec

 Prolific USB-To-Serial Driver

Thread Tools

Similar help and support threads
Thread Forum
Prolific USB-Serial (9/4/2015) from Win Update, error 52 (signature)
I have researched the Prolific USB-to-Serial driver issues. There's loads of information and mis-information regarding the Prolific chips, the counterfeit chips, and various driver versions. I've installed several different versions including (7/31/2007), (10/27/2008),
BSOD i think prolific usb to serial
Hello Some time ago I started to get BSOD. I am almost sure part of them related to Prolific USB to serial i start to use. But i am afraid latest 2 are of some other origin. I tried different Prolific drivers, some of them do not start to work at all. (840.4 KB) Any...
BSOD Help and Support
Prolific USB-to-Serial Driver
Has anyone found a version of this driver to work on W7? Thanks!:huh:
Cant get prolific usb to seriel driver to work
Hi there… I have 2 cables witch is ”usb to seriel” One of the cables installes fine with the “prolific” driver. The other cable does not work. According to the manufactor both of the cables should work on that prolific driver..
Infuriating Prolific driver puzzle
I have just finished a new build Intel i3 on a Gigabyte GA-H55M-UD2H mobo running Windows 7. Both the PCI slots are vacant and I have no need of them. However, I have a device identified as "Prolific USB to COMM port (COM 6)" which infuriatingly loads no driver. I tried downloading the Prolific...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App