Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Intel USB 3.0 root hub and USB root hub registries missing/incomplete?

23 Aug 2013   #1

Windows 7 Professional 64 bit
Intel USB 3.0 root hub and USB root hub registries missing/incomplete?

Ok, so I've run into a very tricky spot:

Yesterday, I successfully resolved a windows update issue (thread can be found here: Unable to get any updates at all: Error 800f0900 ).

Basically, one problem led to another and I ended up having to painstakingly transfer programs from my laptop to a flash drive and then to my desktop. When I finally found out what was the problem with my USB ports not working, I reinstalled the motherboard drivers, and everything seemed to work fine--for the USB 2.0 ports.

Now the USB 3.0 ports aren't working and I have no idea why. I tried downloading intel's drivers from their site and no luck. I tried downloading from the motherboard manufacturer's site and no luck. So, I finally looked at the hardware/device manager: "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)"
My System SpecsSystem Spec
23 Aug 2013   #2

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]

This could be handy for those might want to help you sorted it out, you to System Info - See Your System Specs

Could those Usb 3.0 drivers branded from another manufacturer?
My System SpecsSystem Spec
23 Aug 2013   #3

Windows 7 Professional 64 bit

Actually, I found out what was the problem: It was another program that was causing conflicts. That program has been uninstalled and now everything works fine.
My System SpecsSystem Spec

23 Aug 2013   #4

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]

Welcome, You still can fill your specs and tell us which did the trick!:)
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
USB Root Hubs missing after windows 7 clean install
After a 'convoluted' clean install of Windows 7 Professional 64bit on a pre-installed Windows 8.1 system I seem to be missing all the USB Root Hubs although the USB3 hubs are there and I have reinstalled the Intel chipset drivers. All the USB ports are working properly both USB2 and USB3 but when...
xHCI root hub
I purchased this small card to add 4 USB 3.0 to my system and it came with an useless CD (no driver). It figures on my device manager as "xHCI root hub 0". After to browse online I only found a bunch of crap sites with no driver at all and that instead are sponsor traps that keep bouncing you...
USB Root Hub Issues in RTM
Hi there I've been running various Windows 7 Betas and RCs on virtual machines and spare PCs for a while with no issues, so when I got access to the RTM I was quite confident (probably overly so) to upgrade my laptop from Vista. Right after the install (ironically enough, from a USB),...
Intel i series (i3,i5,i7) usb Root hub problems
Hi ive got a Sony vaio f series Intel i7 laptop running windows 7 64bit home premium. Ive encountered a lot of problems with usb 1.0 devices, Microsoft and Intel are aware of the problems but they still arenít fixed. First I have had alot of issues with rane scratch live SL1, which is a usb 1.1...
Hardware & Devices
Cant Browse UNC Root from XP to 7 after SP1
Hello, This problem has been annoying me for a few days now and I can't figure out what it is. If I browse my Win7 PC via UNC (\\192.168.0.x) on an XP PC I am unable to get a list of shares. If I Directly open \\192.168.0.x\ShareName that will work perfectly. I have a vista PC on the same...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:03.
Twitter Facebook