Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Having trouble with NVM Update Utility for Intel 82579V

04 Sep 2013   #1

Windows 7 Ultimate x64 SP1
Having trouble with NVM Update Utility for Intel 82579V

I've been getting e1cexpress errors in Event Viewer (Event ID 27, Intel(R) 82579V Gigabit Network Connection Network link is disconnected). So I uninstalled my current Intel NIC driver (18.3) and applied the NVM Update Utility.

Problem is, how do I know if the update has been applied? I followed the instructions to the T and this is what's showing in cmd,

LVDASKU version 1.2.2
Tool to update Lewisvillie NVM ASKU
Copyright (c) 2012 Intel Corporation


# Ven Dev SVen Sdev Rev ST Device
1. 8086 1503 1043 849C 5 -- Intel(R) 82579V Gigabit Network Connection
U = needs updating
S = shared NVM; no update needed
* = update already performed
- = no update possible

No update required.
To test and see if it's a driver issue I installed a older driver (16.8.1). After the older driver was installed e1cexpress errors don't appear in Event Viewer anymore which leads me to believe it's a driver issue, but I'm still curious how do I tell if the NVM Update was applied or not.

Seems like an issue with 18.3 and the latest driver on Intel's website is 18.5.

Here is a log file,

=== "NVM Move" table ===
source offset=0000 target offset=0000 length=0000

InstallDriver: Testing for existence of driver C:\Windows\system32\drivers\iqvw64e.sys
InstallDriver: Writing driver file C:\Windows\system32\drivers\iqvw64e.sys
=== Begin enumeration of discovered devices ===
1 Intel(R) device(s) were discovered.
1. Adapter #/Bus/Device/Function: (1, 0/25/0)
1. ID: 8086/1503/1043/849C
1. Branding: Intel(R) 82579V Gigabit Network Connection
1. MAC Address: *censored*
1. EEPROM size: 2048

This device's pre-update EEPROM values at key offsets:
0005h: 00D6h
000Dh: 1503h
This device's pre-update Flash values at key offsets:
This device matches the [match] section.
Value read from 776:20: C069
This is an 82579V device.
There are 1 device(s) that match the required inputs.
Of these, 0 need(s) updating.
This device's NVM/EEPROM will not be updated.

This device's Flash will not be updated.

Deleting file C:\Windows\system32\drivers\iqvw64e.sys

My System SpecsSystem Spec
06 Sep 2013   #2

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

This seems to be a timing issue with the new drivers and not a real problem as far as I can tell.
If you go to the Network and Sharing center and select Change adapter settings.

Then right click on the adapter and select Properties.
Select Configure
Select the advanced Tab

Scroll down to Wait for Link and change the value to ON.

This will eliminate the error message.

From the description:
"On: Driver does wait for automatic detection or negotiation. If the adapter is not set to automatically detect or negotiate speed, the driver waits for a short time for link to complete and then reports the link state."
My System SpecsSystem Spec
07 Sep 2013   #3

Windows 7 Ultimate x64 SP1

pbcopter, Thanks for the reply. I'll install the latest drivers (again) and give your solution it a try.

I'm hoping I didn't accidentally mess things up when I was running the NVM Update Utility. I ran the utility with the NIC driver uninstalled and this kept popping up when I entered 82579VSKUW64e.exe -noslient in command prompt,

Usage: LVDASKU [options]

-noauto - wait for user input

-log [filename] - generate log info

-report [filename] - generate report file

-nosilent - display the user interface

-nofunction0only - update shared EEPROM

-nodriver - don't auto-install driver

-p - only check for update needed

-undo - undo changes previous made
Seeing that -nofunction0only updates the EEPROM I entered 82579VSKUW64e.exe -nofunction0only and nothing happened. What does -nofunction0only do exactly? I searched high and low and can't find an answer. I hope I didn't screw up my NIC's nvm.
My System SpecsSystem Spec


 Having trouble with NVM Update Utility for Intel 82579V

Thread Tools

Similar help and support threads
Thread Forum
Intel Driver Update Utility showing two different drivers
I'd like to update my integrated Intel HD Graphics 4000 driver, but the Intel Driver Update Utility is showing two different drivers, one says Intel Graphics Driver, and the other says Intel HD Graphics Driver. Why is it showing two different drivers and which one, or both, should I install?
intel driver update utility
hi to everyone its been ages since i was here. i have a problem with shockwave crashing my browser (Chrome) plus others and in general my graphics has been slow.i have updated chrome and ran the intel driver update utility which found 2 drivers and tried to install them but it failed for an...
Should I trust Intel's Driver Update utility or Windows Update?
Windows Update is not telling me I need or can update my Wireless networking, but Intel's Update Driver Utility says I should and is offering the update. How would you recommend I proceed? :geek:
Are you also having problems with Intel's Driver Update Utility?
Intel® Driver Update Utility I can run the program tool ten times and the results are hit or miss. Specifically, sometimes its detects my wired networking and other times it will not. any suggestions or thoughts? :geek:

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:56.
Twitter Facebook Google+