Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI AHCI Compatible RAID Driver

23 Oct 2009   #11
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Either System Restore, or use the rollback option in Device Manager, or it should even uninstall using the ATI Uninstall Manager in Programs and Features.


My System SpecsSystem Spec
.
23 Oct 2009   #12
prodgod

Win 7 HP 32-Bit
 
 

Sounds good, thanks a lot.
My System SpecsSystem Spec
25 Oct 2009   #13
metalgirl2045

Windows 7 32 bit (main laptop), XP/Ubuntu (netbook)
 
 

I had the same problem on the same machine and tried the AHCI upgrade. It didn't work (but didn't cause my computer any problems either, I think it just didn't take effect). Would installing the RAID one have any chance of working/turning my laptop into a very expensive brick? Also a friend has suggested just turning the RAID off in the BIOS, is it that simple or would tht require an OS reinstall?
My System SpecsSystem Spec
.

27 Oct 2009   #14
prodgod

Win 7 HP 32-Bit
 
 

Bump, anybody have any more ideas?
My System SpecsSystem Spec
27 Oct 2009   #15
Farel

Vista 32bit
 
 
Same Problem

I have the same laptop and I'm having the EXACT same error... the compatibility checker comes up clean but the actual install says there's an issue with the ATI AHCI Compatible RAID Driver....

I have dell's latest drivers however if I run a tool such as Driver Detective it says it's still out of date...

Please any help this is driving me crazy!
My System SpecsSystem Spec
27 Oct 2009   #16
DrO

Vista
 
 

Hello all,
Same computer, same upgrade hassle. I have the most up-to-date drivers dated 3/17/09 and I still get the same message to update the "AMD AHCI compatible RAID controller". There doesn't seem to be a way to disable the driver and I can't use the Windows 7 drivers from the AMD website. I'm not sure what else can be done.
My System SpecsSystem Spec
27 Oct 2009   #17
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

I get the feeling you guys are all running into the warning AMD has on the download page about these drivers,

Quote:
Warning: This driver does not provide custom configurations used in OEM systems and is recommended for use with retail AMD motherboards only. Installing an incorrect AHCI driver may cause problems with your hard drive including data loss.
which if that is the case then there probably isn't a whole lot you can do until whoever it was that made your laptops come out with Windows 7 compatible drivers. One thing you can try if you haven't and they have one available, is to try Vista drivers.
My System SpecsSystem Spec
27 Oct 2009   #18
Farel

Vista 32bit
 
 

If anyone finds an updated driver or a workaround/fix for this please share... this problem is so annoying and i'm thinking i'm going to have to attempt to return w7
My System SpecsSystem Spec
27 Oct 2009   #19
prodgod

Win 7 HP 32-Bit
 
 

Quote   Quote: Originally Posted by stormy13 View Post
I get the feeling you guys are all running into the warning AMD has on the download page about these drivers,

Quote:
Warning: This driver does not provide custom configurations used in OEM systems and is recommended for use with retail AMD motherboards only. Installing an incorrect AHCI driver may cause problems with your hard drive including data loss.
which if that is the case then there probably isn't a whole lot you can do until whoever it was that made your laptops come out with Windows 7 compatible drivers. One thing you can try if you haven't and they have one available, is to try Vista drivers.
I tried the Vista drivers but it did not work either.
My System SpecsSystem Spec
27 Oct 2009   #20
prodgod

Win 7 HP 32-Bit
 
 

Quote   Quote: Originally Posted by Farel View Post
If anyone finds an updated driver or a workaround/fix for this please share... this problem is so annoying and i'm thinking i'm going to have to attempt to return w7
I emailed Dell about this problem. I'll post their reply when I get one.
My System SpecsSystem Spec
Reply

 ATI AHCI Compatible RAID Driver




Thread Tools




Similar help and support threads
Thread Forum
Issues with RAID and AHCI
So when I first got my SSD I set my motherboard from IDE or AHCI. For a while it ran great. However, now I want to start experimenting with RAID. I picked up a few drives and they are all recognized. However, now I cannot switch from AHCI to RAID on that specific setting without my windows...
PC Custom Builds and Overclocking
Raid vs ahci?
Whats the difference because, i dont know if this is a issue but when ever i want to install windows 7 i have to set my sata controller to ahci instead of its default settings which is RAID, why do i have to do that?
Installation & Setup
Raid vs AHCI
While experimenting with a USB bootable Macrium Restore thumb drive I created, I was looking in my Bios and noticed the SATA controller was set to Raid. I have only one internal HD. I changed it to AHCI and booted up, got a notice that new drivers were being installed and rebooted. The...
Hardware & Devices
Raid 0 + AHCI?
So I picked up a pair of Corsair Force 120Gb SSD drives and set them up in RAID 0. Figured I could just slap them in, load the AMD RAID drivers then do a clean install of Win 7. Which Iíve done and everything seems to be working fine. Now reading about the performance benefits when setting your...
Hardware & Devices
Raid, AHCI or IDE
I have a friends HP system I'm fixing for him. His hard drive died, totally inaccessible (750GB SATA 3 Seagate). I ordered the recovery DVD and a new hard drive. In BIOS, the SATA controller can be set to Raid, AHCI or IDE. My question is, which is the right one to use. It was set to Raid but...
Installation & Setup
Ahci & raid
I recently bought 2 120GB OCZ Vertex 2 SSDs, a new CPU heatsink, and 2 new video cards (5850s). I was running my Windows 7 64 on 2 WD velociraptors in RAID0 prior to rebuilding my system. I never had any issue with Windows installation. I tried setting up my system to where my SSDs would be in...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App