Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI AHCI Compatible RAID Driver

27 Oct 2009   #21
Farel

Vista 32bit
 
 

Thanks Prodgod, while we're waiting for a response any really tech savy folks have any ideas for a possible work around?


My System SpecsSystem Spec
.
27 Oct 2009   #22
walman01

Windows Vista
 
 

Yup, same laptop, same problem. I have tried everything to no avail. Called Dell and they WANTED TO SELL ME A NEW LAPTOP!!!!!!!!
My System SpecsSystem Spec
28 Oct 2009   #23
metalgirl2045

Windows 7 32 bit (main laptop), XP/Ubuntu (netbook)
 
 

I'e heard elsewhere that Dell are planning to release new drivers early next year. Stuck with Vista on this machine for a few more months it seems

Any thoughts on whether the RAID upgrade would be good idea? I don't know about the motherboard generally but the processor is AMD, would that mean an AMD RAID driver is safe?
My System SpecsSystem Spec
.

28 Oct 2009   #24
walman01

Windows Vista
 
 

I am not sure if that is a good idea or not. It is unacceptable that Dell wants to wait until early next year. Certainly there must be another compatible driver out there somewhere. Anyone want to be a guina pig?

Let me just say that I am a little miffed that Microsoft advertises the upgrade as being completely compatible with Vista drivers. Nothing could be further from the truth. I had a long list of stuff I had to UNINSTALL before I could even try the upgrade. Some of them were driver related. Some of them were application related. iTunes was one. Anyone know why that is?
My System SpecsSystem Spec
28 Oct 2009   #25
Farel

Vista 32bit
 
 

I called Dell and they said that I should re-format and install vista -> Windows 7 and everything should be fine.... according to them the machine should be 100% compatible.

Anyone try a completely fresh reinstall w/ reformatting etc.?
My System SpecsSystem Spec
28 Oct 2009   #26
prodgod

Win 7 HP 32-Bit
 
 

So they said to reinstall Vista then do the install of Windows 7? I wonder if it would work if I was to do a factory restore / reformat and then install Windows 7 as a clean install. I don't have the discs for Vista so this would be the only way it would work for me.
My System SpecsSystem Spec
28 Oct 2009   #27
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Would I be correct in assuming that all of you in this thread with this problem all using a laptop?

If so what you are running up against is the same sort of thing that used to happen to users with laptops that had ATI Mobility video cards in them. ATI wrote all the drivers, but then they had to be modified by each computer manufacturer to take into account any bios/firmware changes that they made from the reference (video bios that is); sort of the same as the changes that Dell/HP/etc make to the standard bios, and why you can't use the motherboard manufacturer's reference bios on them. People in that situation always had to wait on the manufacturer to provide the driver update.

As for this,

Quote:
I called Dell and they said that I should re-format and install vista -> Windows 7 and everything should be fine.
I think you'll find what Dell is trying to say is to install Vista, update all the drivers, then do an upgrade install of Windows 7; which in theory should allow 7 to install and have functioning drivers. For any of you that have tried this, when you started the upgrade install, did it flag the RAID/ACHI driver as incompatible before continuing?
My System SpecsSystem Spec
28 Oct 2009   #28
B3astiie

Windows 7 64 bit
 
 

That's exactly what is going on with my Dell Inspiron 1721 laptop.

The Advisor says everything is compatible, flags nothing, and says I should be able to do an upgrade.

But when installing 7, it flags the ACHI Compitable Raid Controller.

My topic here with also a conversation with Dell. This convo annoyed me.

Windows 7 64 bit
My System SpecsSystem Spec
28 Oct 2009   #29
walman01

Windows Vista
 
 

Quote   Quote: Originally Posted by Farel View Post
I called Dell and they said that I should re-format and install vista -> Windows 7 and everything should be fine.... according to them the machine should be 100% compatible.

Anyone try a completely fresh reinstall w/ reformatting etc.?

Uh, yeah, that ain't gonna happen. I bought the upgrade specifically so I DIDN'T have to lose my application installation, files, etc. Dell should fix the driver issue. Period.
My System SpecsSystem Spec
28 Oct 2009   #30
Farel

Vista 32bit
 
 

Quote   Quote: Originally Posted by prodgod View Post
So they said to reinstall Vista then do the install of Windows 7? I wonder if it would work if I was to do a factory restore / reformat and then install Windows 7 as a clean install. I don't have the discs for Vista so this would be the only way it would work for me.
I had same issue so when I called dell I asked for the vista install cd... they're mailing it and all of the computers drivers in disk format =]
My System SpecsSystem Spec
Reply

 ATI AHCI Compatible RAID Driver




Thread Tools




Similar help and support threads
Thread Forum
Issues with RAID and AHCI
So when I first got my SSD I set my motherboard from IDE or AHCI. For a while it ran great. However, now I want to start experimenting with RAID. I picked up a few drives and they are all recognized. However, now I cannot switch from AHCI to RAID on that specific setting without my windows...
PC Custom Builds and Overclocking
Raid vs ahci?
Whats the difference because, i dont know if this is a issue but when ever i want to install windows 7 i have to set my sata controller to ahci instead of its default settings which is RAID, why do i have to do that?
Installation & Setup
Raid vs AHCI
While experimenting with a USB bootable Macrium Restore thumb drive I created, I was looking in my Bios and noticed the SATA controller was set to Raid. I have only one internal HD. I changed it to AHCI and booted up, got a notice that new drivers were being installed and rebooted. The...
Hardware & Devices
Raid 0 + AHCI?
So I picked up a pair of Corsair Force 120Gb SSD drives and set them up in RAID 0. Figured I could just slap them in, load the AMD RAID drivers then do a clean install of Win 7. Which Iíve done and everything seems to be working fine. Now reading about the performance benefits when setting your...
Hardware & Devices
Raid, AHCI or IDE
I have a friends HP system I'm fixing for him. His hard drive died, totally inaccessible (750GB SATA 3 Seagate). I ordered the recovery DVD and a new hard drive. In BIOS, the SATA controller can be set to Raid, AHCI or IDE. My question is, which is the right one to use. It was set to Raid but...
Installation & Setup
Ahci & raid
I recently bought 2 120GB OCZ Vertex 2 SSDs, a new CPU heatsink, and 2 new video cards (5850s). I was running my Windows 7 64 on 2 WD velociraptors in RAID0 prior to rebuilding my system. I never had any issue with Windows installation. I tried setting up my system to where my SSDs would be in...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App