Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No usb devices will install drivers

28 Feb 2014   #31
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Quick question: So i just took a look. Dell extracts the Web Cam driver files to C:\dell\drivers\R277344 but you need to right click setup.exe and run as admin to actually do the install. You should see a Device Driver Installation wizard run.

Did you run the setup file and see a Driver Installation wizard attempt the web cam install?


My System SpecsSystem Spec
.
28 Feb 2014   #32
liverpaul

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by ComputerGeek View Post
Quick question: So i just took a look. Dell extracts the Web Cam driver files to C:\dell\drivers\R277344 but you need to right click setup.exe and run as admin to actually do the install. You should see a Device Driver Installation wizard run.

Did you run the setup file and see a Driver Installation wizard attempt the web cam install?
I executed the setup file and ran the wizard, but still no luck.
My System SpecsSystem Spec
28 Feb 2014   #33
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Did you try a reboot? Is that same web cam line in the msinfo32 report after a reboot?

/* EDIT */
The line:
Laptop_Integrated_Webcam_2HDM USB\VID_0408&PID_2FB1\6&2B19AEDE&0&4 The drivers for this device are not installed.
My System SpecsSystem Spec
.

28 Feb 2014   #34
liverpaul

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by ComputerGeek View Post
Did you try a reboot? Is that same web cam line in the msinfo32 report after a reboot?

/* EDIT */
The line:
Laptop_Integrated_Webcam_2HDM USB\VID_0408&PID_2FB1\6&2B19AEDE&0&4 The drivers for this device are not installed.
After the reboot:
Problem Devices:
facap, FastAccess Video Capture ROOT\IMAGE\0000 This device is disabled.
Laptop_Integrated_Webcam_2HDM USB\VID_0408&PID_2FB1\6&2B19AEDE&0&4 The drivers for this device are not installed.
Optical USB Mouse USB\VID_046D&PID_C016\6&18F7BCC3&0&3 The drivers for this device are not installed.
My System SpecsSystem Spec
28 Feb 2014   #35
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

We'll be back to the web cam, but I'm going to switch gears here to the USB storage devices as they use Windows generic drivers.
1. Insert your USB flash drive. What appears in Device Manager? Is it a new Other device? Or something new under USB? Right click the device that appears->Properties and on the General tab tell me the Device Status code number

2. Next, let's check the USB Mass Storage driver is not corrupt. Verify these files exist
> C:\Windows\inf\usbstor.inf
> C:\Windows\inf\usbstor.pnf
> C:\Windows\System32\drivers\usbstor.sys
My System SpecsSystem Spec
28 Feb 2014   #36
liverpaul

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

(1)
- Plug in USB flash drive.

- Device manager now looks like:


- Properties window:


(2)
> C:\Windows\inf\usbstor.inf (doesn't exist)
> C:\Windows\inf\usbstor.pnf (doesn't exist)
> C:\Windows\System32\drivers\usbstor.sys (exists)
My System SpecsSystem Spec
28 Feb 2014   #37
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Quote   Quote: Originally Posted by liverpaul View Post
> C:\Windows\inf\usbstor.inf (doesn't exist)
> C:\Windows\inf\usbstor.pnf (doesn't exist)
> C:\Windows\System32\drivers\usbstor.sys (exists)
Bingo! We've identified at least one piece of your multi-part problem. The USB Storage driver is corrupt.

Be back in a bit with instructions to try and fix this
My System SpecsSystem Spec
28 Feb 2014   #38
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by liverpaul View Post
Problem Devices:
facap, FastAccess Video Capture ROOT\IMAGE\0000 This device is disabled.
My dumb idea, guys.
This device indicates disabled. What if, in the Device Manager, we right click on the Video device.
Will it say - Enable? If so, clicking on Enable should enable the device. Yes/No?
My System SpecsSystem Spec
28 Feb 2014   #39
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Right click C:\WINDOWS\system32\drivers\usbstor.sys select Properties. Click the Details tab. Write down the file version number displayed

Next, navigate to C:\Windows\System32\DriverStore\FileRepository. Scroll down to find the folder names that begin usbstor.inf. Open the folder with the most recent date. Right click on the usbstor.sys file in that folder and check its file version number.

Does it match the other version number? (I hope so!) If yes, then copy the usbstor.inf and usbstor.pnf files in that folder to C:\WINDOWS\inf\.

Now, try inserting your new flash drive
My System SpecsSystem Spec
28 Feb 2014   #40
maxie

windows 7 home 64bit
 
 

Read the article below might be of some help

USB Mass Storage Driver not Found ( vista home basic )
My System SpecsSystem Spec
Reply

 No usb devices will install drivers




Thread Tools




Similar help and support threads
Thread Forum
Downloading Drivers for (other devices)
In my device manager I am unable to download the drivers for (1) Ethernet Controller (2) SM Bus Controller (3) USB Controller. Help?
Drivers
Ethernet Controller issue, cant install drivers or detect devices
Guys, ive encounter some really frustrating issue here , recently just changed my cpu from an phenom x4 955 to a fx 8350 . After the pc got booted up, the horror began as im using an ethernet card , the internet cant be connected . No matter what drivers I tried , it just show that the driver...
Drivers
No *new* USB devices can find their drivers
Hello, please see my profile for system specs. I am unable to install drivers for NEW usb devices. I currently am using a MS Natural Ergo 400 keyboard and Logictech MX518 mouse that work fine. I have recently tried to install a Nostromo N52te (old device but "new" to my Win7 system), Logitech...
Hardware & Devices
Can't install drivers for my (unknown) devices??
Hi all. A couple days ago, I installed Windows 7 (through MSDNAA). I have a problem with some devices. The situation can be seen here: http://i1015.photobucket.com/albums/af278/rapt0r111/problemdeviceman-1.jpg I tried updating driver software through windows and it said it was...
Drivers
Need Drivers for 2 Unknown Devices
I just clean installed W7 on a Compaq F767NR laptop formerly running Vista SP1. All went well and the laptop is up and running. The laptop has a Quanta 30EA motherboard - Chipset nForce 560 Rev A2 In Device Manager there were 5 unknown devices listed. 1. PCI Bus 2, Device 5,...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:46.
Twitter Facebook Google+