Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Ga-970A-UD3 rev 1.1 and Etron USB driver problems

26 Nov 2014   #11

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

So just what's your question or problem? Your data shows the only USB 3 driver on your machine for Windows to choose is the Etron v1.0.0.18, dated 7/17/2003. So it should also show it's installed as in post #8

My System SpecsSystem Spec

 Ga-970A-UD3 rev 1.1 and Etron USB driver problems

Thread Tools

Similar help and support threads
Thread Forum
Etron Blue Screen of Death (EtronXHCI and various parts of it)
Hello all, I know I probably should have written a introduction thread and such, but the situation with these BSOD's is rather dire and i found more priority in posting this than I would posting a intro thread. Anywho, I've been having problems with ETron drivers, tried various solutions I saw...
BSOD Help and Support
bsod ON ga-970a-ud3 AM3+
BSOD After computer is on for approximately an hour, but when restarted it only lasts about 5 minutes. It doesn't matter what I am doing even if it is nothing!! I tried to disable GDRV but that didn't help. I stopped Easy Tune from running. I am at a loss as what to do!!!
BSOD Help and Support
970A-G46 MB Ram .Volts Question
Will this motherboard accept 1.6v memory by corsair vengance? im looking at the 1.6v memory modules and the g skill sniper series which run at 1.5v
New motherboard Gigabyte 970A-DS3 Now BSOD and freezes
Hi all, This is my first post so please be gentle. I'm not a great computer expert as you'll gather from my post but as I'm absolutely skint at the moment, I can't really afford to take my PC into a shop. :geek: I had built for me about 2 years ago a PC. It has a Phenom ll X3 at 2.8Ghz. It...
Hardware & Devices
Asrock H67M / Etron USB: Can't access USB Mass Storage Devices anymore
Hi, it's driving me mad :devil: My system: Asrock H67M Mainboard with Etron USB 2.0/3.0 chipset Windows 7 Ultimate with all current fixes applied The problem: I just discovered by accident that no matter what USB Mass Storage device (USB-MSD) I plug into my PC (and also no matter if I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:43.
Twitter Facebook Google+