Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Ga-970A-UD3 rev 1.1 and Etron USB driver problems

21 Feb 2014   #1

Windows 7 Pro 32 bit
Ga-970A-UD3 rev 1.1 and Etron USB driver problems

Hi All,

I tried to install the latest USB 3.0 drivers from the Gigabyte website (rev. and it seems there is some kind of installation issue, since I had to remove the drivers while re-booting my computer for them to finally install OK.

Also, I noticed there seems to be some kind of compatibility issue between the latest chipset drivers (rev. 13.125) and the new Etron USB drivers.

I've read about the lousy opinion shared on the Web regarding Etron's USB 3.0 reliability, but all the same, I'm stuck with this system and will have to learn to live with it 'till I get another one (money doesn't grow on trees!).

OK, and last but not least, the AHCI drivers from AMD. I've heard the default Windows 7 driver is better than the AMD driver. Is there any way to switch to the default Windows 7 AHCI driver (msahci.sys)?

I thank you for your contribution and remain in your debt.


My System SpecsSystem Spec
26 Feb 2014   #2

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Please post an image of your Device Manager.
If you need instructions to do this, just ask.
My System SpecsSystem Spec
27 Feb 2014   #3

Windows 7 Pro 32 bit

Are you talking about the Etron or the AHCI drivers?
My System SpecsSystem Spec

27 Feb 2014   #4

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

I am talking about your drivers. All of them. They will be incorporated in your Device Manager.

Edit: I am querying about your Win7 Device Manager. Do you know how to find it?
Do you know how to post the image?
If you need directions, please ask.
My System SpecsSystem Spec
27 Feb 2014   #5

Windows 7 Pro 32 bit


I'm asking again. Have you noticed I asked very specific questions regarding the Etron USB 3.0 driver and also the AHCI driver?

Kindly also notice that I did install both of the drivers in question. I was checking with the membership to see if anybody had further information regarding the Etron compatibility issue and how to change the default AHCI driver provided by AMD via the F6 option during OS installation.

As my postings says, the Etron drivers have a terrible reputation for being hard to handle. As far as the AHCI driver is concerned, I've heard folks say that it can be switched from the AMD to the Windows 7 default. When I offer the controller the MS default driver (msahci.sys) it tells me that the best driver for the controller is already installed.

I thank you for your input and look forward to it.

My System SpecsSystem Spec
27 Feb 2014   #6

Windows 7 Pro 32 bit


BTW, I know EXACTLY what the device manager is, what in the world makes you think I don't?
My System SpecsSystem Spec
27 Feb 2014   #7

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

I will not be able to assist you in your search for a solution in this matter.
I wish you well in your endeavor.
My System SpecsSystem Spec
27 Feb 2014   #8

Win 7 64bit

I have the same mobo and was having etronxhci.sys BSOD. These are my current Etron drivers that have solved the issue.
The only chipset drivers on my mobo cd were usb3 drivers, nothing else.
My System SpecsSystem Spec
27 Feb 2014   #9

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64


re: Your AHCI question. Please do the following should tell me about the AHCI drivers currently available on your machine
  1. Download and unzip
  2. Copy the devcon.exe version for your architecture (probably amd64) to C:\Windows\system32
  3. Open an elevated command prompt window and copy/paste to run the following command
    devcon drivernodes pci\* >"C:\drivernodes.txt"
  4. Upload C:\drivernodes.txt to your next post
My System SpecsSystem Spec
26 Nov 2014   #10

Windows 7 Ultimate x64

He i am not the same guy but i did what you said:

maybe you can help me?

Motherboard: Gigabyte GA-970A-UD3
My System SpecsSystem Spec

 Ga-970A-UD3 rev 1.1 and Etron USB driver problems

Thread Tools

Similar help and support threads
Thread Forum
Etron Blue Screen of Death (EtronXHCI and various parts of it)
Hello all, I know I probably should have written a introduction thread and such, but the situation with these BSOD's is rather dire and i found more priority in posting this than I would posting a intro thread. Anywho, I've been having problems with ETron drivers, tried various solutions I saw...
BSOD Help and Support
bsod ON ga-970a-ud3 AM3+
BSOD After computer is on for approximately an hour, but when restarted it only lasts about 5 minutes. It doesn't matter what I am doing even if it is nothing!! I tried to disable GDRV but that didn't help. I stopped Easy Tune from running. I am at a loss as what to do!!!
BSOD Help and Support
970A-G46 MB Ram .Volts Question
Will this motherboard accept 1.6v memory by corsair vengance? im looking at the 1.6v memory modules and the g skill sniper series which run at 1.5v
GIGABYTE 970A-UD3 wont boot from disc
I have a Gigabyte 970A-UD3 that refuses to Boot from Disc. Trying to run Memtest (before it was Windows 7 disc, had to install OS from inside OS) and the darn thing wont boot up the disc or give me the option to press any key to boot from disc. Even hit F12 in order to select boot and it goes...
Installation & Setup
New motherboard Gigabyte 970A-DS3 Now BSOD and freezes
Hi all, This is my first post so please be gentle. I'm not a great computer expert as you'll gather from my post but as I'm absolutely skint at the moment, I can't really afford to take my PC into a shop. :geek: I had built for me about 2 years ago a PC. It has a Phenom ll X3 at 2.8Ghz. It...
Hardware & Devices
Asrock H67M / Etron USB: Can't access USB Mass Storage Devices anymore
Hi, it's driving me mad :devil: My system: Asrock H67M Mainboard with Etron USB 2.0/3.0 chipset Windows 7 Ultimate with all current fixes applied The problem: I just discovered by accident that no matter what USB Mass Storage device (USB-MSD) I plug into my PC (and also no matter if I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App

Windows 7 Forums