Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Do I NEED this driver?

05 Mar 2014   #1
Joanne13

Windows7 64bit
 
 
Do I NEED this driver?

I recently got a new PC and system (Win7 of course) and am having a really hard time of dealing with the new system (had WinXPPro before). So this window is appearing when I restart & I have NO idea why OR if I actually need the driver it's about. I'm hoping someone will know what the driver is for AND whether or not I actually need it or if it's just wanting me to install it (even though I don't actually need it).

I have avast! Internet Security installed and wonder if it's got anything to do with that. I'm on broadband too but can't imagine why it would have anything to do with that since I've been on it for many years.

Thank you in advance for any advice! I'm hoping to resolve this soon so I can get rid of the pop-up.





Attached Images
Do I NEED this driver?-new-network-detected...broadcom-netlink-tm-gigabit-ethernet-.png 
My System SpecsSystem Spec
.
05 Mar 2014   #2
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

That looks like an Avast deal. Check 'Private' and see what happens.
My System SpecsSystem Spec
05 Mar 2014   #3
maxie

windows 7 home 64bit
 
 

Hi Welcome to Seven Forums ... Look in the Device Manager under Network Adapters .. Do you have any Avast! Firewall NDIS Filter Miniport ? ....
My System SpecsSystem Spec
.

27 Sep 2014   #4
Joanne13

Windows7 64bit
 
 

I'm SO sorry for not thanking you guys for answering my question! I haven't tried either answer yet. I simply forgot I'd asked the question in the first place. Been going through SO much at home since getting this new system and my question simply got forgotten. Sorry again and (apparently) I stopped getting the pop-up. Thanks again.
My System SpecsSystem Spec
27 Sep 2014   #5
maxie

windows 7 home 64bit
 
 

No problem
My System SpecsSystem Spec
Reply

 Do I NEED this driver?




Thread Tools




Similar help and support threads
Thread Forum
No Drivers Found. Click Load Driver to Provide Mass Storage Driver....
Hi all, I'm getting the above error when trying to do a clean install of Windows 7 from a USB drive using the Rufus program for the ISO. I've tried everything I have found online and nothing works: 1. normal boot from a W7 ISO formatted as NTFS using Rufus - same error :shock: 2. Shift +...
Installation & Setup
Windows Driver Foundation User-mode Driver Framework service is Manual
Hi, All of a sudden the Windows Driver Foundation - User-mode Driver Framework service is set to Manual in Services. I clean installed Windows 7 a few weeks ago and my system is clean (as far as clean goes) as in only 15 programs installed (of which 5 x NVIDIA). I use this computer for work...
Drivers
Multiple BSOD. Driver Verifier Driver caught a driver corrupting
I have had BSOD for a while and being super busy I did not have time to look at it and get it fixed. Well Being a computer guy I assumed I could fix it myself. But with tons of research and trying to use every guide I can find I decided to try here(probably should have came here first). Today I...
BSOD Help and Support
No drivers found. click load driver to provide a mass storage driver f
Okay so, my laptop's system is unable to boot, so I just tried to format it since I have to do that for a very long time, and when it asked me in which partition I want to install windows there was nothing, although when I clicked "Load Driver" I could access the hard disk's files, the hard disk IS...
Hardware & Devices
Display driver Intel Graphics Accelerator Driver for Windows XP Stop
I am not sure if this is where it belongs, or if it is a Graphics Card issue. I have an Acer Aspire 7741z-4433 with an Intel(R) Pentium(R) p6200 (2.13 GHz, 3MB 1.3 cache). This only happens to me while I am playing The Sims 3. I have the game set on the lowest quality settings, even though my...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App