Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Driver for WDC WD10EZEX not found

11 Apr 2014   #11

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Quote   Quote: Originally Posted by OvenMaster View Post
Quote   Quote: Originally Posted by ComputerGeek View Post
Check if the following files exist:
> C:\Windows\inf\usbstor.inf
> C:\Windows\inf\usbstor.pnf
> C:\Windows\system32\usbstor.sys

If yes, see my post in another thread about USB Mass Storage Driver Problems
Unless I'm missing a post somewhere, a WD 10EZEX is a SATA 6GB/s internal spinner hard disk drive and not a USB drive. Might I ask what drivers for USB flash drives have to do with a SATA internal hard drive? Thanks.
That's an excellent question. And I'm glad you asked.

On the one hand, I must have had USB on the brain from the start as I had just finished working on a USB thread.

On the other hand, when I asked the OP to check if those 3 USB storage driver files exist. The answer should have been "Yes, all the files are there". But the answer came back "No". So, either the answer was incorrect or there's more then one problem here.

Also evidenced by a flash drive didn't install. The driveclean tool uninstalls driver references from the registry. It only deletes registry keys. It doesn't delete files.

Perhaps the OP could clarify? In any case, attempting a System Restore is still a good thing to try.

My System SpecsSystem Spec
11 Apr 2014   #12

Win7 Pro x64

Yes, I can clarify that for you ComputerGeek: in Post #2 I said that the three usbstor files were NOT on the machine that I was having problems with but they WERE on another (almost identical) machine in those folders. Like I said in my last post, I didn't copy them across because I wasn't told to.

I've followed the advice so far to the word, anyway let's move on and I can give you an update.

I copied those three files from the 17/02/13 folder like you said, re-booted and tried the memory stick. Wouldn't install, got no messages.

So I reconnected the old WDC drive, intending to do a restore. I've 2 screen prints, it's installed but I can't seem to access it to do the restore.

Just before Post #3, I had no problems accessing that HDD and it's never given me problems before (other than not having enough storage).

Appreciate any help towards getting the original and new issues resolved - thanks.

Attached Thumbnails
Driver for WDC WD10EZEX not found-dev-mgr-001.png   Driver for WDC WD10EZEX not found-computer-001.png  
My System SpecsSystem Spec
11 Apr 2014   #13

Win7 Pro 32bit

So on one machine, we have no USB drivers, and no drivers for a new hard disk; the old hard disk is recognized when installed and booted up.

I agree with ComputerGeek (and thanks for answering my question)...a System Restore would be a good idea, especially since it seems that the Registry's been altered. I might also suspect that SFC /SCANNOW could be run as well to replace missing Windows files... but I don't think that will fix the Registry.

I really hesitate to suggest a Windows Repair Install...

OldLaker... could you install the NEW WD 10EZEX in the other machine, just to confirm that the new drive is recognized by that computer and isn't DOA?
My System SpecsSystem Spec

12 Apr 2014   #14

Win7 Pro x64

Ok, thanks.

System restored. USBs working and can access the old WD2500AAKX once more.

SFC / SCANNOW run. No integrity violations.

I'd already tested WD10EZEX by installing it on the other machine before posting on the forum (mentioned in #1). It's not DOA. However, if there's something we can learn from doing that again, I'm happy to try it out, let me know.

Looks like the issue is specific to desktop "A".

/ * EDIT * /

I just re-read the WDC specs. I did the upgrade to the WD10EZEX because it was in the same Caviar Blue family as the old 2500AAKX (expecting no surprises). The only differences are: cache (64Mb vs 16 Mb), data transfer rate (host to/from drive 150Mb/s vs 126Mb/s) and the EZ10EZEX needs more power. The only hardware differences between machines "A" and "B" are the backup HDDs, the PSUs and graphics cards.

When WD10EZEX is installed on "B" the driver is showing as 6.1.760.16385 in the Device Properties for the HDD. I have the same driver (name and date) on "A" when WD2500AAKX is installed.
My System SpecsSystem Spec
12 Apr 2014   #15

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Whooopie! We got your USB issue resolved!

When WD10EZEX is installed on "B" the driver is showing as 6.1.760.16385 in the Device Properties for the HDD. I have the same driver (name and date) on "A" when WD2500AAKX is installed.
OK. That's good and what i'd expect to see.

Question is: What do you see in Device Manager when the WD10EZEX is installed? I see an Other device in your earlier screen shot (that's disabled). You still have an Other device when WD10EZEX is installed?

Install the drive again
  • Click the Start Orb. Type msinfo32 in the search box, hit Enter
  • When the window opens, click the + sign next to Components to expand it
  • Click Problem Devices. Anything appear?
  • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
  • On the other hand, if no devices are listed, tell me so
My System SpecsSystem Spec
12 Apr 2014   #16

Win7 Pro 32bit

Quote   Quote: Originally Posted by OldLaker View Post
I'd already tested WD10EZEX by installing it on the other machine before posting on the forum (mentioned in #1). It's not DOA.
Ouch. Missed that. My bad.
My System SpecsSystem Spec
13 Apr 2014   #17

Win7 Pro x64

Ok, well thanks I guess, I do appreciate all the time you've taken on this and best endeavours etc.

I've stopped at the point where the restore was done, so I won't mark this as solved. I can say why in full if you want it as a point of record.

The machine is working just fine again and I've decided to juggle around some hardware and will run the new drive on the other machine (where it works) and just be more careful about managing space on this machine where I'd intended it to be used. I'll take care of that myself.

I've provided a screenshot, more so you can reflect on the mystery (if you like) of all this. Those files didn't exist before the hardware upgrade attempt and the machine (with this hardware) runs just fine. The two HDDs (old and new) have been in and out quite frequently, I can assure you that when installing WD2500 (it searched and found the drivers) there is evidently no need for those 3 files. It's odd.

Attached Thumbnails
Driver for WDC WD10EZEX not found-montage-001.png  
My System SpecsSystem Spec

 Driver for WDC WD10EZEX not found

Thread Tools

Similar help and support threads
Thread Forum
No Drivers Found. Click Load Driver to Provide Mass Storage Driver....
Hi all, I'm getting the above error when trying to do a clean install of Windows 7 from a USB drive using the Rufus program for the ISO. I've tried everything I have found online and nothing works: 1. normal boot from a W7 ISO formatted as NTFS using Rufus - same error :shock: 2. Shift +...
Installation & Setup
WD10EZEX Hard Drive Completely Wiped
Recently a family member of mine got a new hard drive due to the old one quitting on her. After putting it in the computer and booting up, there was nothing on it. She is unable to install the Windows 7 64 bit. The hard drive came with no CD for the drivers either. Any ideas?
Driver cannot be found / replacing default driver for Android Tablet
Hi, Hoping I can find some help here. We have a standard android tablet that we use to deploy throughout stores that runs an android app that we use. We use Google's ADB to deploy our application and I do this VIA a workstation that I have set up running Windows 7 64 bit. My issue...
USB Driver not Found
hi there having some probs with usb 3.0 ports not showing up in my computer. Whenever i put my hard drive (which works in usb 2.0 fine and is definitely usb 3.0 compatible) a windows update thing dialog pops up and start searching for 2 usb controller drivers (im guessing for the only 2 usb 3.0...
No drivers found. click load driver to provide a mass storage driver f
Okay so, my laptop's system is unable to boot, so I just tried to format it since I have to do that for a very long time, and when it asked me in which partition I want to install windows there was nothing, although when I clicked "Load Driver" I could access the hard disk's files, the hard disk IS...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App