Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: General drivers problem "device acess denied"

19 Apr 2014   #1

7 64bits Pro
General drivers problem "device acess denied"

First post on this forum, that I discovered by chance looking for an answer to my problem, so Hi everybody

I recently changed the Graphic Card on a computer running on Windows 7 64 bits, SP1 (from a Geforce 760 to a Geforce 560Ti)
I had a huge amount of problems doing so: after uninstalling the drivers of the precedent card and installing the new one (both coming from the Nvidia website), the computer simply couldn't find the new or the ancient GC!! Or it did find it, but "couldn't access it" or "hadn't access to it" (sorry, don't know the exact terms, the OS is set to French).

Anyway after half a day of trial and errors, I finally managed to install it in safe mod, and I thought that everything was -finally- okay.

Then, a few days later, it appeared that the "couldn't access device" was now spreading in the whole computer: I can't even install or use a single USB device.
I tried the USB drivers - general fixes for problems that you advice, three times without success: it still have the same problems.
I can't totally install USB devices (and all devices, I assume from the GC incident) even on safe mod.

Oh, and on top of that, the windows restoration system doesn't work: I would have tried to go before the GC change to see if everything was working.

I also checked the famous SP1 USB driver problem, but it doesn't seems to fixt it (the .exe find no problems).

EDIT: more info:
1) I checked the UAC, the slider is all the way down, so it shouldn't be linked to it.
2) Windows update also seems not able to do work properly. I got 4 updates waiting to install: I can download them, but their installation always fail

I honestly don't know what to try now. Does somebody have an Idea?
In all cases, thanks for reading!


My System SpecsSystem Spec
22 Apr 2014   #2
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot

I would scan the machine for malware first thing.

Are you able to run system restore from safe mode?
My System SpecsSystem Spec
24 Apr 2014   #3

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

A malware check is always good advice. You can get the program here...
Malwarebytes | Internet Security Product Downloads

Once cleared by Malwarebyte, you can update your drivers with this...
My System SpecsSystem Spec


 General drivers problem "device acess denied"

Thread Tools

Similar help and support threads
Thread Forum
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
When I click "install now", it's saying "No device drivers were found"
Ok, now I get another problem... When I click "install now", I get a msg box that is saying 'no device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK' What should I do now?
Installation & Setup
Cannot install HP printer drivers - "Access is denied" in Windows 7
I have a newly purchased HP Deskjet 3050A e-All-in-One Printer series - J611 which should be working with Windows 7, but when I try to install the device drivers I get a "Access is denied" error. How can this be bypassed or fixed? :(
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing
"DVD drive device drivers missing" in Win7 installation setup
Hi, my attempt to install windows 7 today ended in!!!! When I boot from the DVD, choose the Language and press "Install" I get an Error message stating "A DVD/CD drive device driver is missing. If you have a driver CD/Floppy please insert it...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:05.
Twitter Facebook Google+