Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Friend's new Lenovo Ideapad Z710 refuses to install touchpad driver.

11 May 2014   #11
Yui Kitamura

Windows 7 Home Premium x64

Got the driver fixed! Turns out it was actually an Elan touchpad, I didn't realize that I had to go to where it installed files and run a separate setup to actually install the drivers. I feel dumb. Thank you all so much for the help!

My System SpecsSystem Spec
11 May 2014   #12

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by Yui Kitamura View Post
Got the driver fixed! Turns out it was actually an Elan touchpad, I didn't realize that I had to go to where it installed files and run a separate setup to actually install the drivers. I feel dumb. Thank you all so much for the help!
Glad you got this resolved. I saw on that Lenovo forum thread where others were asking about "are you sure you have a Synaptics touchpad, and not an Elan?" which is why I asked that question of you here in my previous post.

So that was the secret.

Where was this driver you had to manually run? Was it expanded into C:\Drivers somewhere below that? Exactly what was the full path to the SETUP.EXE you finally ran and which was the proper Elan driver install?
My System SpecsSystem Spec
11 May 2014   #13
Yui Kitamura

Windows 7 Home Premium x64

I don't have his laptop on me, so I don't know the exact path, but it was something like C:/Drivers/Synaptics Touchpad driver/Elan/Setup.exe

Pretty easy to find. The fact that the installer only said "Install synaptics driver" was a little misleading, but I'm glad it was all figured out in the end.
My System SpecsSystem Spec

11 May 2014   #14

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Just for closure (and not to nitpick, but to possibly help others who might have a similar issue in the future), the Lenovo driver download site for the Z710 does in fact name both Synaptics and Elan as the type of touchpad supported by the driver:

And the URL for that specific driver download was in fact provided by Solid_Cruver (Lenovo support specialist in the Philippines) post #9 in the Lenovo forum thread I provided the link to earlier which I mentioned sounded pretty much like it was discussing your exact problem, or very much the same.

And in message #12 of that thread, it was Solid_Cruver who questioned the OP of that thread whether he knew if it was a Synaptics or an Elan touchpad that was causing the problem. It was this comment (in that Lenovo forum post #12) which prompted me to offer that same question here, in my own post #9 of this thread.

Although I don't have a Z710 (but instead have a W530 laptop which does truly have a Synaptics touchpad), I decided to duplicate your experience. I downloaded that Z710 driver file (for Synaptics/Elan), just to see what was in it (i.e. by running it to self-expand into the C:\Drivers folder, planning to un-check the final "install now" box which I expected to encounter at the end of the self-expansion.

And when I ran the file to the very last "finish" page, you are correct that the text shown has an "install now" checkbox shown which mentions only the Synaptics driver. There is no mention of the Elan, or what to do if you have one. This is certainly confusing, and very possibly misleading, as there is no further mention made of the Elan situation and what to do if that's your hardware... assuming you actually know. Mysterious, for sure.

So, I un-checked that "install now" box, just so I could see the expanded installation folder(s) in C:\Drivers from the downloaded driver file TP161W764.EXE. Again, TP161W764.EXE is nothing more than a self-expanding file with an autorun option for SETUP.EXE (in the highest-level folder produced by the self-expansion one would assume). What gets self-expanded is simply the "installation folder" in which the actual driver installs can then proceed once the correct SETUP.EXE is run. Nevertheless, after un-checking the "install now" box and pushing the FINISH button the process wrapped up immediately so that I could now look into C:\Drivers to see what was going on.

Well, the folder and sub-folders produced by the self-expanding TP161W764.EXE looks as follows:

This structure appears to be a top-level master folder, along with three sub-folders (one for Synaptics and two for Elan). Presumably the FINISH process would have run a SETUP.EXE that understood the hardware present, and picked the proper driver installer sub-folder below.

Note that there is a SETUP.EXE at the top level "C:\DRIVERS\Touchpad Driver (Synaptics, Elan)", so one would guess that this is the SETUP.EXE which would have been auto-launched if I'd left the "install now" box checked on the final page of the self-expansion process dialog (with the FINISH button, to then auto-launch SETUP.EXE to actually do the installation of the touchpad driver).

But furthermore, there is a DEV.INI file in that same folder which is suspiciously named and looks quite relevant. Looking at that INI file it contains the following:

Well, that's very interesting. It looks to be a list of the different types of touchpads which might be present: two different Synaptics hardware DEVICE_ID values (with SETUP/EXE for the driver install for both Synaptics devices coming from the one single \Synaptics sub-folder), and two different Elan hardware DEVICE_ID values (with two separate driver install sub-folders and two separate SETUP.EXE's to be run). I would have guessed that the related SETUP.EXE in this folder should have first accessed Device Manager to find out the precise DEVICE_ID associated with the touchpad, and then used this DEV.INI file to determine which of the THREE SEPARATE device driver installation folders would then be used to run the imbedded SETUP.EXE present in each of those three separate sub-folders:

(1) VEN_SYN&DEV_2B22 and VEN_SYN&DEV_2B16-> \Synaptics sub-folder, and Setup.exe within it

(2) VEN_ETD&DEV_060E -> \Elan-PS2 sub-folder, and Setup.exe within it

(3) VEN_ETD&DEV_0619 -> \Elan-SMBus sub-folder, and Setup.exe within it.

So, if you go into Device Manager on your Z710, and then go to the "System Devices" group item (not "mice") and expand that group, you will most probably see an item for your Elan touchpad (or, if it had been a Synaptics touchpad then that's what would have shown up). In my own case of my W530, the item which appears is as follows:

And then if you right-click on the item and select Properties, and then go to the Details tab in the Properties dialog, and then select Hardware ID from the drop-down list of detail info, you will see the actual DEVICE_ID value corresponding to your particular touchpad hardware in your particular Z710. In my own W530, the Hardware ID value looks like this:

I'm curious what your particular Z710 Device Manager Hardware ID is, if you can locate it and provide it. I'm certain it's one of the two Elan Device ID values I showed above.

So, back to your own Z710, in my opinion that top-level SETUP.EXE working in conjunction with the DEV.INI file contents, along with the Hardware ID value returned from Device Manager for you particular touchpad, well I would have guessed that all of this should have worked together automatically to then select which of the three subordinate driver installer sub-folders should have been selected, and then from which the SETUP.EXE in that particular sub-folder would have been automatically run... to complete the proper and correct and appropriate installation of the correct driver for the particular touchpad hardware device present on your particular Z710.

That's what I would have guessed. That this all should have tied together automatically as I described above, and that theoretically it shouldn't have been necessary to take any special installation steps (or manual overrides, and then manually run SETUP.EXE from anywhere)... if the top-level SETUP.EXE were working properly and the use of DEV.INI in that folder was interpreted and used as I deduced.

So, now looking inside each of the three separate driver installer sub-folders for (a) the one sub-folder for the two separate Synaptics Hardware ID devices, and (b) the two separate sub-folders for each of the two separate Elan Hardware ID devices, sure enough we see exactly what now would be expected:

Bottom line: if anything other than an automatically successful driver install for the PARTICULAR touchpad present on your Z710 occurred, it strongly suggests that the high-level SETUP.EXE is NOT correctly utilizing the DEV.INI present in that top-level folder in order to decide which of the three imbedded driver installer sub-folders to go to in order to then run that particular SETUP.EXE automatically.

Either that, or perhaps the specific Hardware ID value which Device Manager discovers on your specific Z710 is actually a THIRD ELAN VALUE!!! That would certainly explain why the two existing Elan-related Hardware ID's did not get used properly as expected, and perhaps SETUP.EXE was written to simply fall back and issue a "misleading" error message claiming "Synaptics device not found", where in fact the problem was that it was a new Elan touchpad device that was present... but Lenovo had not added the correct values to DEV.INI to support it.

Now it's quite possible (and apparently true) that whatever the Elan touchpad on your Z710 is (either one of the two values currently shown in DEV.INI, or perhaps one with the third Hardware ID as I am suggesting might be possible) might be fully supported by the existing Elan driver (either or both!), as suggested by your use of one of those two Elan sub-folders from which you ran SETUP.EXE manually. Obviously you ran SETUP.EXE yourself using one of those two sub-folders, so it was either a very good guess or you knew something you haven't revealed yet or both drivers are actually fully compatible with ALL Elan touchpads (including this possible third variant).

And that's how my analysis would go.

So I'm now very curious as to what the actual Hardware ID for the Elan touchpad is that is shown in Device Manager on your particular Z710, as this would bring a good deal of closure to fully understanding what's happening here.

Also, if my theory about the possibility of a new third variety of Elan touchpad is true, and it really is DEV.INI which is at fault, we really should notify Lenovo so that they can correct this.

There is, of course, yet one more possible explanation for the failure of the driver install on your Z710, and that is that the auto-run of SETUP.EXE which is triggered if you keep that "install now" checkbox checked on the FINISH page mistakenly is executing the SETUP.EXE specifically in the \Synaptics sub-folder, rather than running the SETUP.EXE (which presumably uses DEV.INI) in the top-level folder. Don't know, but this could be a reason for the "Synaptics device not found" error message and why you had to manually run SETUP.EXE from one of the two Elan folders in order to get the correct Elan driver installed (though they actually may be identical, in the two sub-folders, so that it didn't matter which one you chose if you didn't know the Hardware ID in advance).

Please provide that mysterious name and Hardware ID for your touchpad, in "System Devices" on your Z710.
My System SpecsSystem Spec
12 May 2014   #15

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Lenovo driver download site for the Z710 does in fact name both Synaptics and Elan as the type of touchpad supported by the driver:
No mate that is really good to know as I for one would never have picked it.
My System SpecsSystem Spec
12 May 2014   #16
Yui Kitamura

Windows 7 Home Premium x64

So I'm going to give a little bit of my own thoughts on the matter before I tell you what the hardware ID is.

Originally, before i installed the driver, the only listing under the "Mice" category in device manager was a ps/2 mouse, which I assumed was for USB mice or something akin. It turns out I was wrong, because that doesn't make sense in the first place, and it was simply a generic windows driver to let the touchpad work with basic functions in the first place.

When I installed the driver, I selected the SMBus installation at random, and as such, the hardware ID that now displays for the touchpad is the one that corresponds to the SMBus driver. This means that I don't know if it was just luck that I selected the correct driver, or if the touchpad simply decided to assign the touchpad the hardware ID of the driver I installed. Of course, I don't even know if that's how it works, so I could be wrong.

But to clarify, the hardware ID ends with 0619.
My System SpecsSystem Spec
12 May 2014   #17

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by Yui Kitamura View Post
But to clarify, the hardware ID ends with 0619.
Can you please provide the COMPLETE character string shown in Device Manager for the Hardware ID, like the values shown in my screenshot above for my own Synaptics SMBus driver.

The Hardware ID is not assigned by the driver you install. It is built into the firmware of the hardware, and is provided to the operating system by the hardware as part of the "plug 'n' play technology" architecture.

That's how Windows Update knows what driver to look for up on their Windows Update Catalog web site (when you let it "search for drivers on the Internet") in order to find the most up-to-date drivers available for any given piece of hardware. Note that you can only get to that Microsoft driver web site through Internet Explorer. You are not permitted there using any other browser.

So theoretically, if you go to that site with IE and search for "VEN_ETD&DEV_0619", if Microsoft has a driver for that vendor/device (provided by the vendor usually, but possibly provided by MS itself) it would be presented for download. This is exactly what happens automatically with Windows Update for hardware that is missing its driver and shows a yellow exclamation mark.

But in this case, I've tried that search and there is NO available driver match for that ID. That's why the driver provided by Lenovo is the one-and-only software that is available, and obviously the installer should work.

So, you have the Elan-SMBus device. Not a surprise, actually. Note that the Synaptics touchpad on my W530 is similarly a Synaptics-SMBus.

Anyway, this shoots down my theory that it might be a new third type of Elan device whose Hardware ID is not shown in DEV.INI.

But it does add credence to my theory that there's no question the auto-launched SETUP.EXE doesn't seem to be the one in the high-level folder, which one would think should read DEV.INI and match up the device's Hardware ID to decide which of the three actual driver install folders to use to next run that SETUP.EXE for that hardware. Instead, based on your experience it does seem that the auto-run SETUP.EXE must always be the Synaptics folder SETUP.EXE. While this will work if a Synaptics touchpad is present, clearly it won't work if an Elan touchpad is present.

So given the obvious defect in which auto-run SETUP.EXE is triggered, until Lenovo is told about the problem and fixes the auto-run SETUP.EXE to use that top-level folder SETUP.EXE as it should (if my interpretation of things is correct), it does appear true that your "solution" is the correct one. Just go to the Elan-SMBus driver installer folder and manually yourself run that SETUP.EXE.

Case closed, at least as far as getting the Elan touchpad on your Z710 working.

And I think we now have a better understanding of what's happening, and also have at least a theory about why the Lenovo-provided driver installer file for Synaptics/Elan is failing when an Elan touchpad is preseent.

I will try phoning Lenovo to report this, even though I don't own a Z710 so I don't know if they'll even listen to me.

Thanks for the 0619 value on that Hardware ID.
My System SpecsSystem Spec
13 May 2014   #18
Yui Kitamura

Windows 7 Home Premium x64

The FULL hardware ID that device manager gives me is this: ACPI\ETD0619

So that's weird, I was expecting something longer.
My System SpecsSystem Spec
14 May 2014   #19

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by Yui Kitamura View Post
The FULL hardware ID that device manager gives me is this: ACPI\ETD0619

Note that this ACPI\ETD0619 value (which, remember, comes from the hardware itself) shown in the Hardware ID is NOT a value shown in DEV.INI. It appears Lenovo thought the value should be VEN_ETD&DEV_0619 which is why they coded that in their DEV.INI data (at least that's my interpretation of how it should be working).

It's very curious that all other devices have a form of Hardware ID returned by Device Manager that are parsed with the VEN_ and DEV_ prefixes, whereas the value you show is not. So either there's something odd about what is actually being provided by the Elan Touchpad hardware (so that Device Manager is confused, and simply shows the actual value from the hardware), or there's some other explanation. But there's no question this is NOT a value present in DEV.INI.

So of course there's not a match found in the lookup in DEV.INI, which perhaps is why we see SETUP.EXE simply taking either (a) a default to the Synaptics driver folder (and of course that SETUP.EXE finds a mismatch of the hardware-provided ACPI\ETD0619 to the expected EN_SYN&DEV_2B22 or EN_SYN&DEV_2B16, thus leading it to put out "Synaptics device not found"), or (b) maybe that high-level SETUP simply puts out the misleading "Synaptics device not found" message itself.

I'm baffled Lenovo doesn't know about this problem.

Anyway, as we now know, the user workaround is simply to forget about the failure of the automatic auto-run of the SETUP.EXE, and just go to the correct one-of-three driver installer sub-folder itself and manually run the SETUP.EXE directly from that sub-folder... same as the auto-run high-level SETUP.EXE would have done if the Hardware ID match had been a success to some value in DEV.INI.

Fascinating. I will phone Lenovo support and report this.
My System SpecsSystem Spec
14 May 2014   #20

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Yui the best info that yiu can ifnd is usually through HW Info see my ditty

Using HW Info

DownloadHW Info and pick the right bit version - HWiNFO, HWiNFO32/64 - Download -(copy and paste this site into the search bar) If you do not need the runninginformation in the smaller right hand panel close it. In the left hand windowclick on the + for the individual device groupings and they will open out tothe various components.

Goon opening out further until you get to the device itself. click on it and itwill highlight. In the right hand window there will be a very detaileddescription of that device as in brand, speeds model number etc etc These arevery detailed and are just what is needed for searching for drivers etc.

Seemy pic for an example - in this I have opened out my memory and then highlightedone of the sticks and you can see the detail.

Attached Thumbnails
Friend's new Lenovo Ideapad Z710 refuses to install touchpad driver.-hw-devices-info.png  
My System SpecsSystem Spec

 Friend's new Lenovo Ideapad Z710 refuses to install touchpad driver.

Thread Tools

Similar help and support threads
Thread Forum
Lenovo G780 laptop refuses to accept drivers after a clean install
Hi, I have just run a clean installation for a neighbour on her Lenovo laptop G780. Her original W7Pro 64-bit installed perfectly then I downloaded the audio, graphics and LAN drivers, transferred them to a flash drive which I inserted into the laptop and started to install the drivers. I've...
Lenovo IdeaPad 100 can only go to sleep once
When i close the lid or turn off the laptop the first time, it is fine, and goes to sleep and i can wake it up again. But the second time i do it, the power light stays on and doesn't blink like it shoud, and when i try to awake it, it doesn't wake up, but i still cannot hear the hard drive, the...
General Discussion
Lenovo Ideapad Y560, win 7 64 install problem
Hi allways I got this notofication, No dewice driver where found, make shure that the installation.... About week ago i install from same dvd on brand new ideapad G780 and got same problems, but then I found on lenovo site driver and is worked. I try use that same driver for Y560 and no work....
Installation & Setup
Lenovo IdeaPad S10-3t
My father bought a Lenovo IdeaPad S10-3t. Does anyone know, if the Lenovo IdeaPad S10-3t, can be upgraded from Win 7 Starter, to Win 7 home basic or premium? Any thoughts would be appreciated. Thanks
Hardware & Devices
Hey I was hoping for a little help with a pc issue i have been having lately. In the past month out of nowhere i have been receiving BSOD reading irql less or equal. I'm running 7 on this laptop and have been running the preview since march with zero hardware issues previously. All of my drivers...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:45.
Twitter Facebook Google+