Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Have to keep reinstalling drivers on Win 7 x64

29 May 2014   #1

Have to keep reinstalling drivers on Win 7 x64

Hi all,
I upgraded to Win 7 x64 a few wks past and initially all went well. However, since then, I've discovered that I have to keep reinstalling drivers for all my plug & play hardware. Once I reinstall they work fine for that session, but then on a reboot, I have to once again reinstall. I'm doing so through the device right click/Troubleshoot option.

When I first noticed it on the Kindle I thought it was because it wasn't compatible for x64 or something & indeed the Kindle tech I spoke to stated that, BUT others with the same model as me use theirs on an x64 platform without any diffs.

So I'm really unsure whether it is a compatibility issue etc or something else. For 2 of the devices I downloaded the specific drivers & updated manually, where the other device I let Windows find the driver itself.

Anyone any suggestions either how to check where the problem is coming from or else ideas on how best to fix it?


My System SpecsSystem Spec
02 Jun 2014   #2

Windows 10 Pro

Try this:

USB drive or flash problems? How to cleanup and remove old USB storage drivers - TechSpot Forums

That should resolve any issues you have with usb devices unless it is hardware related.

EDIT: Make sure to run this bat file as an admin. Right click the bat file, run as administrator. Code used for the bat is on the website, and verified by me as being the same when editing the bat file.
My System SpecsSystem Spec
03 Jun 2014   #3


Andrew - thanks SO much for your taking the time to help me out with this. Truly appreciated. . I think it's worked - first time I connected the camera I had the same issue with a missing driver but once I worked through the troubleshooter again, then tried the 2nd time to connect it, it did so perfectly. Will come back to you if anything changes after the next reboot.

Plus you've provided me with another superb source for help in the future. )
My System SpecsSystem Spec

03 Jun 2014   #4

Windows 10 Pro

We are always here for you. Glad you got it resolved!
My System SpecsSystem Spec
09 Jun 2014   #5


Sorry to have to come back on this one but seems the problem was only resolved through one reboot - since then it's continuing to recur. I've repeated the utility steps but still not getting success. Also have a possible driver issue with my keyboard which may or may not be related (mute key won't work).

Just wondering if you've any other thoughts on it? Thanks
My System SpecsSystem Spec
09 Jun 2014   #6

Windows 10 Pro

Please Run sfc /scan now using option 2 in this tutorial: SFC /SCANNOW Command - System File Checker

Please post back the results.
Please indicate what message was displayed at the end:

Windows found no integrity violations


Corrupt files were found, and windows was unable to fix them.


Corrupt files were found, and windows successfully repaired them
My System SpecsSystem Spec
10 Jun 2014   #7

SFC Results

Hi Andrew
Thanks for your continued patience with this issue.

SFC ran ok & stated that: Corrupt files were found, and windows successfully repaired them.

I did Option 3 as well so have the output file if you want it, but there isn't much in it apart from a lot of component verifications & then these last 3 entries:

00000324 [SR] Beginning Verify and Repair transaction
2014-06-10 15:57:29, Info CSI 00000326 [SR] Repairing corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:20{10}]"wmploc.DLL" from store
2014-06-10 15:57:29, Info CSI 00000328 [SR] Repair complete
2014-06-10 15:57:29, Info CSI 00000329 [SR] Committing transaction
2014-06-10 15:57:29, Info CSI 0000032d [SR] Unable to complete Verify and Repair transaction because some of the files that need to be repaired are in use. A reboot is required to complete this operation.
2014-06-10 15:57:29, Info CSI 0000032e [SR] Repairing 1 components
2014-06-10 15:57:29, Info CSI 0000032f [SR] Beginning Verify and Repair transaction
2014-06-10 15:57:30, Info CSI 00000331 [SR] Repairing corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:20{10}]"wmploc.DLL" from store
2014-06-10 15:57:31, Info CSI 00000333 [SR] Repair complete

Rebooted, and re-ran the test and then got the 1st one - no integrity violations.

Sadly still no joy with the drivers issue tho
My System SpecsSystem Spec
10 Jun 2014   #8

Windows 10 Pro

Now that the integrity issues were resolved,

Download the tool to wipe all usb devices and try again.

If you still have issues, it may be hardware related. Do other usb devices have problems?
My System SpecsSystem Spec
10 Jun 2014   #9


I'm beginning to seriously contemplate reinstalling Windows for the heck of it as true enough - this isn't my only current issue with drivers etc. I know it's not the devices as they work fine on Win 7 x32 & Win 8 on other PCs. All the fixes I've been provided thus far for both problems (other relates to keyboard media keys not working) haven't resolved any of the issues, & while they're not major ones, ideally I'd like to get them resolved - hate anything beating me!!!

But I know a reinstall is probably overkill as a possible solution.

I built this PC myself & it's a new (Coolermaster) case & while I don't think I connected anything wrongly I'll doublecheck tomorrow anyway.

But I've connected all USB items to different ports to no avail. About the only ones working appropriately are the scanner & mouse.

Meanwhilie I'll continue to work on both fronts to see if I can twig when/where it all started (tho I think it was only with the switchover to the x64 version - everything was fine on the x32 one).

Thanks again.
My System SpecsSystem Spec

 Have to keep reinstalling drivers on Win 7 x64

Thread Tools

Similar help and support threads
Thread Forum
Drivers can't be installed after reinstalling windows 7.
I've recently reinstalled windows 7 64 bit. The drivers for PCI controller ethernet controller, SM Bus controller, USB controller and an unknown device. PCI Simple communications controller PCI\VEN_8086&DEV_1E3A&SUBSYS_77561462&REV_04 PCI\VEN_8086&DEV_1E3A&SUBSYS_77561462...
Win7 keeps reinstalling USB drivers
Windows 7 Home Premium X64 keeps re-installing the same existing USB drivers every time I plug in an USB device. This means every time I plug in my Wireless mouse, my printer, scanner, external hard drive... and so on I have to wait minutes before I can start using the device. Also, it does not...
Bluetooth Drivers Keep Reinstalling
Not every time but what seems like nearly every time I switch from battery to AC or visa versa the Bluetooth drivers reinstall (about 5 of them) and say "device is ready". The only BT devices I have at the moment are a wireless mouse and a portable printer which I seldom, if ever use BT. Anyway...
Reinstalling Graphics Drivers Problem
Hi A third-party application called Air Display totally ruined my display settings on my switchable graphics card and it's stuck on a basic windows seven look the last time this happened i fixed it by fiddling around with it but this time it wont work is there a way that i can completely...
Graphic Cards
Reinstalling. What drivers do I need?
Hi, I'm new to the forum! I'm reformatting my computer and upgrading it to Windows 7 Home Premium 64-bit from Windows Vista Home Basic 32-bit. I have already done the check to make sure all my hardware is compatible; it is. My question is what drivers do I need exactly? My list so far has:...
How to skip auto-reinstalling of drivers?
New here, Hi guys. :) I recently picked up a pre-built machine that came with W7 (OEM) pre-installed and an Nvidia 8400GS. I replaced the 8400GS with a GTS 250 and figured I'd uninstall the drivers that W7 pulled in through Windows Update, and download the latest Nvidia drivers. I uninstalled...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App

Windows 7 Forums