Drivers for Marvel 91xx Config ATA Device...  

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 24
    Windows 7 Ultimate x64
    Thread Starter
       #11

    Can I switch to AHCI in bios and just reformat again? I don't mind.

    If so how would I do that?

    Also are their any repercussions or risks to changing from IDE to AHCI? I've never done this sort of thing before and am worried ill stuff up my computer further.

    P.S I've already got all my important data backed up on a external.
      My Computer


  2. Posts : 21,007
    Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
       #12

    You just need to folow this tutorial AHCI : Enable in Windows 7 / Vista

    - read it thoroughly first and if not sure posta query in that tutorial.


    I did this on my Sandy Bridge build and I had no problems.

    Repercusssons no mate in fact there are only benefits - but if you are unsure do post in that tutorial.
      My Computer


  3. Posts : 24
    Windows 7 Ultimate x64
    Thread Starter
       #13

    Success!


    Thanks mate, the driver installed this time!

    Will the settings be set to AHCI in the future when I reformat again?

    Also I still don't have the Marvel 91xx driver in my control panel.

    And for some odd reason there are no devices in the "Devices and Printers" tab.
    AND....my secondary hard drive is not showing up in My Computer.

    Aha sorry for being so pesty!, appreciate help so far.
      My Computer


  4. Posts : 21,007
    Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
       #14

    Yes mate it will stay there until or if you reset it back. Look you are not being pesky we are all here to help I am just an average user and there are lot of members who are far better at this than me I just do my best.

    Now lets just run these to eliminate any file problems

    https://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html

    https://www.sevenforums.com/tutorials/433-disk-check.html< if necessary include the /f in thecommand line as per Option2
      My Computer


  5. Posts : 24
    Windows 7 Ultimate x64
    Thread Starter
       #15

    Thanks buddy, I appreciate that, really do :)

    The sfc scannow fixed my devices and printers problem so yey to that 1.

    But I am still missing the driver and my other hard drive is not appearing in my computer.

    With the "Marvel 91xx driver" I went looking for the download from a previous sevenforum post ages ago (i had BSOD issues and that driver fixed it) and only come across these files, don't know what to do with them.
      My Computer


  6. NoN
    Posts : 4,167
    Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
       #16

    Anima said:
    Thanks buddy, I appreciate that, really do :)

    The sfc scannow fixed my devices and printers problem so yey to that 1.

    But I am still missing the driver and my other hard drive is not appearing in my computer.

    With the "Marvel 91xx driver" I went looking for the download from a previous sevenforum post ages ago (i had BSOD issues and that driver fixed it) and only come across these files, don't know what to do with them.
    Those drivers Marvel "mvs91xx.sys" you picked up V1.2.0.1039 are know by having dropped support of some Sata devices.

    I'll pick up Marvell 88SE9xxx Sata 6G Controller drivers 1.2.0.1035 instead for your board. Run the "drvSetup.exe"

    Try HERE if you can find it. The latest one is the V1.2.0.1041 but i'm unsure of the version history.

    In the folder you've got on screenshot is missing the installer "drvSetup.exe". You have the pre-OS F6 "floppy" install.
      My Computer


  7. Posts : 21,007
    Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
       #17

    NoN said:
    Anima said:
    Thanks buddy, I appreciate that, really do :)

    The sfc scannow fixed my devices and printers problem so yey to that 1.

    But I am still missing the driver and my other hard drive is not appearing in my computer.

    With the "Marvel 91xx driver" I went looking for the download from a previous sevenforum post ages ago (i had BSOD issues and that driver fixed it) and only come across these files, don't know what to do with them.
    Those drivers Marvel "mvs91xx.sys" you picked up V1.2.0.1039 are know by having dropped support of some Sata devices.

    I'll pick up Marvell 88SE9xxx Sata 6G Controller drivers 1.2.0.1035 instead for your board. Run the "drvSetup.exe"

    Try HERE if you can find it. The latest one is the V1.2.0.1041 but i'm unsure of the version history.

    In the folder you've got on screenshot is missing the installer "drvSetup.exe". You have the pre-OS F6 "floppy" install.
    Hmm Thanks Non the ones I picked up needed machine numbers which was throwing me a bit i fyou loom at the link I found
      My Computer


  8. Posts : 24
    Windows 7 Ultimate x64
    Thread Starter
       #18

    Victory!


    Thanks for all your help guys, I'm all good now. Learn't quite a bit thanks to you guys. Now I'm on the road to setting up my computer.
    :)
      My Computer


  9. Posts : 21,007
    Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
       #19

    Well if you want to set it up real nice and get a bit more out of the machine try this - I use it on all my machines and fixes:)

    Optimize Windows 7
      My Computer


  10. NoN
    Posts : 4,167
    Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
       #20

    ICit2lol said:
    NoN said:
    Anima said:
    Thanks buddy, I appreciate that, really do :)

    The sfc scannow fixed my devices and printers problem so yey to that 1.

    But I am still missing the driver and my other hard drive is not appearing in my computer.

    With the "Marvel 91xx driver" I went looking for the download from a previous sevenforum post ages ago (i had BSOD issues and that driver fixed it) and only come across these files, don't know what to do with them.
    Those drivers Marvel "mvs91xx.sys" you picked up V1.2.0.1039 are know by having dropped support of some Sata devices.

    I'll pick up Marvell 88SE9xxx Sata 6G Controller drivers 1.2.0.1035 instead for your board. Run the "drvSetup.exe"

    Try HERE if you can find it. The latest one is the V1.2.0.1041 but i'm unsure of the version history.

    In the folder you've got on screenshot is missing the installer "drvSetup.exe". You have the pre-OS F6 "floppy" install.
    Hmm Thanks Non the ones I picked up needed machine numbers which was throwing me a bit i fyou loom at the link I found
    No worries...the Marvel link you provided does mention for the "Yukon" and not the "Magni" drivers. Haven't deeply such on the link but on its first approach it tolds me that. Anyway always good to have an official link somewhere bookmarked!

    @Anima, glad you solved that install.
      My Computer


 
Page 2 of 3 FirstFirst 123 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:32.
Find Us