Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with USB not recognizing anything but disk drives

10 Jul 2014   #1
rjreiffer

Windows 7 Ultimate 64
 
 
Problems with USB not recognizing anything but disk drives

Hello all,

I just ran into a situation that had the following symptoms:
  1. USB Disk drives would install fine
  2. Any other USB device (wireless mouse, scanner, etc) would not install with the error "cannot find the device driver"
  3. The USB core device driver, USB Root driver, USB Composite driver and Generic USB Hub driver all appeared to be working ok
  4. If you went to update the driver for the USB Composite or the USB Hub it would state that it could not find the driver for the device, even though they were installed
So I went through all of the usual troubleshoot procedures, removed the USB core driver, USB Root, USB Composite and Generic USB Hub, restarted and then let the system reinstall. After the reinstall the same symptoms appears. Utilized an open source program called USB Oblivion to wipe ALL USB entries from the registry (USB Oblivion makes a copy of the registry before doing so but if I were you I would also make a recovery point before doing this). Rebooted, everything USB reinstalled just fine but still had the same issue with composite devices.

I was down to the wire with Dell tech support (they even sent someone out to replace the motherboard thinking there might be a problem there) whereby I was going to have to reinstall the complete OS!

So here is how I finally resolved the problem:
  1. I had read about an issue on one of the forums here about the files being in sync between the c:\windows\inf directory and the c:\windows\system32\DRIVERS directory.
  2. I went and found a file that contained the three files (all released at the same time) of usb.inf, usbsys.dll and usbccgp.sys
  3. I then copied them from my source to both the c:\windows\inf and the c:\windows\system32\DRIVERS directory.
  4. I then rebooted my system

After this, everything installed just fine and took care of the issue. I suspect that this same issue could be present if these three files are not from the same release as well (specific version). The final version of the usb.inf, usbccgp.sys and usbhub.sys was 6.1.7601.22526. I hope this method saves somebody a ton of hours! Good luck
Rich


My System SpecsSystem Spec
.
Reply

 Problems with USB not recognizing anything but disk drives




Thread Tools




Similar help and support threads
Thread Forum
Windows Installer not recognizing USB drives
Hello, I posted a topic a few days ago about trying to install Windows 7 Ultimate on my friend's computer, and I kept getting the message that a required CD/DVD Drive device driver was missing, and to load up the media/driver for it. I've tried every troubleshooting method I could find on the...
Installation & Setup
Windows7 Installer not recognizing USB drives
Hello there, first time pc builder and first time posting so please excuse me if some of my questions seem a bit silly. I'am having an issue with my windows 7 installer, displaying "A required CD/DVD driver is missing" when using a USB as a bootable device Things I've tried/noted 1.The...
Installation & Setup
Windows 7 not recognizing Hard disk (Promise 378)
OK, I'm currently using Windows XP Pro 32 bit. I have an Asus A8v-Deluxe mobo. My hard drive is a samsung, SATA. I have it set in my bios to IDE. I go to install Windows 7 Professional, x64. When it gets to the screen where my hard-drives / partitions should be located so I can select...
Installation & Setup
Windows 7 not consistently recognizing optical drives and external HD
Okay I have been having this problem for the past two months or so where my BIOS and/or Windows 7 is only sporadically recognizing my two optical drives and my external HD. I can't seem to find a fix! First, here are my specs: OS: Windows 7 Ultimate x64 CPU: AMD Athlon II X3 445...
Hardware & Devices
Problems Recognizing Enabled Virtualization
I'm having issues with Windows XP Mode recognizing that my virtualization is enabled. I have double checked in BIOS and it is indeed enabled. The application havdetectiontool.exe is not recognizing that it is enabled as well, so I'm a little unsure what the problem is. I'm running Windows 7...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:22.
Twitter Facebook