Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Driver for USB 3.0 PCIe Card

22 Jul 2014   #31

Windows 7 64bit Home Premium SP1

Hello there, I'm a complete newby to formums so apologies in advance if I make a mistake.

I too have exactly the same problem with the 'Dynamode 4-port PCI-Express Card Superspeed USB3.0 plug n paly'. The drivers on the disc supplied did nothing, so I looked at the chip on the card ' VLI VL805-Q6' and did a search which lead me to the VIA website as mentionied in a previous post one this thread, were I downloaded the 2 driver files, VIA_XHCI_Driver_V4.50A_AP.exe & VIA_XHCI_Driver_V4.40D_AP.exe . The card was recognised after installing the V4.40D. exe program from the VIA website but was not running at 'superspeed' transfer rates of 5Gbps more like 50Mbps with a USB 3.0 HDD! However, when I logged off my PC for the night and logged on the next day the 2 HDD drives plugged into the PCI card were not showing, on checking device manager the yellow ! triangle appeared next to the VIA USB 3 root hub again. Anyone help further with this issue? My system is Win7 Home Premium 64bit.
My System SpecsSystem Spec
22 Jul 2014   #32

Windows 7 Home Premium 32-Bit - Build 7600 SP1

If you are referring to the download of the files being extra slow, yea that is right. It took me about an hour to download the file that you are speaking of. The file with the V4.50A in the title is the newer one so use that. You might try uninstalling the V4.40D file. Make sure it is not loaded and try loading the V4.50A. The PCI card is not working is the reason your HDD is not recognized. Plug them in a port from the motherboard until you get the card working. == Let us know your progress.
My System SpecsSystem Spec
22 Jul 2014   #33


I did notice on the download page there were extra files relating to the 05/06 chipset - I know its a pain downloading them from the site - don't recall now what exactly they were for, but they may help.
BTW - an hour for downloading - I WISH !! Took me nearly 36 hours to get 4.5 completed - kept timing out on me and failing.
My System SpecsSystem Spec

27 Aug 2014   #34

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I was having trouble with my startech usb 3.0 pci card. When connecting even a 2.0 thumb drive to the 3.0 port I'd get the message that it could go faster. The drivers on the cd that came with the card were from 2012. I d/l'd the VIA driver mentioned above 4.50 dated 2014. Installed it and now no notification of thumb drives able to go faster.

Though my galaxy S5 still created the alert when connecting to the computer. Found that the S5 defaults to usb 2.0 and you have to tell it to use usb 3.0. by swiping down on the phone screen when it is connected to the computer. A menu is listed with different connections. On mine the bottom one is usb 3.0. Select that and its done. While the phone is in usb 3.0 mode the phone goes into airplane mode. So no texts and such while usb 3.0 is in effect. Also once it has 5 minutes of inactivity the phone goes back to usb 2.0 speeds. Hope this helps.
My System SpecsSystem Spec
23 Oct 2014   #35

Windows 7 Home Premium 64bit

Quote   Quote: Originally Posted by Phone Man View Post
It worked for me too.

Quote   Quote: Originally Posted by dsperber View Post
Finally completed the download of the ZIP file from Taiwan. It unzips to VIA_XHCI_Driver_V4.50A_AP.exe.
And sure enough, that VEN_1106&DEV_3483 is present for XHCI:
Thank you very much for research and proof of correctness of this driver.

If somebody wants to find out, whether this driver is the correct one for him, he can check out this download link on gigabyte site:
GIGABYTE Motherboard GA-970A-DS3P (VIA USB 3.0 Driver)
It's quite outdated though.

It's ridiculously big (100MB) since it contains some weird "control tool" and .net redist, but downloads in minutes. It's a self-extracting archive you can open by 7-zip, and extract just the 14.6MB setup.exe.
My System SpecsSystem Spec
14 Apr 2015   #36

Win7 home premium 32 bit

Just another guy with a Protronix 4 port USB3.0 card looking for the driver after the ones on the mini-CD provided didn't work. Downloaded the latest from the Via site ( as of 4/14/15) and it worked fine. One note: My system drive is I:, and the install failed with a message about an invalid path to C:. I did a "subst c: i:\FakeDriveC" to allow "C:" to resolve, and the install worked. (Didn't leave anything in that directory.)

Just wanted to say thanks to all you folks for providing the legwork that led me to the driver!

I got mine from JacobsParts via Ebay. I posted an offer to the vendor of the board I bought that I'd leave positive feedback if he'd modify his Ebay posting mentioning that the included CD may not contain the correct driver but that it may be downloaded from the Via site <with link>. JacobsParts declined my offer/recommendation, saying if I'd just contacted them they would have provided the driver link.

Anyway, thanks again!
My System SpecsSystem Spec
24 Mar 2016   #37

Windows 7 Ultimate, Windows 8.1 Pro, Linux Mint/Cinnimon (Triple Boot)
Thankyou thankyou thankyou

17 hours later I decided to check out Ye Olde Windows 7 Forums and solved my problem within the hour.

I should have came here first instead of playing Mr.Independent to no avail. For those of us who have USB 3.0 HUBS and card readers running on Win 7 (because we stubbornly hold onto the last real o/s Microsoft ever made) this thread is Priceless. No more ugly yellow triangles in device manager! More importantly, usb 3.0 works front top and back! The wife will be impressed because she won't have to dual boot back to 8.1 to use all the hardware.
My System SpecsSystem Spec
20 Mar 2020   #38

both, 64 and 32, professional

Hi, I decided to refresh the topic. I have a no-name card with the VIA VL805 chipset and the same problems: controller disappearing from CP, ports not working. I searched internet forums. There are different versions of the drivers - unfortunately only by VIA "for Evaluation Board reference only". Some suggest replacing the card firmware. There is also a possible problem with the power supply via the internal Molex connector. And here's my question - in not-working card are there voltages on the outputs or not?
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Generic USB3.0 PCIe card driver
I purchased through eBay a USB 3.0 PCIe card with a generic host card and VIA Labs,inc VL805 chip. The minl CD with driver software was corrupted, so I had to acquire the driver from VIA's website. The driver software installed and the card is functional. However, I'm only seeing about twice USB...
Need driver help for WLAN PCIe Card
I have been noticing some DPC latency spikes that cause my sound make popping sounds. I believe I have narrowed it down to my wireless card being the culprit. Instead of disabling it, I would like to update the driver, but I cant find any driver download from the manufacturer, or dell, or a...
Computer Can't Find A PCIe Device (UAD 2 Quad PCIe Card)
Hello! I have a UAD Quad PCIe card (A card for music making, not a soundcard tho), which my computer can't find. It has a LED light that indictates that it's getting power from the computer and so on. System: Windows 7 32bit Proffesional Motherboard: Asus M4N68T CPU: AMD Phenom 3Ghz (4x)
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:40.
Twitter Facebook