Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sony Vaio Touchpad

02 Jul 2010   #11

Windows 7 Enterprise
Problem with Alps Touchpad Scrolling Capabilities

I am also having problems with the scrolling capabilities on my Alps Touchpad.
I recently did a clean install from Vista Home Premium 32-bit to Windows 7 Ultimate 64-bit. The touchpad was originally listed as PS2 device but I installed a Alps driver for 64 bit systems so now it is registering correctly but I still have no scrolling function.

I tried the solution offered here: but it appears to be for 32-bit system and also did not restore scroll function.

I also tried installing the original drivers in compatibility mode without success.

Any ideas? I'm fresh out.
Other than buying a USB mouse, I can only think to revert back to 32 bit.

Oh, sorry, I have a VGN-FZ4000
Any help much appreciated!

My System SpecsSystem Spec
02 Oct 2010   #12

Windows 7 Ultimate (64-bit)

Hi KingKhan786. I have the same problem with my Sony Vaio VGN-CS36GJ laptop. I tried installing the Synaptics Pointing Driver but this just disables my touchpad. How were you able to resolve this?
My System SpecsSystem Spec
05 Oct 2010   #13

Windows 7

Hi there. Its been a while now but i wrote down some of the steps i had to take to resolve the problem. Here they are:

1. Download all sony drivers for vista
2. Install Vaio Event Service
3. Reboot
4. Install SOny Dll Utilities
5. Reboot
6. Install Sony Shared Library
7. Reboot again. Everything should be working now.
My System SpecsSystem Spec

08 Sep 2011   #14

Windows 7 Ultimate x64

i've just had this issue also, and the quick fix is to install this vista ultimate x64 alps driver from the sony site: View Document

hope this helps others
My System SpecsSystem Spec
06 Nov 2012   #15

Windows 7 Home Premium 64-bit
Sony Vaio Touchpad

Use a mouse to carry out the task.

Start > All Programs > [COLOR=#3485bd !important][COLOR=#3485BD ! important]Vaio[/COLOR][/COLOR] Control Center > Keyboard and Mouse > Pointing Device > Enable > Apply > OK.

I struggled for hours troubleshooting, deleting and reinstalling drivers, 2 System restores,,, oy!!! Until I came across this fix on another forum. Hope this helps any new lost souls along the way.
My System SpecsSystem Spec

 Sony Vaio Touchpad

Thread Tools

Similar help and support threads
Thread Forum
Touchpad not working on Sony Vaio
I believe that I turned it off by mistake... Could anybody give me any ideas about how to turn it on again? I don't realy think that this is a driver problem,the laptop is brand new.
Hardware & Devices
Problem Touchpad Sony Vaio VPCEH18FA
Good afternoon Seven Forum I have a problem with a Pointing Device that does not work I experienced this problem when i restore windows by using the Vaio Care Rescue, Pointing Device I still can be used as the Vaio Care Rescue mode (I also use an external mouse is currently in recovery...
Sony vaio PCG-7183M problem with touchpad
i have a problem with my touch pad and the left and right button, so basically entire mouse is not working. i have tried using the the keyboard to go to control penal and look at the properties of my mouse. (see the attachment please) in the mouse property in the hardware panel there is nothing,...
Sony Vaio VGN-BX665P Touchpad woes and solution
Well like many, sony users, windows 7 is the pits of support from Sony themselves their basic answer is, if you ran the "hardware verification and there is incompatibilities then don't install windows 7 as we wont make new drivers for it" situation: Windows 7 64 Bits, Sony Viao VGN-BX...
Sony Vaio VGN-FZ140 Alps touchpad not working on Win 7
Today I upgraded my Vaio VGN-FZ140 laptop from Vista Home Premium 32-Bit to Windows 7 Home Premium 32-Bit and everything is working great (motioneye camera, physical media controls buttons like vol up/down, etc.) except the Alps touchpad does not work at all. It is not listed in the Device Manager...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App