Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: intel USB 3.0 Driver

19 Sep 2014   #11

windows 7 home 64bit

F7 does seem to be the latest Version ...

The Link below you might find useful .....

GIGABYTE How to Reflash Motherboard BIOS

My System SpecsSystem Spec
19 Sep 2014   #12

Windows 7 Professional (64bit)

ld caught that page before, lm contemplating using @bios tho lm wondering if its ok to do it through safe mode (also l'll do it from the hard drive and not over the internet) but lve heard many say not to use the tool however since l dont have a spare thumb drive (or at least not one l trust) or any cdr's l doubt l could do it using q-flash hell l havent got any floppies either (or a drive to put one in lol).
My System SpecsSystem Spec
19 Sep 2014   #13

Windows 7 Professional (64bit)

just wanted to update, have updated bios to F7 strangely there was some new devices picked up after updating, looked like they were intel based ones (didnt catch what they were as the bubble tips passed to quick).

however there hasnt really been any change to the wireless, its still fluctuation despite excellent signal, so l guess l will be purchasing a new adapter.

l used Q-Flash (was pretty worrying waiting, however l tested the thumb drive on my laptop to make sure there was no corruption etc, tho it would be more apt to call it a microSD to usb converter as it was the only thing l had to hand).

l am curious, is there a place where l can find similar logs to the ones lve linked to:Woke up to BSOD

reason l ask is while those were obtained from a bsod dump l posted it would be interesting to see if l could find out if updating the bios rectified those issues.
My System SpecsSystem Spec

19 Sep 2014   #14

Windows 7 Professional (64bit)

just recieved this

Faulting application name: teracopy.exe, version:, time stamp: 0x52a2ba02
Faulting module name: ntdll.dll, version: 6.1.7601.22436, time stamp: 0x521eaa80
Exception code: 0xc0000005
Fault offset: 0x00032532
Faulting process id: 0x710
Faulting application start time: 0x01cfd4875bf40e52
Faulting application path: C:\Program Files\TeraCopy\teracopy.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: a3d32145-407a-11e4-9b85-c3289d97281b
tho if its related to the program itself lve rolled back to version 2.27 of teracopy which lve had no issues with.

that said could the problem still be related to usb, because so far lve only received this error while copying files onto usb based drives.
My System SpecsSystem Spec
20 Sep 2014   #15

windows 7 home 64bit

I am sure you have tried other Ports ...

And also another Flash Drive ...

If so it does look like Hardware related issue ...

Your BIOS has now changed to UEFI ...

Just wonder where the other Update is ....
My System SpecsSystem Spec
20 Sep 2014   #16

Windows 7 Professional (64bit)

actually my bios from factory settings was UEFI based, the original version was F4 (took a backup before and after the upgrades). did two cold boots to check there was no problems (it still says F7 so l guess things are ok lol).

you are correct in assuming lve tried other drives.. in fact l use two different externals and a thumb drive and lve had teracopy crash using all of them.. however l have downgraded to the version on my laptop will have to see how it goes to if things happen again.

that said lm using the front ports (easier to access), that said my wireless speed issues lve changed from the bottom set of ports to the top (l believe the bottom 6 are usb 3.0 and the top ones are usb 2.0 with the idea they are for keyboards and mice).

as for that F14b bios l was told to update to, it definitely wasnt for my board considering the updates only go up to F7.. however someone did suggest changing to legacy support in bios, l did take a gander for the setting however there seemed to be only one and l couldnt edit it but it stated "partial initial".
My System SpecsSystem Spec
20 Sep 2014   #17

windows 7 home 64bit

Are you still having problems with the USB Ports ...

I have went through your Posts again ...

Do you know which Version of the Chipset Driver you have Installed ? ..

Do you have the Intel Management Engine Installed ?

I wonder how your Ports work with other Devices ?

Still think there could be some thing wrong with the USB 3 Driver ...
My System SpecsSystem Spec
20 Sep 2014   #18

Windows 7 Professional (64bit)

well if it isnt the wireless hardware (my usb dongle being outdated) then the only thing l can assume is that my issues relate to USB drivers.

problem is how l would find out if there are any issues with my usb 3.0 drivers, l was only told based upon a bsod memory dump (which thankfully hasnt happend since l removed the older ram). so l dont know if windows is still picking up problems.

that said l wondered if my teracopy issue was related to the usb problem or it could have just been a bug in the new version (will give it a few weeks with the downgraded version l know has been completely fine on my laptop).

as for the version of the drivers lm using its which according to the motherboard website are the latest drivers (gigabyte said they were the latest as well).

not sure about the intel management engine, it doesnt show up on my start menu.. even ran a search for it so l guess l dont have it installed, but looks like something useful.

as for other devices, l dont seem to have any problems with keyboard/mouse and the sound card that lve noticed.

change that.. just downloaded the install of the intel management engine and it told me that the files on system were newer than the ones from the gigabyte website so l guess l do have it.
My System SpecsSystem Spec
21 Sep 2014   #19

windows 7 home 64bit

I see you have been having problems with your Network ..

Strange how your Lan connection does not work well ...

I think your have to work on each problem one at a time to rule other things out ..

So i suggest we start with your Network ...

I have asked a Network Specialist to have a look at your other Post ..

Maybe you are still thinking about getting a new Adapter ? ....
My System SpecsSystem Spec
21 Sep 2014   #20

Windows 7 Professional (64bit)

there should be nothing wrong with my lan, l just prefer not to use it due to bad past experiences of my system getting fried due to power spikes resulting from the phone line and entering my system through the lan. wireless just removes that possibility.. l may have been extremely unlucky to have had it happen twice, but twice is enough which is why l use wireless.

tho l do plan to get a new wireless adapter so if it is hardware l can rule that out.
My System SpecsSystem Spec

 intel USB 3.0 Driver

Thread Tools

Similar help and support threads
Thread Forum
USB port not working Intel USB3 xhci Driver for Intel® 8/9 Series
Hi, Just wondering if anyone has been having the same issue. Windows 7 x64 series 8 motherboard. ASUS z87-expert. My USB3 and USB2 are not working right after I install the Intel USB3 xhci Driver for Intel® 8/9 Series version I have used the setup.exe to install the driver...
Display driver Intel Graphics Accelerator Driver for Windows XP Stop
I am not sure if this is where it belongs, or if it is a Graphics Card issue. I have an Acer Aspire 7741z-4433 with an Intel(R) Pentium(R) p6200 (2.13 GHz, 3MB 1.3 cache). This only happens to me while I am playing The Sims 3. I have the game set on the lowest quality settings, even though my...
Manufacturer driver or Intel driver for intel hd 3000
Which one would be better? When i try and update via Intel website i get this however. And my score on the windows experience index is only 4.9 for gpu.
Installing DRIVER for my laptop neo b3362, error Intel(R) driver miss
i changed the OS of my laptop from windows7 starter to windows ultimate x64. but i cant connect my laptop to the internet. some drivers are missing. {2 BASE SYSTEM DEVICE DRIVER missing, ETHERNET CONTROLLER DRIVER missing, NETWORK CONTROLLER and VIDEO CONTROLLER DRIVER is also missing.} Can...
Intel Corporation driver update for Intel(R) Management Engine Interfa
helllo I bought a new laptop now and I am not so well with the technology :o so if someone would help me I would be very thankful it says: Intel Corporation driver update for Intel(R) Management Engine Interface so what do I need to do now? thnx a lot
Windows Updates & Activation
Pre-Wddm 1.0 Intel driver 945 Express Driver thru Windows update
Hi, I'm a little confused by one of my update options. I was under the impression that windows 7 was using wddm 1.1, and that the wddm 1.0 drivers have been available for quite some time. I checked and the driver I have is wddm 1.0, released 10/28/2008, version number So why am...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App